Broadcom 4331 is not supported

Bug #912941 reported by Marco Pozzato on 2012-01-06
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
b43-fwcutter (Debian)
Fix Released
Unknown
b43-fwcutter (Ubuntu)
Medium
Daniel T Chen

Bug Description

MacBookPro 8.x (late 2011) have BC 4331 which is supported by latest firmware by Broadcom, but not properly managed by current version of the firmware-b43-installer.

I managed to get it working using the latest driver 5.100.138 and fixing postinst script for firmware-b43-installer

Marco Pozzato (mpodroid) wrote :
Marco Pozzato (mpodroid) wrote :

Succesfully tested on:
* MacBookPro 8.2
* Ubuntu Precise daily 20120103 booted with BIOS emulation

The attachment "fix postinst script to support 4331" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
sarathy (sps-sarathy) wrote :

The firmware works great on my new mac mini ( mid 2011 - no optical drive ). Thanks a ton Marco !!!

Marco Pozzato (mpodroid) wrote :

Just published *.deb packages in my ppa for mactel. You can fix issue from a terminal doing:

sudo apt-add-repository ppa:mpodroid/mactel
sudo apt-get update
sudo apt-get install linux-backports-modules-cw-3.2-3.0.0-14-generic firmware-b43-installer
sudo modprobe b43

Buck Evan (bukzor) wrote :

Marco: Your PPA is the best support for MacbookPro8,2 until they fix this bug.

I don't see a package by that name on your PPA right now. Could you update / fix it for me?

Marco Pozzato (mpodroid) wrote :

Thanks Buck

Di you checked https://launchpad.net/~mpodroid/+archive/mactel/+packages expanding b43-fwcutter?

b43-fwcutter is the name of the source package which has 4 binaries (3 common e 1 specific for 32bit and for 64bit) as reported also at https://launchpad.net/~mpodroid/+archive/mactel/+sourcepub/2169499/+listing-archive-extra

Let me know if this solve your issue

josemanuel (josemanuelqm) wrote :

Dear Marco, after many trials I am not able to apply your solution. I have a macbook pro 15'' of December 2011 (8.2? 8.3?). I feel absolutely frustrated with the broadcom 4331. After several re-installations of ubuntu 12.04 alpha, beta, I just got working (miraculously) the wireless after some patching + update, but it messed up afterwards and I had to reinstall from scratch. No more luck afterwards.

I see linux-backports-modules-cw-3.2-3.0.0-14-generic in one of your subdirectories but I dont know how to load it ( when I try "sudo apt-get install linux-backports-modules-cw-3.2-3.0.0-14-generic" it isn't found)

 I would extramely appreciate any help.

Hi Jose Manuel

Your laptop should be 8.2 (x.3 are 17" models).

I packaged wireless module for Ubuntu 11.10 only. So, try that stable
version

Remember to carry on installation in bios mode, not EFI

Marco
Il giorno 17/mar/2012 09:10, "josemanuel" <email address hidden> ha
scritto:

> Dear Marco, after many trials I am not able to apply your solution. I
> have a macbook pro 15'' of December 2011 (8.2? 8.3?). I feel
> absolutely frustrated with the broadcom 4331. After several re-
> installations of ubuntu 12.04 alpha, beta, I just got working
> (miraculously) the wireless after some patching + update, but it messed
> up afterwards and I had to reinstall from scratch. No more luck
> afterwards.
>
>
> I see linux-backports-modules-cw-3.2-3.0.0-14-generic in one of your
> subdirectories but I dont know how to load it ( when I try "sudo apt-get
> install linux-backports-modules-cw-3.2-3.0.0-14-generic" it isn't found)
>
> I would extramely appreciate any help.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/912941
>
> Title:
> Broadcom 4331 is not supported
>
> Status in “b43-fwcutter” package in Ubuntu:
> New
>
> Bug description:
> MacBookPro 8.x (late 2011) have BC 4331 which is supported by latest
> firmware by Broadcom, but not properly managed by current version of
> the firmware-b43-installer.
>
> I managed to get it working using the latest driver 5.100.138 and
> fixing postinst script for firmware-b43-installer
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/b43-fwcutter/+bug/912941/+subscriptions
>

D (debian-middle-kingdom) wrote :

Hi there,

It looks like the patch downloads the firmware from "www.lwfinger.com/b43-firmware", I'm a bit curious where the firmware comes from and is it trustworthy? (I know that linuxwireless.org does have this link, but still ...)

D.

Marco Pozzato (mpodroid) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in b43-fwcutter (Ubuntu):
status: New → Confirmed

I can confirm that the patch is working fine on my MacBook Pro 8,1 (early 2012) running Ubuntu 12.04. Thanks, Marco.

Robert Pendell (shinji257) wrote :

Thanks Marco Pozzato. The version in your repo got wireless up and running on my Mid-2011 Mac Mini on Linux Mint 13 (ubuntu precise branch). The version in the official repo still doesn't have this patch as of today as I tried it earlier and it was a no go.

Just an FYI though. If you already have kernel 3.2 then linux-backports-modules-cw-3.2-3.0.0-14-generic isn't needed.

shinji@shinji-Macmini ~ $ uname -a
Linux shinji-Macmini 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Ali M (awm086) wrote :

Does this add support to n mode? I have been having problem when trying to connect to certain access point at work. While the wireless card support b/g/n/ when I do iwconfig the out put is always
wlan0 IEEE 802.11b/g ...
I am running ubuntu 12.10.

Changed in b43-fwcutter (Debian):
status: Unknown → New
edvar (edvar-f) wrote :

I can confirm I cannot run wireless N with the patch. Without the patch, wireless doesn't work at all. I'm running ubuntu 12.10 on a macmini 2012.

Also created a thread with some details: http://ubuntuforums.org/showthread.php?t=2095426

Daniel T Chen (crimsun) on 2013-01-23
Changed in b43-fwcutter (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in b43-fwcutter (Debian):
status: New → Fix Released
Ma Hsiao-chun (mahsiaochun) wrote :

Hi, all.

Debian already have an "should work" version in experimental.

I believe that anyone know better than me can do something.

Marco Pozzato, as per https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx your chipset is supported. Could you please advise if this is still an issue for you in a supported release?

Changed in b43-fwcutter (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.