B43 driver - severely reduced range

Bug #205114 reported by mykrob
12
Affects Status Importance Assigned to Milestone
b43-fwcutter (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: b43-fwcutter

Kubuntu Hardy 8.04 Beta installed on Compaq V5204NR

Wifi chipset is Broadcom 4311. While the B43 driver works, the range seems to be severely effected. On version 7.10 using ndiswrapper, I am able to use my laptop throughout my entire house without problems. On 8.04 using B43, i am unable to use the laptop more than about 50 feet from the router. I have two routers side by side, operating on different channels broadcasting different SSID. One doesnt even show up in the next room, the other shows but cant connect.

The problem seems to be isolated to the B43 driver, as it works flawlessly with ndiswrapper.

One more thing, I cannot get ndiswrapper to work properly in 8.04, even after blacklisting B43 and ssb.

-myk

Revision history for this message
Jim Qode (jimqode) wrote :

Confirmed on Dell M1330 with Broadcom BCM4312. Only works when really close to the router.

Changed in b43-fwcutter:
status: New → Confirmed
Revision history for this message
lispy (janietz) wrote :

Same here in DEll D505.

Revision history for this message
Christian Wolf (christianwolf) wrote :

Same here on a HP NX6325 notebook with BCM4310 WLAN device.

De facto not working, even if I increase antenna power of my hot spot to insane levels (WRT 54GL router with DD-WRT).

If this can not be fixed, pls replace it with the old, proprietary firmware until this issue gets fixed as many many notebooks come with a BCM 43xx device and such issues really delay fixing bug #1

Revision history for this message
Christian Wolf (christianwolf) wrote :

With the latest kernel update in Hary (-15) and the new jockey version, my WLAN now is stable again, I have no connection problems for longer distances any more.

However, since I also manually messed around in the settings, one should test this on a clean install to be sure that the issue is really fixed now.

Revision history for this message
notoriousdbp (david-baird-parker) wrote :

Performance with the b43 driver on my Acer with a BCM4318 is terrible. Connection dropping, Internet speed running at about 370kbps when it should be around 1920kbps. I struggle to get to my router's web console too. I really wish I could get ndiswrapper to work again but for some reasons this seems impossible in Hardy. By the way, when I ran Hardy Alpha 6, the B43 driver worked really well.

Revision history for this message
notoriousdbp (david-baird-parker) wrote :

I think the importance of this needs to be raised, I have rolled back to Gutsy until things improve

Revision history for this message
Christian Wolf (christianwolf) wrote :

The bcm43xx-fwcutter package instead the b43-fwcutter will restore the proprietary firmware for you. bcm43xx-fwcutter is in Universe. No need to go back to Gutsy:

aptitude purge b43-fwcutter
aptitude install bcm43xx-fwcutter

should give you the Gutsy feeling :-) You can also try a simple reinstall of b43-fwcutter (purging and installing).

BTW, my problems with the b43 driver are gone - throughput and stability is the same as with the proprietary Broadcom firmware. Notebook is HP NX6325.

Revision history for this message
Przemek K. (azrael) wrote :

Not a fwcutter bug

Changed in b43-fwcutter:
status: Confirmed → Invalid
Changed in linux:
status: Invalid → New
Revision history for this message
Przemek K. (azrael) wrote :

I've had this issue with bcm43xx on Feisty and Gutsy and that's why I'm using ndiswrapper.

Changed in b43-fwcutter:
status: New → Invalid
Revision history for this message
Przemek K. (azrael) wrote :

B43 works fine for me on Hardy.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

From some comments here, it appears that this bug is resolved for Hardy. I'm tentatively marking this "Fix Released" for Hardy. If anyone is still experiencing problems, care to test if this is still an issue with the latest Alpha for the upcoming Intrepid Ibex 8.10 as developers are actively working on this upcoming release. You should be able to test via a LiveCD - http://www.ubuntu.com/testing. Please let us know your results. Also, please change the Status back to "New" if the issues persist. Thanks.

Changed in linux:
status: New → Fix Released
Revision history for this message
Przemek K. (azrael) wrote :

After some time of using B43 I can say that it works for me on Hardy, but it sometimes doesn't see my home network. I have to turn wifi off (hw switch), turn it back on, and wait a moment for it to refresh the available networks. But that might be a separate bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers