restricted manager in hardy fails to install correct firmware b43-fwcutter - solution

Bug #202567 reported by el es on 2008-03-15
20
Affects Status Importance Assigned to Milestone
b43-fwcutter (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Hardy 8.04 latest beta just after upgrade from Gutsy.

The Broadcom firmware is wrong for the used b43 driver.
For Hardy's 2.6.24.x kernel we need to use the 'non-bleeding-edge' firmware.

The solution is here :
http://linuxwireless.org/en/users/Drivers/b43#fw-b43-old

As the b43-fwcutter *from*package* version is correct (011) you don't need to build it again as described.
There is no need to compile anything.

To make the b43 driver running you need to do

export FIRMWARE_INSTALL_DIR="/lib/firmware" # or /lib/firmware/`uname -r`

(FIXME!!! i have actually done it on both paths, don't know where it should really go)

wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2 # <<< the correct tarball !!!
tar xjf broadcom-wl-4.80.53.0.tar.bz2
cd broadcom-wl-4.80.53.0/kmod

# as the b43-fwcutter package is installed, this
sudo b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta.o
has just worked.[1]

I have an Acer 3023WLMi and from the previous Gutsy installation, it has the acer-acpi package.

Whenever you have the sudo fixed, might be that if you do it, your Network Manager daemon will just modprobe the b43 module and everything starts working. If not, a reboot will be needed.

[1] I did it in recovery mode, without sudo, and when leaving it, going into normal X session, the card just started working normally.

el es (el-es-poczta) wrote :

In ubuntu Hardy 8.04 latest beta kernel

description: updated
tatojo (manuel-mlmateos) wrote :

Have a Acer-Ferrari-4000; just update from Gutsy to Hardy. Got b43-fwcutter-011, untar and cd, but make doesn't build b43-fwcutter. The tail is:
fwcutter.c:683: error: ‘stderr’ undeclared (first use in this function)
fwcutter.c:688: warning: implicit declaration of function ‘find_file’
fwcutter.c:688: warning: assignment makes pointer from integer without a cast
fwcutter.c:692: error: ‘const struct file’ has no member named ‘flags’
fwcutter.c:692: error: invalid operands to binary &
fwcutter.c:699: warning: incompatible implicit declaration of built-in function ‘printf’
fwcutter.c:702: warning: implicit declaration of function ‘extract_or_identify’
fwcutter.c:702: error: ‘const struct file’ has no member named ‘flags’
make: *** [fwcutter.o] Error 1
root@ferrari:~/b43-fwcutter-011#

Are everybody able to make b43-fwcutter in hardy?
Thanks
Manuel

el es (el-es-poczta) wrote :

tatojo: Don't build a new fwcutter - the one from Hardy is OK
Whenever you have the distupgrade ready, the b43-fwcutter package is installed (at least it was on my Acer 3023WLMi)

It is enough to just run it as I stated above. (by means it worked for me OK)

The problem is only I don't know exactly where the firmware should be extracted - so I did the above both for /lib/firmware and /lib/firmware/`uname -r`.

Ah. One thing : use the 2.6.24 kernel that comes with hardy. b43 is only there.

(it was frankly the reason I went on to Hardy instead of staying with Gutsy)

description: updated
el es (el-es-poczta) on 2008-03-19
description: updated
Gert Kulyk (gkulyk) wrote :

I do not understand your complain - what exactly do you think the hardy-package is doing wrong?

The script that is (or at least: should be) called at post-install stage is /usr/share/b43-fwcutter/install_bcm43xx_firmware.sh

If you look at the code, the mentioned script is downloading (and extracting) the v3 files for b43legacy and the mentioned 4.80.53.0.tar.bz2 for use with b43 in 2.6.24. So what's wrong with that in your opinion?

el es (el-es-poczta) wrote :

@Gert Kulyk :
I don't know what went wrong when I did the dist-upgrade from Gutsy (7.10) - the fact was, the b43 driver complained about wrong firmware installed.
To be specific, after the dist-upgrade I ran into another problem (with something overwriting my hosts file (or so) and sudo could not resolve the hostname) - that I fixed later - might that be related ?

Because of the sudo problem I had to do it as described in recovery root console (i.e. no sudo involved) but when finished cutting and left that one and went on to a normal X login, the card just started working as it should be.

My complaint (well, that's a big word really) was, that it wasn't automatic enough ;)

Currently, I've got 2 theorem :
- some problem in the script you've mentioned (will check when I have the chance to look at it)
or
- sudo problem

el es (el-es-poczta) wrote :

@Gert : (side note)
I know the dangers of using 'beta' software ;) don't worry, I wish to help to improve, that's it :) If I didn't want it, I wouldn't be going to Hardy beta :)

Download full text (4.6 KiB)

You are right el es!
I just ran, from directory
/root/broadcom-wl-4.80.53.0/kmod
The command
sudo /usr/bin/b43-fwcutter -w /lib/firmware wl_apsta.o
and worked fine.
This message is wireless going with the new b43 driver in a bcm4318 [Air
Force One 54g] 802.11g in a Acer-Ferrari-4000, Hardy-server-86_64.
Manuel

el es wrote:
> tatojo: Don't build a new fwcutter - the one from Hardy is OK
> Whenever you have the distupgrade ready, the b43-fwcutter package is installed (at least it was on my Acer 3023WLMi)
>
> It is enough to just run it as I stated above. (by means it worked for
> me OK)
>
> The problem is only I don't know exactly where the firmware should be
> extracted - so I did the above both for /lib/firmware and
> /lib/firmware/`uname -r`.
>
> Ah. One thing : use the 2.6.24 kernel that comes with hardy. b43 is only
> there.
>
> (it was frankly the reason I went on to Hardy instead of staying with
> Gutsy)
>
> ** Description changed:
>
> Ubuntu Hardy 8.04 latest beta just after upgrade from Gutsy.
>
> The Broadcom firmware is wrong for the used b43 driver.
>
> http://linuxwireless.org/en/users/Drivers/b43#fw-b43-old
>
> - As the b43-fwcutter version is correct (011)
> + As the b43-fwcutter *package* version is correct (011) you don't need to
> + build it again!
>
> To make the b43 driver running you need to do
>
> - export FIRMWARE_INSTALL_DIR="/lib/firmware" # or
> - /lib/firmware/$kernel_version
> + export FIRMWARE_INSTALL_DIR="/lib/firmware" # or /lib/firmware/`uname
> + -r`
>
> (i have actually done it on both paths, don't know where it should
> really go)
>
> wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2 # <<< the correct tarball !!!
> tar xjf broadcom-wl-4.80.53.0.tar.bz2
> cd broadcom-wl-4.80.53.0/kmod
>
> # as the b43-fwcutter package is installed, this
> - b43-fwcutter-011/b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta.o
> + b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta.o
> + has just worked.
>
> - I have an Acer 3023WLMi and from the previous Gutsy installation, it has the acer-acpi package.
> - I do it in recovery mode, and when leaving it, going into normal X session, the card just starts working normally.
> + I have an Acer 3023WLMi and from the previous Gutsy installation, it has
> + the acer-acpi package.
>
> - (in recovery mode, because I need to fix the sudo, but that is a topic
> - for different bug actually...)
> + Whenever you have the sudo fixed, might be that if you do it, your
> + Network Manager daemon will just modprobe the b43 module and everything
> + starts working. If not, a reboot will be needed.
> +
> + I did it in recovery mode, and when leaving it, going into normal X
> + session, the card just started working normally.
>
> ** Description changed:
>
> Ubuntu Hardy 8.04 latest beta just after upgrade from Gutsy.
>
> The Broadcom firmware is wrong for the used b43 driver.
> + For Hardy's 2.6.24.x kernel we need to use the 'non-bleeding-edge' firmware.
>
> + The solution is here :
> http://linuxwireless.org/en/users/Drivers/b43#fw-b43-old
>
> - As the b43-fwcutter *package* version is correct (011) you don't nee...

Read more...

phil_tank (phil-tank) wrote :

I am having similar problems, though mine is a bit strange. I have followed the instructions above and manually installed the b43-fwcutter package. I have then downloaded the wl_apsta.o firmware and issued the command to install the firmware (fwiw, I used /lib/firmware, not /lib/firmware/uname -r). The driver loads and my card can see networks. When I try to connect, it seems to crash my router. I am posting this from my work laptop, and when I attempt to connect, the connection drops on this machine. dmesg shows my card authenticating with the access point but association times out.

I have tried the neighbour's wifi as well but the same results (though I don't know if their access point falls over). Incidentally, while I have been able to connect with this setup using Gutsy, I would experience intermittent wireless failures. It seemed to occur in a random fashion (it would stay up for weeks, then fall over frequently over a weekend or something) so I assumed it was my provider or the access point, though I'm not so sure anymore.

My wireless card has a BCM4306 chip

gnome29 (kerdudo) wrote :

I have an acer 5024WLMi laptop. It's a BCM4318 wireless card.
As el es, before Hardy, I used acer_acpi module and BCM43xx driver or ndiswrapper (for few networks).
But now in Hardy, if I understand, the driver is b43 (kernel 2.6.24) and acer_acpi is enabled by default in hardy and also in the new kernel 2.6.25.
No need build modules any more. :)

So, I tried LiveCD Hardy beta, but the wireless led didn't blink. The acer_acpi module was enabled and /proc/acpi/acer/wireless was 1.
So, I tried to install the new b43 firmware by b43-fwcutter and reloaded acer_acpi module.
Now, it's works. ;)
I'm very glad for acer_acpi module embedded in hardy.
I waiting for the release now and hope b43 firmware problem will be fix before.

@el es : Thanks for your solution
and obviously ubuntu developers for yours amazing jobs.

Tom Adams (holizz) on 2008-03-25
Changed in b43-fwcutter:
status: New → Confirmed
David Terei (davidterei) wrote :

Thank you!

I finally have wireless again and working great. Dell XPS M1530 Laptop, Broadcom BCM4312 rev01.

delaneya (antony-delaney) wrote :

i could not get my broadcom wirelss working. it was showing in the hardware devices as in use, but wireless

i ran /usr/share/b43-fwcutter/install_bcm43xx_firmware.sh manually and my wirelss is now working

el es (el-es-poczta) wrote :

delaneya:
Yes, this works too (ran this and didn't break my wireless, so it is working)
one remark : I used this with sudo.

sudo /usr/share/b43-fwcutter/install_bcm43xx_firmware.sh

Pat Double (patdouble) wrote :

I can confirm on installing Hardy Beta from CD, running all updates, then using Hardware Drivers to enable b43, the wireless is recognized but no access points are found. Running manually:

sudo /usr/share/b43-fwcutter/install_bcm43xx_firmware.sh

fixes the problem.

delaneya (antony-delaney) wrote :

Does anyone know if this has been fixed in the release?

jepeuxlavoir (jepeuxlavoir) wrote :

I just upgraded from 7.10. The driver's not listed in Hardware Drivers -- in 7.10 it (and my modem) were there, now there's nothing. the interface was not listed under ifconfig.

After upgrading I was getting an error from b43legacy-phy0 in /var/log/syslog telling me to follow the instructions at http://linuxwireless.org/en/users/Drivers/b43#devicefirmware to update my firmware. this I did, but when I tried to make b43-fwcutter i got a load of compile errors. I installed the b43-fwcutter package, and told it to download & install the drivers. The message in /var/log/syslog persisted. I noticed that it installed firmware version 4; for my chipset it's using the b43legacy module and so (according to linuxwireless.org) needs the version 3 firmware.

I followed the rest of the instructions on the linuxwireless.org site for b43legacy, using the b43-fwcutter installed by the package, restarted networking, and now everything works okay. The driver still doesn't show up in Hardware Drivers; neither does anything else.

so no, i guess it hasn't been fixed, at least not for those who use the b43legacy module

i am having the same issue with the rc which is updated with all the latest pkgs. it says with a dmesg that the the firm ware either was not found or load failed and it gives me a link to where i can download the firmware and what version i should get.

Dara Adib (daradib) wrote :

This bug is fixed on the release as the b43-fwcutter package in Ubuntu 8.04 (1:011-1) uses the correct binary tarball (4.80.53.0). However, the update will not fix the problem for people who have upgraded from betas; they must run install_bcm43xx_firmware.sh manually after updating.

Dara Adib (daradib) wrote :

fixed by b43-fwcutter (1:011-1) unstable; urgency=low

Changed in b43-fwcutter:
status: Confirmed → Fix Released
Rekster (derek-vaxxine) wrote :

I have an Acer Ferrari 4000. I installed Hardy and it complained about
the firmware on the Broadcom chip so I followed the link and updated it.

Ok, so now wireless works fine in Ubuntu, but when I boot into Windows
the wireless is broken, it will see networks but when u try to connect to
one with WPA it will not connect and with WEP it connects but you cannot
ping or do anything. I even reformatted/reinstalled, same problems..

I know this is now a problem with Windows, not Ubuntu BUT by following the
firmware instructions as per Ubuntu my wireless is messed up now and will
not function in Windows. The worst part is I want to sell my laptop and now
I cant sell it with broken wireless.

HELP!!!!!! I'm worried updating the firmware has busted my laptop now
and Acer wont help.

How do I get my old firmware back and WHY did I have to
update it in the first place since wireless worked FINE on a previous Ubuntu
version.

VERY FRUSTRATED

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers