/usr/share/glib-2.0/schemas/org.ayatana.indicator.datetime.gschema.xml:4:1 Error on line 4 char 1: <enum id='time-enum'> already specified. This entire file has been ignored.

Bug #1893028 reported by Norbert
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Indicator
Fix Released
Unknown
ayatana-indicator-datetime (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Have Ubuntu MATE 20.10 installed
2. Upgrade or install some package which have glib triggers

Expected result:
* no error messages in APT/dpkg output

Actual result:

```
Processing triggers for libglib2.0-0:amd64 (2.64.4-1) ...
/usr/share/glib-2.0/schemas/org.ayatana.indicator.datetime.gschema.xml:4:1 Error on line 4 char 1: <enum id='time-enum'> already specified. This entire file has been ignored.

```

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: ayatana-indicator-datetime 0.8.0-1
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu44
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: MATE
Date: Wed Aug 26 13:32:05 2020
SourcePackage: ayatana-indicator-datetime
UpgradeStatus: Upgraded to groovy on 2020-08-25 (0 days ago)

Revision history for this message
Norbert (nrbrtx) wrote :
Changed in ayatana-indicator:
status: Unknown → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ayatana-indicator-datetime (Ubuntu):
status: New → Confirmed
Revision history for this message
Sai Vinoba (saivinob) wrote :

I see this error message when trying to reinstall 'ayatana-indicator-datetime' package.

I tried reinstallation of 'ayatana-indicator-datetime' because the latest package would not show date in the panel. Ref https://bugs.launchpad.net/ubuntu/+source/ayatana-indicator-datetime/+bug/1893244.

Revision history for this message
Sai Vinoba (saivinob) wrote :

For the 'ayatana-indicator-datetime' package, the issue resolved (no more schema error as above) after removing 'indicator-datetime' package. Possible conflicts.

Changed in ayatana-indicator:
status: New → Fix Released
Revision history for this message
Bill (franksmcb) (franksmcb) wrote :

This issue is still occurring for a a user upgrading to Ubuntu MATE 20.10.
Panel will not show clock after upgrade.

As suggested in post #4 doing an apt remove ayatana-indicator will resolve this issue

Norbert (nrbrtx)
Changed in ayatana-indicator-datetime (Ubuntu):
status: Confirmed → Fix Released
tags: removed: groovy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.