AWSCLI doesn't support S3 in eu-central-1

Bug #1566352 reported by psl
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
awscli (Ubuntu)
Fix Released
Undecided
Unassigned
Xenial
Fix Released
Undecided
Unassigned
Yakkety
Fix Released
Undecided
Unassigned

Bug Description

Ubuntu 14.04.4
awscli 1.2.9-2

AWS S3 in EU (eu-central-1) changed authorization method to AWS4-HMAC-SHA256. This is not supported in awscli 1.2.9-2. Such S3 bucket cannot be used with awscli. Authorization method AWS4-HMAC-SHA256 is used in all new AWS regions. This problem is addresses in newer awscli release.

HOW to test it:

$ aws s3 ls s3://some-eu-central-1-bucket

A client error (InvalidRequest) occurred when calling the ListObjects operation: The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256.

INFO:
http://docs.aws.amazon.com/AmazonS3/latest/API/sig-v4-authenticating-requests.html

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in awscli (Ubuntu):
status: New → Confirmed
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello psl, or anyone else affected,

Accepted awscli into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/awscli/1.11.13-1~16.10.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in awscli (Ubuntu):
status: Confirmed → Fix Released
Changed in awscli (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Changed in awscli (Ubuntu Xenial):
status: New → Fix Committed
Revision history for this message
Adam Conrad (adconrad) wrote :

Hello psl, or anyone else affected,

Accepted awscli into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/awscli/1.11.13-1~16.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Kamal Mostafa (kamalmostafa) wrote :

Verified fixed by awscli (1.11.13-1~16.04.0) and python-botocore (1.4.70-1~16.04.0), and their 16.10 equivalents.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awscli - 1.11.13-1~16.04.0

---------------
awscli (1.11.13-1~16.04.0) xenial; urgency=medium

  * No-change backport to Xenial:
    - This awscli update is required to support the Amazon EC2 "Elastic
      Network Adapter" ('ENA') driver (LP: #1642730)
    - Fix "AWSCLI doesn't support S3 in eu-central-1" (LP: #1566352)

awscli (1.11.13-1) unstable; urgency=medium

  * New upstream version 1.11.13 (Closes: #819451)
  * debian/patches: Refresh patches.

awscli (1.11.7-2) unstable; urgency=medium

  * debian/control: add python3-s3tranfert to B-D. (Closes: #841064)

awscli (1.11.7-1) unstable; urgency=medium

  * debian/control: Update Vcs-* to new git repository.
  * New upstream version 1.11.7

awscli (1.11.2-1) unstable; urgency=medium

  * New upstream release
  * Bump Standards-Version to 3.9.8
  * debian/rules: Change to library style layout.
  * debian/links: link from doc direcotory.
  * debian/control: Move to under DPMT.

 -- Kamal Mostafa <email address hidden> Tue, 22 Nov 2016 14:33:43 -0800

Changed in awscli (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of the Stable Release Update for awscli has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awscli - 1.11.13-1~16.10.0

---------------
awscli (1.11.13-1~16.10.0) yakkety; urgency=medium

  * No-change backport to Yakkety:
    - This awscli update is required to support the Amazon EC2 "Elastic
      Network Adapter" ('ENA') driver (LP: #1642730)
    - Fix "AWSCLI doesn't support S3 in eu-central-1" (LP: #1566352)

awscli (1.11.13-1) unstable; urgency=medium

  * New upstream version 1.11.13 (Closes: #819451)
  * debian/patches: Refresh patches.

awscli (1.11.7-2) unstable; urgency=medium

  * debian/control: add python3-s3tranfert to B-D. (Closes: #841064)

awscli (1.11.7-1) unstable; urgency=medium

  * debian/control: Update Vcs-* to new git repository.
  * New upstream version 1.11.7

awscli (1.11.2-1) unstable; urgency=medium

  * New upstream release
  * Bump Standards-Version to 3.9.8
  * debian/rules: Change to library style layout.
  * debian/links: link from doc direcotory.
  * debian/control: Move to under DPMT.

 -- Kamal Mostafa <email address hidden> Tue, 22 Nov 2016 14:33:43 -0800

Changed in awscli (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers