comics.py crashed with KeyError in on_feed_updated()

Bug #356334 reported by Andy Duffell on 2009-04-06
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
Gabor Karsay
awn-extras (Ubuntu)
Medium
Julien Lavergne

Bug Description

Random crash, was not interacting directly with applet at the time. Applet is set to get the feeds from XKCD and Cyanide and Happiness, but comics were not maximised at the time.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/avant-window-navigator/applets/comics/comics.py
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: awn-applets-python-core 0.3.2.1-0ubuntu2
PackageArchitecture: all
ProcCmdline: python /usr/share/avant-window-navigator/applets/comics/comics.py --uid=1238589205 --window=67108919 --orient=0 --height=48
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/avant-window-navigator/applets/comics/comics.py', '--uid=1238589205', '--window=67108919', '--orient=0', '--height=48']
SourcePackage: awn-extras-applets
Title: comics.py crashed with KeyError in on_feed_updated()
Uname: Linux 2.6.28-11-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape vboxusers video

 Traceback (most recent call last):
   File "/usr/share/avant-window-navigator/applets/comics/comics_view.py", line 579, in on_feed_updated
     self.select_item(feed.items[feed.newest])
 KeyError: 1238976000.0

Related branches

Andy Duffell (andy-duffell) wrote :
tags: removed: need-duplicate-check
Julien Lavergne (gilir) wrote :

Thanks for your bug report, forwarded upstream.

visibility: private → public
Mark Lee (malept) on 2009-05-06
tags: added: applet comics
m0m0 (a0005783) wrote :

just had the same crash on amd64 ubuntu 9.10 beta; I was not interacting with the program or anything, I just suddenly realised the crash icon. Trying to recreate it failed though.

Julien Lavergne (gilir) wrote :

Thank you for your bug report.

Do you still have this problem with the 0.4.0 rc1 version of Awn and Awn-extras ?

You can obtain this version by one of the following ways :
- Using Ubuntu 10.04 (Lucid) up-to-date.
- Using the Awn-testing PPA (https://launchpad.net/~awn-testing/+archive/ppa) and installing avant-window-navigator-trunk.
- Using Ubuntu 9.10 (Karmic) and my PPA (https://launchpad.net/~gilir/+archive/backports/+packages)

Thanks in advance for your cooperation and understanding.

Changed in awn-extras-applets (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium

I stopped using it, but activated though (because of this email) and it
seems that Daily Dilbert is working
but if I open penuts and wizard of iz dont work

Julien Lavergne wrote:
> Thank you for your bug report.
>
> Do you still have this problem with the 0.4.0 rc1 version of Awn and
> Awn-extras ?
>
> You can obtain this version by one of the following ways :
> - Using Ubuntu 10.04 (Lucid) up-to-date.
> - Using the Awn-testing PPA (https://launchpad.net/~awn-testing/+archive/ppa) and installing avant-window-navigator-trunk.
> - Using Ubuntu 9.10 (Karmic) and my PPA (https://launchpad.net/~gilir/+archive/backports/+packages)
>
> Thanks in advance for your cooperation and understanding.
>
> ** Changed in: awn-extras-applets (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: awn-extras-applets (Ubuntu)
> Importance: Undecided => Medium
>
>

Julien Lavergne (gilir) on 2010-08-26
Changed in awn-extras-applets (Ubuntu):
status: Incomplete → Confirmed
Gabor Karsay (gabor-karsay) wrote :

Just happened to me while interacting with the Mail applet. Started Awn, Mail applet logs in (Gmail account), hovered mouse over Mail applet and Comics! showed that backtrace. It didn't crash always, maybe every 10th time or so. After repeating that procedure several times, the complete dock crashed with this backtrace:

Exception in thread Thread-3 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
  File "/usr/lib/python2.6/threading.py", line 484, in run
  File "/usr/local/lib/python2.6/dist-packages/awn/extras/threadqueue.py", line 64, in run
  File "/usr/local/share/avant-window-navigator/applets/feeds/feeds.py", line 1277, in get_data
<class '__main__.NetworkException'>: Couldn't fetch file

onox (onox) on 2010-09-18
description: updated
tags: added: traceback
Changed in awn-extras:
status: New → Confirmed
Gabor Karsay (gabor-karsay) wrote :

Fix committed in rev. 1494.

Changed in awn-extras:
assignee: nobody → Gabor Karsay (gabor-karsay)
importance: Undecided → Medium
milestone: none → 0.4.2
status: Confirmed → Fix Committed
Julien Lavergne (gilir) on 2011-01-11
affects: awn-extras-applets (Ubuntu) → awn-extras (Ubuntu)
Julien Lavergne (gilir) on 2011-02-21
Changed in awn-extras (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awn-extras - 0.4.1~bzr1507-0ubuntu1

---------------
awn-extras (0.4.1~bzr1507-0ubuntu1) natty; urgency=low

  * New upstream snapshot.
   - comics applet crashed with KeyError in on_feed_updated() (LP: #356334)
   - feeds applet crashed with GError in show_notification() (LP: #618830)
   - media control crashed with KeyError in get_media_info() (LP: #693829)
  * debian/control:
   - Fix duplicate short description for weather applet.
 -- Julien Lavergne <email address hidden> Tue, 22 Feb 2011 01:53:31 +0100

Changed in awn-extras (Ubuntu):
status: In Progress → Fix Released
Povilas Kanapickas (p12) on 2013-11-17
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers