New upstream snapshot (r1372) FFe

Bug #626265 reported by Julien Lavergne on 2010-08-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
awn-extras-applets (Ubuntu)
Wishlist
Unassigned

Bug Description

I would like to update awn-extras to revision 1372. I request a Feature Freeze exception.

It introduces 2 main features that will be nice to have in maverick :
- Support for hosting indicator applets (like gnome-panel).
- Support for a Zeitgeist applet

Others changes are bug fixes, translation updates, and some minor adjustments on applets.

Also, as the 2 features are on separate applets, so the risk for users are only if they activate the applets. It should be safe for others, they will only have the bug fixes and the translations updates.

Applets have been tested under maverick, with no problems. Also, there are tested upstream by daily build : https://launchpad.net/~awn-testing/+archive/ppa

Bzr log since 0.4.0 release is included.

Testing packages are available in my PPA : https://launchpad.net/~gilir/+archive/unstable/+packages?field.name_filter=&field.status_filter=published&field.series_filter=maverick

Changelog entry :
 awn-extras-applets (0.4.0+bzr1372-0ubuntu1) maverick; urgency=low
 .
   * Sync with Debian
   * New upstream snapshot (LP: #626265)
    - YAMA: use lda instead of xdg for managing desktop files (LP: #497787)
    - Volume: fix crash on high volume value. (LP: #461123)
    - Weather: fix crash on activate_map_cb (LP: #581414)
    - File-browser-launcher: fix crash on mounting LUKS partition (LP: #532848)
    - Feeds: fix crash when getting favicon (LP: #561611)
    - Slickswitcher: Fix division by 0 (LP: #562548)
   * debian/control:
    - Build-depends on libindicator-dev (>= 0.3).
    - Build-depends on libzeitgeist-dev (>= 0.2.2).
    - Recommends python-gtop | python-gnome2-desktop for bandwidth-monitor.
    - Update description for new applets.
   * debian/rules:
    - Pass --with-indicator to enable indicator applet.
    - Remove schemas for desactivated applets.
    - Disable mount applet.
   * debian/awn-applets-c-core.install:
    - Install indicator applet.
    - Install related applet.
   * debian/awn-applets-python-core:
    - Disable mount applet.

Julien Lavergne (gilir) wrote :

Changes since 0.4.0 release.

description: updated
Julien Lavergne (gilir) on 2010-08-29
description: updated
description: updated
Julien Lavergne (gilir) on 2010-08-29
description: updated
Changed in awn-extras-applets (Ubuntu):
importance: Undecided → Wishlist
Scott Kitterman (kitterman) wrote :

Ack. Approved.

Changed in awn-extras-applets (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir) wrote :

Thanks Scott, uploaded.

Changed in awn-extras-applets (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package awn-extras-applets - 0.4.0+bzr1372-0ubuntu1

---------------
awn-extras-applets (0.4.0+bzr1372-0ubuntu1) maverick; urgency=low

  * Sync with Debian
  * New upstream snapshot (LP: #626265)
   - YAMA: use lda instead of xdg for managing desktop files (LP: #497787)
   - Volume: fix crash on high volume value. (LP: #461123)
   - Weather: fix crash on activate_map_cb (LP: #581414)
   - File-browser-launcher: fix crash on mounting LUKS partition (LP: #532848)
   - Feeds: fix crash when getting favicon (LP: #561611)
   - Slickswitcher: Fix division by 0 (LP: #562548)
  * debian/control:
   - Build-depends on libindicator-dev (>= 0.3).
   - Build-depends on libzeitgeist-dev (>= 0.2.2).
   - Recommends python-gtop | python-gnome2-desktop for bandwidth-monitor.
   - Update description for new applets.
  * debian/rules:
   - Pass --with-indicator to enable indicator applet.
   - Remove schemas for desactivated applets.
   - Disable mount applet.
  * debian/awn-applets-c-core.install:
   - Install indicator applet.
   - Install related applet.
  * debian/awn-applets-python-core:
   - Disable mount applet.

awn-extras-applets (0.4.0-3) unstable; urgency=low

  * debian/control:
   - Add depends on python-awn-extras (>= 0.4.0) for all python applets.
     Closes: #589317
   - Fix wrong description for awn-applets-common. Closes: #587632
   - Recommend python-pyinotify for thinkhdaps applet.
   - Use Breaks instead of Replaces and Conflicts when moving files between
     packages to conform to Standards-Version 3.9.0.
   - Bump Standards-Version to 3.9.0.
   - Fix Conflicts for python-awn-extras.
   - Improve short descriptions.
  * debian/pyversions: Build only for python >= 2.5. Thanks Jakub Wilk for the
    patch. Closes: #587964
  * debian/copyright: Remove mention of BSD license in
    /usr/share/common-licenses to conform to Standards-Version 3.9.0.

awn-extras-applets (0.4.0-2) unstable; urgency=medium

  * Urgency set to medium to close RC bug.
  * debian/control:
   - Add Conflicts/Replaces between python-awn-extras and python-awnlib, all
     files from python-awnlib was moved into python-awn-extras.
     (Closes: #586744).

awn-extras-applets (0.4.0-1) unstable; urgency=low

  * New upstream release.
   - Catch error in weather applet (LP: #359668)
   - Stack applet close on click (LP: #261520)
   - Close cairo-menu after a click (LP: #511256)
   - Fix crash of awn-system-monitor (LP: #545164)
   - Fix crash when removing a volume >1 or adding volume >1 or using prefs
     while > 1 volumes is present (LP: #556175)
   - Fix crash of media-control when Rhythmbox quit (LP: #558463)
   - Fix crash of file-browser-launcher when there is no .gtk-bookmarks
     (LP: #551119)
  * Update applets location:
   - Plugger, Filebrowser, Trasher, DesktopManager, Lastfm, Meebo, Digg, Pynot,
     RTM applets removed.
   - Sysmon, Bandwidth-monitor, Dialect, Hardware sensors, YAMA, Slickswitcher
     applets added
   - Separator applet move to Awn package.
   - Trash applet replaced by Garbage applet.
   - Arss applet replaced by Feeds applet.
   - Showdesktop applet move from python-core to c-core.
   - Digital Clock applet mov...

Read more...

Changed in awn-extras-applets (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers