slickswitcher.py crashed with ZeroDivisionError in get_windows()

Bug #562548 reported by Dario on 2010-04-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
Matt
awn-extras-applets (Ubuntu)
Medium
Julien Lavergne

Bug Description

.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: awn-applets-python-extras 0.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Tue Apr 13 22:31:17 2010
ExecutablePath: /usr/share/avant-window-navigator/applets/slickswitcher/slickswitcher.py
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/share/avant-window-navigator/applets/slickswitcher/slickswitcher.py --uid=1271099549 --window=29360176 --panel-id=1
ProcEnviron:
 LANG=pl_PL.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/avant-window-navigator/applets/slickswitcher/slickswitcher.py', '--uid=1271099549', '--window=29360176', '--panel-id=1']
SourcePackage: awn-extras-applets
Title: slickswitcher.py crashed with ZeroDivisionError in get_windows()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Traceback (most recent call last):
  File "/usr/share/avant-window-navigator/applets/slickswitcher/switch.py", line 52, in emitted
    func()
  File "/usr/share/avant-window-navigator/applets/slickswitcher/slickswitcher.py", line 208, in update_icon
    self.icon.update(force)
  File "/usr/share/avant-window-navigator/applets/slickswitcher/drawing.py", line 475, in update
    self.draw_windows()
  File "/usr/share/avant-window-navigator/applets/slickswitcher/drawing.py", line 747, in draw_windows
    windows = switch.get_windows(self.number - 1)
  File "/usr/share/avant-window-navigator/applets/slickswitcher/switch.py", line 170, in get_windows
    current_row = int((current_workspace-1) / float(num_columns)) + 1
ZeroDivisionError: float division

Dario (dario84) wrote :
visibility: private → public
Julien Lavergne (gilir) wrote :

Thanks for your bug report. Could you please descripte what did you do before the crash of the applet ?

Changed in awn-extras-applets (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
tags: removed: need-duplicate-check
Dario (dario84) wrote :

The problem is that I really don't know exactly what have I done.
I was running the game Glest. After I had exit the game the problem have happened.
I were using two monitors with two separate displays. The display on my second monitor had reset with unoptimal resolution.
I don't know if it could help you but that's all I had noticed.

Dario (dario84) on 2010-04-14
Changed in awn-extras-applets (Ubuntu):
status: Incomplete → New
Julien Lavergne (gilir) wrote :

Thanks for the answer, it seems to be relative to the number of displays.
Forwarded upstream.

Changed in awn-extras-applets (Ubuntu):
status: New → Triaged
Matt (mjz) on 2010-04-17
Changed in awn-extras:
assignee: nobody → Matt (sharkbaitbobby)
Michal Hruby (mhr3) on 2010-05-23
Changed in awn-extras:
milestone: none → 0.4.2
status: New → Confirmed
Matt (mjz) wrote :

This has been fixed in r1310. Thank you for your bug report.

Changed in awn-extras:
status: Confirmed → Fix Committed
Julien Lavergne (gilir) on 2010-08-26
Changed in awn-extras-applets (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package awn-extras-applets - 0.4.0+bzr1372-0ubuntu1

---------------
awn-extras-applets (0.4.0+bzr1372-0ubuntu1) maverick; urgency=low

  * Sync with Debian
  * New upstream snapshot (LP: #626265)
   - YAMA: use lda instead of xdg for managing desktop files (LP: #497787)
   - Volume: fix crash on high volume value. (LP: #461123)
   - Weather: fix crash on activate_map_cb (LP: #581414)
   - File-browser-launcher: fix crash on mounting LUKS partition (LP: #532848)
   - Feeds: fix crash when getting favicon (LP: #561611)
   - Slickswitcher: Fix division by 0 (LP: #562548)
  * debian/control:
   - Build-depends on libindicator-dev (>= 0.3).
   - Build-depends on libzeitgeist-dev (>= 0.2.2).
   - Recommends python-gtop | python-gnome2-desktop for bandwidth-monitor.
   - Update description for new applets.
  * debian/rules:
   - Pass --with-indicator to enable indicator applet.
   - Remove schemas for desactivated applets.
   - Disable mount applet.
  * debian/awn-applets-c-core.install:
   - Install indicator applet.
   - Install related applet.
  * debian/awn-applets-python-core:
   - Disable mount applet.

awn-extras-applets (0.4.0-3) unstable; urgency=low

  * debian/control:
   - Add depends on python-awn-extras (>= 0.4.0) for all python applets.
     Closes: #589317
   - Fix wrong description for awn-applets-common. Closes: #587632
   - Recommend python-pyinotify for thinkhdaps applet.
   - Use Breaks instead of Replaces and Conflicts when moving files between
     packages to conform to Standards-Version 3.9.0.
   - Bump Standards-Version to 3.9.0.
   - Fix Conflicts for python-awn-extras.
   - Improve short descriptions.
  * debian/pyversions: Build only for python >= 2.5. Thanks Jakub Wilk for the
    patch. Closes: #587964
  * debian/copyright: Remove mention of BSD license in
    /usr/share/common-licenses to conform to Standards-Version 3.9.0.

awn-extras-applets (0.4.0-2) unstable; urgency=medium

  * Urgency set to medium to close RC bug.
  * debian/control:
   - Add Conflicts/Replaces between python-awn-extras and python-awnlib, all
     files from python-awnlib was moved into python-awn-extras.
     (Closes: #586744).

awn-extras-applets (0.4.0-1) unstable; urgency=low

  * New upstream release.
   - Catch error in weather applet (LP: #359668)
   - Stack applet close on click (LP: #261520)
   - Close cairo-menu after a click (LP: #511256)
   - Fix crash of awn-system-monitor (LP: #545164)
   - Fix crash when removing a volume >1 or adding volume >1 or using prefs
     while > 1 volumes is present (LP: #556175)
   - Fix crash of media-control when Rhythmbox quit (LP: #558463)
   - Fix crash of file-browser-launcher when there is no .gtk-bookmarks
     (LP: #551119)
  * Update applets location:
   - Plugger, Filebrowser, Trasher, DesktopManager, Lastfm, Meebo, Digg, Pynot,
     RTM applets removed.
   - Sysmon, Bandwidth-monitor, Dialect, Hardware sensors, YAMA, Slickswitcher
     applets added
   - Separator applet move to Awn package.
   - Trash applet replaced by Garbage applet.
   - Arss applet replaced by Feeds applet.
   - Showdesktop applet move from python-core to c-core.
   - Digital Clock applet mov...

Read more...

Changed in awn-extras-applets (Ubuntu):
status: In Progress → Fix Released
onox (onox) on 2010-10-03
description: updated
tags: added: slickswitcher traceback
Changed in awn-extras:
importance: Undecided → Medium
Povilas Kanapickas (p12) on 2013-11-17
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.