mail.py crashed with NameError in on_toggle()

Bug #557410 reported by Riccardo Ancona on 2010-04-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Awn Extras
Medium
onox
awn-extras-applets (Ubuntu)
Medium
Julien Lavergne

Bug Description

I was trying to get new IMAP emails from the Mail Applet of the AWN dockbar, then the error came out.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: awn-applets-python-core 0.4.0~rc1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Apr 7 18:06:13 2010
ExecutablePath: /usr/share/avant-window-navigator/applets/mail/mail.py
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/share/avant-window-navigator/applets/mail/mail.py --uid=1270656335 --window=31507793 --panel-id=1
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/avant-window-navigator/applets/mail/mail.py', '--uid=1270656335', '--window=31507793', '--panel-id=1']
SourcePackage: awn-extras-applets
Title: mail.py crashed with NameError in on_toggle()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

 Traceback (most recent call last):
   File "/usr/share/avant-window-navigator/applets/mail/mail.py", line 876, in on_toggle
     boxE.set_sensitive(allE.get_active())
 NameError: free variable 'boxE' referenced before assignment in enclosing scope

tags: removed: need-duplicate-check
Julien Lavergne (gilir) wrote :

Thank you for your bug report. Forwaded upstream.

Changed in awn-extras-applets (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
visibility: private → public
Changed in awn-extras-applets (Ubuntu):
assignee: nobody → Grega Podlesek (muscardinus)
Julien Lavergne (gilir) on 2010-04-11
Changed in awn-extras:
assignee: nobody → Grega Podlesek (muscardinus)
Changed in awn-extras-applets (Ubuntu):
assignee: Grega Podlesek (muscardinus) → nobody
tags: added: applet mail
Changed in awn-extras:
assignee: Grega Podlesek (muscardinus) → Gabor Karsay (gabor-karsay)
Gabor Karsay (gabor-karsay) wrote :

I can't reproduce this. Do you remember what you did exactly that led to this crash? Does it happen all the time and can you reproduce it? Do you still have such crashes?

onox (onox) on 2010-09-18
description: updated
tags: added: traceback
onox (onox) wrote :

Fixed in revision 1404. Also improved the UI a bit.

Changed in awn-extras:
assignee: Gabor Karsay (gabor-karsay) → onox (onox)
importance: Undecided → Medium
milestone: none → 0.4.2
status: New → Fix Committed
Julien Lavergne (gilir) on 2010-09-21
Changed in awn-extras-applets (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Julien Lavergne (gilir)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awn-extras-applets - 0.4.0+bzr1372-0ubuntu3

---------------
awn-extras-applets (0.4.0+bzr1372-0ubuntu3) maverick; urgency=low

  * debian/control:
   - Build-depends on libindicator-dev (>= 0.3.14) to rebuild on lastest
     libindicator. (LP: #637692).
  * debian/patches/901-cairo-menu-fix-d-and-d.patch:
   - From upstream, fix drag and drop in cairo-menu. (LP: #568700)
  * debian/patches/902-mail-fix-pop-backend.patch:
   - From upstream, fix POP3 backend in mail applet (LP: #561919)
  * debian/patches/903-mail-fix-io-error.patch:
   - From upstream, unlock keyring on startup in mail applet (LP: #581075)
  * debian/patches/904-mail-fix-crash-on-toggle.patch
   - From upstream, Fix crash on_toggle() in mail applet (LP: #557410)
  * debian/patches/905-yama-fix-crash-nonetype.patch
   - From upstream, fix NoneType crash in YAMA applet (LP: #506847)
  * debian/patches/906-mail-desktop-icon.patch
   - From upstream, fix icon in desktop file of mail applet.
 -- Julien Lavergne <email address hidden> Fri, 24 Sep 2010 16:04:00 +0200

Changed in awn-extras-applets (Ubuntu):
status: In Progress → Fix Released
Povilas Kanapickas (p12) on 2013-11-17
Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers