stacks_applet.py crashed with AttributeError in on_ok_button_clicked()

Bug #359097 reported by Wouter de Groot on 2009-04-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Awn Extras
Undecided
Unassigned
awn-extras-applets (Ubuntu)
Medium
Unassigned

Bug Description

Was adjusting the stack layout to curved GUI and clicked ok. Dialog did not do anything, until the crash notification popped up.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/avant-window-navigator/applets/stacks/stacks_applet.py
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: fglrx
Package: awn-applets-python-core 0.3.2.1-0ubuntu2
PackageArchitecture: all
ProcCmdline: python /usr/share/avant-window-navigator/applets/stacks/stacks_applet.py --uid=1239373315 --window=56641237 --orient=0 --height=41
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/avant-window-navigator/applets/stacks/stacks_applet.py', '--uid=1239373315', '--window=56641237', '--orient=0', '--height=41']
SourcePackage: awn-extras-applets
Title: stacks_applet.py crashed with AttributeError in on_ok_button_clicked()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/avant-window-navigator/applets/stacks/stacks_config.py", line 365, in on_ok_button_clicked
     cols = self.widgets['cols_entry'].get_text()
 AttributeError: 'StacksConfig' object has no attribute 'widgets'
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Wouter de Groot (donteatcheese) wrote :
tags: removed: need-duplicate-check
Julien Lavergne (gilir) wrote :

Thanks for your bug report.
Forwarded upstream.

visibility: private → public
Mark Lee (malept) on 2009-04-11
tags: added: applet stacks
Julien Lavergne (gilir) wrote :

Thank you for your bug report.

Do you still have this problem with the 0.4.0 rc1 version of Awn and Awn-extras ?

You can obtain this version by one of the following ways :
- Using Ubuntu 10.04 (Lucid) up-to-date.
- Using the Awn-testing PPA (https://launchpad.net/~awn-testing/+archive/ppa) and installing avant-window-navigator-trunk.
- Using Ubuntu 9.10 (Karmic) and my PPA (https://launchpad.net/~gilir/+archive/backports/+packages)

Thanks in advance for your cooperation and understanding.

Changed in awn-extras-applets (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium

On Sun, Apr 11, 2010 at 4:25 PM, Julien Lavergne
<email address hidden>wrote:

> Do you still have this problem with the 0.4.0 rc1 version of Awn and
> Awn-extras ?
>

It does not look like it. Changing the GUI now seems to work fine.

Julien Lavergne (gilir) wrote :

Thanks for the feedback, I'm closing this bug.

Changed in awn-extras-applets (Ubuntu):
status: Incomplete → Fix Released
Changed in awn-extras:
status: New → Fix Committed
Michal Hruby (mhr3) on 2010-04-12
Changed in awn-extras:
status: Fix Committed → Fix Released
milestone: none → 0.4.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers