Ubuntu

awesome install does not create desktop listing in GDM/LightDM

Reported by John Turek on 2012-12-31
188
This bug affects 41 people
Affects Status Importance Assigned to Milestone
awesome (Debian)
Confirmed
Unknown
awesome (Fedora)
Unknown
Unknown
awesome (Ubuntu)
High
Unassigned
Nominated for Saucy by Adam Gandelman
Nominated for Trusty by Adam Gandelman

Bug Description

When installing awesome, it does not create an entry to launch the window manager from GDM or LightDM or KDM

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: awesome 3.4.14-1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
Date: Mon Dec 31 00:08:37 2012
InstallationDate: Installed on 2012-12-28 (3 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64+mac (20120926)
MarkForUpload: True
SourcePackage: awesome
UpgradeStatus: Upgraded to raring on 2012-12-28 (2 days ago)

John Turek (john-turek) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in awesome (Ubuntu):
status: New → Confirmed
Kevin Jadin (marcspitz) wrote :

I recently updated to raring, and came accross a problem while trying to use Awesome-wm.

Awesome doesn't seem to be registered in "gnome-session" which I believe has become the standard way of launching a session.

I therefore tried adding some files in order for awesome to be shown in lightdm, but it doesn't work.
The two files which I have been working on are attached to this post.

/usr/share/xsessions/awesome.desktop
/usr/share/gnome-session/sessions/awesome.session

Unfortunately, this does not work..

gregor herrmann (gregoa) wrote :

Reported and apparently fixed upstream:
https://awesome.naquadah.org/bugs/index.php?do=details&task_id=1031

gregor

Kevin Jadin (marcspitz) wrote :

@gregor

I regret but this is not the same bug. The bug you mentionned is about Awesome showing in the applications menus of other WM.

This specific bug is about :
1) awesome not showing in lightdm/gdm
2) not starting even with the modified desktop and session files I provided..

I don't know how to fix this, what has changed since 12.10..

On Mon, 04 Mar 2013 16:48:56 -0000, Kevin Jadin wrote:

> I regret but this is not the same bug. The bug you mentionned is about
> Awesome showing in the applications menus of other WM.

Not only; it's referred to from
http://bugs.debian.org/701514 ("Awesome doesn't display on GDM")
and mentions
https://bugzilla.redhat.com/show_bug.cgi?id=901434 ("awesome not
listed in X sessions") but reading through the bug log it seems it's
still not fixed, sorry for that assumption.

> I don't know how to fix this, what has changed since 12.10..

Sorry, me neither, just thought I'd provide some further pointers.

Cheers,
gregor

--
 .''`. Homepage: http://info.comodo.priv.at/ - OpenPGP key 0xBB3A68018649AA06
 : :' : Debian GNU/Linux user, admin, and developer - http://www.debian.org/
 `. `' Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe
   `- NP: Judy Collins: Send In The Clowns

Changed in awesome (Debian):
status: Unknown → Confirmed
Bartlomiej Skwira (e1eetu5er) wrote :

+1

Hairong Zhu (hrzhu) wrote :

The bug still exists in Xubuntu 13.04 release. And I can confirm that delete `NoDisplay=true' in /usr/share/xsessions/awesome.desktop solves the problem.

Lemon (leeway1985) wrote :

+1 the gnome version of ubuntu 13.04 release also have this issue.

Bartlomiej Skwira (e1eetu5er) wrote :

Deleting NoDisplay=true also worked for me, thanks Hairong Zhu!

James Crowther (j1aks) wrote :

just tried this in Ubuntu 13.4 (x64) and I can confirm that just changing `NoDisplay=true' to `NoDisplay=false' in '/usr/share/xsessions/awesome.desktop' is sufficient to make it show up in the window manager list on the login screen.

+1,
13.4 x64 Unity GDM.
Deleting NoDisplay=true worked for me

Aryo Adhi (aryo-adhi) wrote :

Solved, by changing string `NoDisplay=true` to `NoDisplay=false`. Running 13.04 x64, standard LightDM.

Achim Behrens (k1l) wrote :

Still happening in 13.10.
the fix is to change `NoDisplay=true` to `NoDisplay=false` in /usr/share/xsessions/awesome.desktop as mentioned above and on some blogs. this should be easily fixed, imho

Jack-Benny Persson (jackbenny) wrote :

Confirmed, it worked by changing NoDisplay to false in /usr/share/xsessions/awesome.desktop

Changed in awesome (Ubuntu):
importance: Undecided → High
Janus (reslayer-mail) wrote :

In 13.10 NoDisplay to false fixes the problem too. And still.

CheolHan Yoon (mait) wrote :

+1 "In 13.10 NoDisplay to false fixes the problem too. And still."

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awesome - 3.4.15-1ubuntu1

---------------
awesome (3.4.15-1ubuntu1) trusty; urgency=low

  * debian/patches/remove-nodisplay-from-desktop-file.patch: Removes
    problematic "NoDisplay=true" from desktop file. Cherry picked from
    upstream (LP: #1094811)
 -- Adam Gandelman <email address hidden> Wed, 22 Jan 2014 00:19:01 -0800

Changed in awesome (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.