Broken argument parser

Bug #68483 reported by Taupter on 2006-10-26
10
Affects Status Importance Assigned to Milestone
awesfx (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: awesfx

When I try to load a soundfont (.sf2) with either asfxload or sfxload (from package awesfx, in both Kubuntu 6.06 i386 and 6.10 i386) using an extra argument, like

asfxload -V 100 /home/taupter/8mbgmsfx.sf2

or a similar construction with other valid arguments as defined by the "--help" if fails, in this case complaining about an unrecognized option "-V" and "Could not find SoundFont 100".

I downloaded the awesfx-0.5.0d.tar.gz and compiled it. When I run the aforementioned command using the newly generated binary it recognizes the syntax perfectly and acts accordingly, setting the SoundFont volume to 100% and loading the /home/taupter/8mbgmsfx.sf2.

Lionel Le Folgoc (mrpouit) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in awesfx:
status: New → Incomplete
Taupter (taupter) on 2007-09-05
Changed in awesfx:
status: Incomplete → New
Taupter (taupter) wrote :

Dear Lionel,

The problem seems to be fixed in Gutsy Gibbon. Thanks to the maintainer who fixed it upstream. I cannot tell you if the problem persists in 6.06 LTS, 6.10 and 7.04, as I am not using these versions anymore. Maybe it should be verified at least for 6.06 LTS, but I have no resources to do it myself.
Bug #85192 is a duplicate of this bug. Maybe the newest one must be closed.

Thank you

Cláudio

Lionel Le Folgoc (mrpouit) wrote :

Thanks for your fast response.

I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Gutsy Gibbon.

If someone needs a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at [WWW] https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in awesfx:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers