avra doesn't work with supplied *.inc files

Bug #681491 reported by Dave Webb on 2010-11-25
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
avra (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: avra

1)
# lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10

2)
# apt-cache policy avra
avra:
  Installed: 1.2.3a-1
  Candidate: 1.2.3a-1
  Version table:
 *** 1.2.3a-1 0
        500 http://vesta.informatik.rwth-aachen.de/ftp/pub/comp/Linux/ubuntu/ubuntu/ maverick/universe amd64 Packages
        100 /var/lib/dpkg/status

3)
assembling shipped *.inc files without errors.

4)
According [1] Avra is supplied with *.inc files for different AVRs, e.g. /usr/share/avra/m8def.inc

Putting

   .include "m8def.inc"

into test.asm and running

# avra -I /usr/share/avra test.asm

produces errors. No file is assembled:

Output
> Pass 1...
> /usr/share/avra/m8def.inc(40) : Error : Unknown mnemonic/macro: #ifndef
> /usr/share/avra/m8def.inc(41) : Error : Unknown mnemonic/macro: #define
> /usr/share/avra/m8def.inc(44) : Error : Unknown mnemonic/macro: #pragma

Please ship include files with avra which work with avra.
The include files are assembler version 2 whereas avra does only understand version 1 files.

Thanks a lot!

[1] http://packages.ubuntu.com/en/maverick/amd64/avra/filelist

Hello, Dave Webb.

I've just solved the same incompatibility using an instruction I found here (in Russian): http://src.lgg.ru/2011/03/avra_first/

The attachment "Only for the m8def.inc file: Just comment all the # out." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in avra (Ubuntu):
status: New → Confirmed
KoRnKloWn (kornklown) wrote :

Honestly guys, it's kind of rediculous that 3 years after the bug report, it's still here. Avra is not compatible with avr assembler 2 include files, so why are they still shipped with avra??? If you manually get all the include files from version 1, and overwrite the ones that ship with avra, then it works fine. And by the way, it's not just the m8def.inc file, it's also m16def.inc, which that's where I ran into the problem myself.

Avra should be compatible with all the include files that ship with it.

KoRnKloWn (kornklown) wrote :

In case you don't believe me, here's the output when including m16def.inc:

/usr/share/avra/m16def.inc(40) : Error : Unknown mnemonic/macro: #ifndef
/usr/share/avra/m16def.inc(41) : Error : Unknown mnemonic/macro: #define
/usr/share/avra/m16def.inc(44) : Error : Unknown mnemonic/macro: #pragma
/usr/share/avra/m16def.inc(48) : Error : Unknown mnemonic/macro: #pragma
/usr/share/avra/m16def.inc(53) : Error : Unknown mnemonic/macro: #pragma
/usr/share/avra/m16def.inc(534) : Error : Line to long
/usr/share/avra/m16def.inc: No such file or directory

Now if I replace it with the one from version 1, it assembles fine with no errors

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avra - 1.3.0-2

---------------
avra (1.3.0-2) unstable; urgency=low

  * Update standards version to 3.9.6
  * Lintian override license-problem-undefined-license for files containing
    interface definitions.
  * Use proper function return types (closes: #749604)
  * LP: #681491 was fixed in upstream version 1.3.0

 -- Milan Kupcevic <email address hidden> Sat, 29 Nov 2014 21:35:16 -0500

Changed in avra (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers