avidemux version 1:2.5.4-0ubuntu6 failed to build on i386

Bug #766017 reported by Matthias Klose on 2011-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Avidemux
New
Undecided
Unassigned
Gentoo Linux
Fix Released
Medium
avidemux (Ubuntu)
High
Alessio Treglia

Bug Description

avidemux version 1:2.5.4-0ubuntu6 failed to build on i386
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2446031

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2446031/+files/buildlog_ubuntu-natty-i386.avidemux_1%3A2.5.4-0ubuntu6_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 7098 lines into the build log:

[ 83%] Building CXX object avidemux/ADM_UIs/ADM_QT4/src/CMakeFiles/ADM_UIQT4.dir/T_configMenu.cpp.o
/build/buildd/avidemux-2.5.4/avidemux/ADM_UIs/ADM_QT4/src/T_configMenu.cpp: In member function 'void ADM_Qt4Factory::ADM_QconfigMenu::saveAsClicked(bool)':
/build/buildd/avidemux-2.5.4/avidemux/ADM_UIs/ADM_QT4/src/T_configMenu.cpp:213:69: error: taking address of temporary [-fpermissive]
/build/buildd/avidemux-2.5.4/avidemux/ADM_UIs/ADM_QT4/src/T_configMenu.cpp: In member function 'virtual void ADM_Qt4Factory::diaElemConfigMenu::updateMe()':
/build/buildd/avidemux-2.5.4/avidemux/ADM_UIs/ADM_QT4/src/T_configMenu.cpp:319:54: error: taking address of temporary [-fpermissive]
/build/buildd/avidemux-2.5.4/avidemux/ADM_UIs/ADM_QT4/src/T_configMenu.cpp: In member function 'virtual void ADM_Qt4Factory::diaElemConfigMenu::finalize()':
/build/buildd/avidemux-2.5.4/avidemux/ADM_UIs/ADM_QT4/src/T_configMenu.cpp:359:54: error: taking address of temporary [-fpermissive]
make[3]: *** [avidemux/ADM_UIs/ADM_QT4/src/CMakeFiles/ADM_UIQT4.dir/T_configMenu.cpp.o] Error 1
make[3]: Leaving directory `/build/buildd/avidemux-2.5.4/build'
make[2]: *** [avidemux/ADM_UIs/ADM_QT4/src/CMakeFiles/ADM_UIQT4.dir/all] Error 2
make[2]: Leaving directory `/build/buildd/avidemux-2.5.4/build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/avidemux-2.5.4/build'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110419-0221
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/avidemux-2.5.4

Related branches

I tried to compile media-video/avidemux-2.5.4-r2, but the compile phase always fails. I have been able to patch the problem successfully. GCC 4.6 is stricter than previous versions and avidemux code triggers some spots where some particular code semantics is not allowed by the standard.

Reproducible: Always

Steps to Reproduce:
1. emerge -1 gcc:4.6
2. use it as default compiler
3. emerge -1 avidemux
Actual Results:
Avidemux fails to compile.

Expected Results:
Avidemux should compile fine.

I'm on ~amd64 but I guess the compile errors should show up on any architecture when using GCC 4.6. The errors arise because GCC 4.6 is stricter than previous versions about code semantics. I tried with and without graphite flags (whole world was recompiled), and all of the available versions in portage. I have tried also the SVN ebuild from multimedia overlay but it still fails in the same spots.
The three attached patches resolve the problems and allow avidemux to compile fine. I've tested the avidemux GUI interface which is the affected part and it works ok.
It should not introduce errors with previous GCC versions since the patch is cosmetic only (I've been unable to test with GCC<4.6).
I guess this should also be filed upstream.
Thanks.

Created attachment 270363
Patch for QT4 "Open file" GUI

Created attachment 270365
Patch for x264 "Preset" GUI

Created attachment 270367
Patch for xvid "Preset" GUI

Please post the patch upstream.

(In reply to comment #4)
> Please post the patch upstream.

Done.
According to the thread on the forums the patches for qt4 and x264 interfaces have already been coded upstream.
I linked this bug and asked to pull the xvid one if it is still missing.

http://avidemux.org/admForum/viewtopic.php?pid=50437#p50437

(In reply to comment #5)
> (In reply to comment #4)
> > Please post the patch upstream.
>
> Done.
> According to the thread on the forums the patches for qt4 and x264 interfaces
> have already been coded upstream.
> I linked this bug and asked to pull the xvid one if it is still missing.
>
> http://avidemux.org/admForum/viewtopic.php?pid=50437#p50437

Thanks, I modified the URL field accordingly. Let's wait until upstream acknowledges/commits your patch.

Matthias Klose (doko) on 2011-04-19
Changed in avidemux (Ubuntu):
importance: Undecided → High

Created attachment 270721
avidemux-2.5.4-r2.ebuild

Attached a working ebuild. Download all 3 patches and place in files directory. Indeed patches work.

*** Bug 364029 has been marked as a duplicate of this bug. ***

(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Please post the patch upstream.
> >
> > Done.
> > According to the thread on the forums the patches for qt4 and x264 interfaces
> > have already been coded upstream.
> > I linked this bug and asked to pull the xvid one if it is still missing.
> >
> > http://avidemux.org/admForum/viewtopic.php?pid=50437#p50437
>
> Thanks, I modified the URL field accordingly. Let's wait until upstream
> acknowledges/commits your patch.

The upstream url seems broken or there is something wrong with their website. I will wait a little bit longer for their reply before I commit your patches

Their forum changed URL ( http://avidemux.org/smf/index.php ). Can you post the new URL of your thread

The thread was not mine, it was opened by a Fedora developer.
Avidemux.org have migrated their forums and it seems that the thread were this issue was being discussed has been lost in the transition.
However, by cloning the svn, I can confirm that the qt4_ui and x264_ui patches have been applied, while the xvid_ui one has not.
I re-opened the thread on the forums under the same name and asked to pull the Xvid patch. The URL field has been modified accordingly.

s/thread were this/thread where this/

  29 Apr 2011; Markos Chandras <email address hidden> avidemux-2.5.4-r2.ebuild,
  +files/avidemux-2.5.4-openfileqt.patch,
  +files/avidemux-2.5.4-x264-build115.patch, +files/avidemux-2.5.4-x264.patch,
  +files/avidemux-2.5.4-xvid.patch:
  Add gcc-4.6 patches thanks to Fabio Scaccabarozzi <email address hidden>. Add
  patch for latest x264 thanks to zimous <email address hidden>. Bugs #364009 and
  #365153

Fixed. Thanks :)

Alessio Treglia (quadrispro) wrote :
Changed in avidemux (Ubuntu):
status: New → In Progress
assignee: nobody → Alessio Treglia (quadrispro)
Changed in gentoo:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.4-0ubuntu7

---------------
avidemux (1:2.5.4-0ubuntu7) oneiric; urgency=low

  * Add patch to fix audio in avidemux2_qt4 (LP: #774912).
  * Add patch to fix FTBFS with GCC4.6 (LP: #766017).
  * Bump Standards.
 -- Alessio Treglia <email address hidden> Thu, 12 May 2011 11:36:01 +0200

Changed in avidemux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.