Crash using flv as output (with mp3 audio codec)

Bug #481561 reported by fred lonauer on 2009-11-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Avidemux
Fix Released
Undecided
Unassigned
avidemux (Ubuntu)
Medium
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: avidemux

1) Ubuntu 9.10
2) 2.5.1+repack-0ubuntu2
3) Convert a mov-file to flv-format.
4) Crash! A window opens and report ... see attachment. Worked fine in avidemux version that came with 9.04! When audio is mp3(lame) and format is flv it crashes. When you use avi as container instead, it works fine.

Related branches

fred lonauer (sumperer) wrote :
Deje (deje07) wrote :

I can confirm, the same happens with me. The avidemux error message is the same.

i have the same problem in Karmic Koala (worked fine on Jaunty)

Assert failed :!currentEncoder
 at line 284, file /build/buildd/avidemux-2.5.1+repack/avidemux/ADM_audiofilter/audio_encoderPlugin.cpp/usr/lib/libADM_core.so(ADM_backTrack+0x6d) [0xc7392d]
avidemux2_gtk(_Z25audioFilter_getOuputCodecv+0x2e) [0x80a552e]
avidemux2_gtk(_Z9oplug_flvPKc+0x3e5) [0x80dbab5]
avidemux2_gtk(_Z6A_SavePKc+0x3a0) [0x809ed30]
avidemux2_gtk(_Z13A_SaveWrapperPc+0x13) [0x8097483]
/usr/lib/libADM_coreUI.so(_Z17FileSel_ReadWritePFvPKcEiS0_S0_+0x77) [0x3d4da7]
avidemux2_gtk [0x81ac8a2]
/usr/lib/libADM_coreUI.so(_Z16GUI_FileSelWritePKcPFvS0_E+0x2c) [0x3d526c]
avidemux2_gtk(_Z12HandleAction6Action+0x1694) [0x809c6d4]
avidemux2_gtk(_Z11guiCallbackP12_GtkMenuItemPv+0x20) [0x81b1950]
/usr/lib/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0x7c) [0x6ec9fc]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x1b2) [0x6df072]
/usr/lib/libgobject-2.0.so.0 [0x6f47a8]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7bd) [0x6f5b2d]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_by_name+0x192) [0x6f5e42]
/usr/

Sergio Zanchetta (primes2h) wrote :

Mark it as confirmed because other people have this issue, even a friend of mine.

Changed in avidemux (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Sergio Zanchetta (primes2h) wrote :

Crashes using .wmv as input as well.

Sergio Zanchetta (primes2h) wrote :

Upstream link:
http://avidemux.org/admForum/viewtopic.php?id=6991
(LP doesn't accept avidemux forum as bug tracker (obviously)).

Changed in avidemux (Ubuntu):
status: Confirmed → Triaged
summary: - crash when audio is mp3(lame)
+ Crash using flv as output (with mp3 audio codec)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.2~rc-0ubuntu1

---------------
avidemux (1:2.5.2~rc-0ubuntu1) lucid; urgency=low

  * 2.5.2 release candidate; taken from upstream's SVN
    (tag avidemux_2.5.2rc, revision #5655):
    - Re-enabled Vorbis decoder (regression introduced 2.5.0)
    - Updated the FFmpeg libraries
    - Added support for latest x264 core and updated Qt interface
    - Added support for H264 video, VP6A video and AAC audio in FLV
      container
    - Added support for SEDG and WMVA four CCs
    - Various fixes related to Xvid settings
    - Fixed Xvid stat files remaining locked after encoding (regression
      introduced 2.5.0)
    - Improved MKV demuxer
    - New Colour Curve Editor plugin for Qt interface
    - Fixed partial filter support (regression introduced 2.5.0)
    - Fixed FluxSmooth filter plugin (regression introduced 2.5.0)
    - Added extra bitrate settings for LAME audio encoder
    - Enabled JACK audio device plugin (regression introduced 2.5.0)
    - Various GUI fixes for GTK+ and Qt interface
    - Fixed command-line interface support for various video filters
    - Changed "save-jpg" parameter of command-line interface to honour
      "begin" parameter
    - Fixed saving of crash file when Avidemux unexpectedly quits (regression
      introduced in 2.5.0)
    - Fixed GUI quirks when using Copy mode and AVI un/packing
    - Proper channel mapping for multichannel DTS & Vorbis files
    - Proper decoding of 5.1 vorbis file in mkv
    - Fixes bugs:
      - LP: #481561
  * debian/rules: Update ffmpeg tarballs' filenames.
  * Drop 01-build_vorbis_decoder.diff patch.
  * Refresh 02-alsa_output.diff patch, partially adopted by upstream.
 -- Alessio Treglia <email address hidden> Sun, 13 Dec 2009 12:41:41 +0100

Changed in avidemux (Ubuntu):
status: Triaged → Fix Released

Hello

And how to update on Karmic Koala?

Changed in avidemux:
status: New → Fix Released
EAB (adair-boder) wrote :

Yeah ... its great that the fixed was released for Lucid ... but its no help for the current release ... so the real question is how to get it sorted out in Karmic!?

add getdeb.net repository ;-)

2010/1/16 Zeth <email address hidden>

> Yeah ... its great that the fixed was released for Lucid ... but its no
> help for the current release ... so the real question is how to get it
> sorted out in Karmic!?
>
> --
> Crash using flv as output (with mp3 audio codec)
> https://bugs.launchpad.net/bugs/481561
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sébastien

Reinhard Tartler (siretart) wrote :

On Sa, Jan 16, 2010 at 10:18:26 (CET), Zeth wrote:

> Yeah ... its great that the fixed was released for Lucid ... but its no
> help for the current release ... so the real question is how to get it
> sorted out in Karmic!?

cf. http://wiki.ubuntu.com/SRU

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Changed in avidemux (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers