Video>Filters-"Add Logo" removed, "Partial" selection crashes program

Bug #461350 reported by emarkay on 2009-10-26
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: avidemux

Karmic, version 2.5.1

Original confirmation of feature: http://avidemux.org/admWiki/index.php?title=Video_filter_Logo

And under "Video > Filters", also, now shows an entry "Partial" which crashes program with:

Segfault
at line 0, file ??/usr/lib/libADM_core.so(ADM_backTrack+0x6d) [0x1f292d]
/usr/lib/libADM_core.so(_Z20sig_segfault_handleri+0x46) [0x1f2db6]
[0x22a400]
/usr/lib/libADM_coreImage.so(_ZN10CONFcouple10lookupNameEPKc+0x1a) [0x213d9a]
/usr/lib/libADM_coreImage.so(_ZN10CONFcouple9getCoupleEPKcPj+0x2c) [0x2142bc]
avidemux2_gtk(_ZN15ADMVideoPartialC1EP22AVDMGenericVideoStreamP10CONFcouple+0x58) [0x80c8708]
avidemux2_gtk(_Z14partial_createP22AVDMGenericVideoStreamP10CONFcouple+0x2b) [0x80c881b]
avidemux2_gtk [0x81add5b]
/usr/lib/libgtk-x11-2.0.so.0 [0x11ec72f]
/usr/lib/libgobject-2.0.so.0(g_closure_invoke+0x1b2) [0x646d072]
/usr/lib/libgobject-2.0.so.0 [0x64827a8]
/usr/lib/libgobject-2.0.so.0(g_signal_emit_valist+0x7bd) [0x6483b2d]
/usr/lib/libgobject-2.0.so.0(g_signal_emit+0x26) [0x6483fb6]
/usr/lib/libgtk-x11-2.0.so.0(gtk_tree_view_row_activated+0x98) [0x12e6fc8]
/usr/lib/libgtk-x11-2.0.so.0 [0x12f991a]
/usr/lib/libgtk-x11-2.0.so.0 [0x11ee474]
/usr/lib/libgobject-2.0.so.0 [0x646b6f9]
/usr/lib/libgobject-2.

Presuming these changes are related, as prior repository versions functioned correctly.

There is some information on the official Avidemux message board, but thus needs to be addressed here, for the repository version.
http://avidemux.org/admForum/viewtopic.php?id=6807

Alessio Treglia (quadrispro) wrote :

Fixed in the latest release available for Lucid.

Changed in avidemux (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
VPablo (villumar) wrote :

Fixed means that the filter has gone?

I have installed 2.5.2-1 from GetDeb and "Partial" filter has changed from Misc to External but does nothing, and Logo filter isn't on filters.

emarkay (mrk) wrote :

It is STILL not functioning, even in Lucid with version 2.5.2!

One would think that the ONLY Linux Video editor [that used] to]have this feature would ensure that this useful and "modern" feature would be fixed by now!

Alessio Treglia, I have returned this to "Confirmed".

Changed in avidemux (Ubuntu):
status: Fix Released → Confirmed
emarkay (mrk) wrote :

Also, it may not now always crash the program, but it's still missing and there is no legit workaround.
See: http://avidemux.org/admForum/viewtopic.php?pid=43849#

emarkay (mrk) wrote :

Also, the newest version (via GetDeb) 2.5.3 still crashes as originally submitted.

"Segfault
 at line 0, file ??ADM_backTrack
sig_segfault_handler(int)
[0x259400]
CONFcouple::lookupName(char const*)
CONFcouple::getCouple(char const*, unsigned int*)
ADMVideoPartial::ADMVideoPartial(AVDMGenericVideoStream*, CONFcouple*)
partial_create(AVDMGenericVideoStream*, CONFcouple*)
filterCreateFromTag(unsigned int, CONFcouple*, AVDMGenericVideoStream*)
avidemux2_gtk() [0x8178eb8]

g_closure_invoke

g_signal_emit_valist
g_signal_emit
gtk_tree_view_row_activated

g_closure_invoke"

Alessio Treglia (quadrispro) wrote :

Please confirm this with the latest release available in Maverick.

Changed in avidemux (Ubuntu):
status: Confirmed → Incomplete
emarkay (mrk) wrote :

Returned to Complete - I am not Alpha testing Maverick, and will not update to it when it is released.
This does however affect Lucid which is a LTS as well as Karmic, both which are still active products and are affected by this bug.
I also have confirmed that this is also an issue in the latest GetDeb (release, which is newer than the Canonical Repos).
Thank you.

Changed in avidemux (Ubuntu):
status: Incomplete → Confirmed
emarkay (mrk) wrote :

Still broken in Avidemux 2.5.3

Can we please get someone to look into this? Avidemux is the only Ubuntu video editor that allowed "logos" or watermarks to be superimposed on the video!

Thanks!

arndt (arndtt) wrote :

Confirmed for Avidemux 2.5.3 in Maverick Beta.

emarkay (mrk) wrote :

This is because of a problem in Windows. I have been working with a developer and this feature has been restored in a test version of Avidemux 2.6. Please see the Avidemux message boards for details and testing info (Link in post #4)..
My understanding is that it won't be replaced in 2.5, and again, as I understand, Afidemux 's filters and the like will now be external "plug-ins" as of 2.6, allowing for independent platform features.
As of now, there are still debug issues in 2.6, but I was able to get my "Logo" (copyright watermark) on a test video. :)

emarkay (mrk) wrote :

For now, the workaround is to "Pin" (Lock Version") to Avidemux 2.4.4.

Note that there are issues with Pinning and "Fix Broken Packages" (as found in Recovery menu) as noted here:
https://bugs.launchpad.net/ubuntu/+source/friendly-recovery/+bug/452222

emarkay (mrk) wrote :

With version 2.5.4 the "Add Logo" feature has been restored, but "Partial" section still crashes program with:

"Crash
Segfault
 at line 0, file ??ADM_backTrack
sig_segfault_handler(int)
[0x22e400]
CONFcouple::lookupName(char const*)
CONFcouple::getCouple(char const*, unsigned int*)
ADMVideoPartial::ADMVideoPartial(AVDMGenericVideoStream*, CONFcouple*)
partial_create(AVDMGenericVideoStream*, CONFcouple*)
filterCreateFromTag(unsigned int, CONFcouple*, AVDMGenericVideoStream*)
avidemux2_gtk() [0x8183928]
g_closure_invoke
g_signal_emit_valist
g_signal_emit
gtk_tree_view_row_activated
g_closure_invoke"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers