vorbis decoder plugin is missing

Bug #447720 reported by Aaron Haviland on 2009-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
Low
Alessio Treglia

Bug Description

Binary package hint: avidemux

the Vorbis decoder plugin (in plugins/ADM_audioDecoders/ADM_ad_vorbis/) is not being built. This makes it impossible to open files with vorbis audio streams.

Upstream has fixed this in branches/avidemux_2.5_branch_gruntster in r5256. I've attached the specific changes applied to renable this plugin, and tested that it does work.

ProblemType: Bug
Architecture: i386
Date: Fri Oct 9 21:30:40 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: avidemux-plugins 1:2.5.1+repack-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: avidemux
Uname: Linux 2.6.31.2-eris1 i686

Related branches

Aaron Haviland (aaron-haviland) wrote :
Alessio Treglia (quadrispro) wrote :

Attaching the result of:

dpkg -c avidemux-plugins_2.5.1+repack-0ubuntu1_i386.deb > contents

Alessio Treglia (quadrispro) wrote :

The vorbis plugin seems installed.

Changed in avidemux (Ubuntu):
status: New → Incomplete
Aaron Haviland (aaron-haviland) wrote :

Please look at your list again. It confirms what I've said. Only the vorbis *encoder* plugin is installed, not the *decoder*.

orion@eris:~$ dpkg -c avidemux-plugins_1%3a2.5.1+repack-0ubuntu1_i386.deb | grep -i enc.*vorbis
-rw-r--r-- root/root 13996 2009-08-20 05:08 ./usr/lib/ADM_plugins/audioEncoders/libADM_ae_vorbis.so

orion@eris:~$ dpkg -c avidemux-plugins_1%3a2.5.1+repack-0ubuntu1_i386.deb | grep -i dec.*vorbis
orion@eris:~$

Alessio Treglia (quadrispro) wrote :

You're right, I'm on it.

Changed in avidemux (Ubuntu):
status: Incomplete → In Progress
importance: Undecided → Low
assignee: nobody → Alessio Treglia (quadrispro)
Alessio Treglia (quadrispro) wrote :

Please test the package available from my testing PPA:

ppa:quadrispro/testing

Changed in avidemux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.1+repack-0ubuntu2

---------------
avidemux (1:2.5.1+repack-0ubuntu2) karmic; urgency=low

  * debian/{control,rules,README.source}: Add quilt support.
  * debian/rules: Prevent FTBFS if the dir exists.
  * Add a patch to build vorbis decoder plugin (LP: #447720).

 -- Alessio Treglia <email address hidden> Mon, 12 Oct 2009 23:44:26 +0200

Changed in avidemux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers