Missing plugins in avidemux - regression

Bug #401386 reported by Roger on 2009-07-19
54
This bug affects 14 people
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
High
Alessio Treglia

Bug Description

Source package: avidemux 1:2.5.0-0.0ubuntu2
Release: 9.10 Karmic

Starting with version 2.5.0, audio and video encoders (xvid, h264), video filters and so on are now plugins, and Avidemux has to be built in two steps: first the application itself and then the plugins. Have a look at

http://www.avidemux.org/admWiki/index.php?title=Install_2.5

for reference.

It appears that no plugins were packaged, so Avidemux in Karmic cannot convert sound, cannot convert into xvid and h264, cannot adjust the picture using filters etc. A whole lot of functionality is lost, so we're looking at a severe regression compared to 2.4.4.

Related branches

Roger (r-wiberg) on 2009-07-19
description: updated
Philip Muškovac (yofel) on 2009-07-19
affects: ubuntu → avidemux (Ubuntu)
Changed in avidemux (Ubuntu):
status: New → Confirmed
tags: added: regression-potential
Christoph Korn (c-korn) wrote :

I was able to compile and package the plugins.

Alessio Treglia (quadrispro) wrote :

Cristoph, thank you!

I'm on it.

Changed in avidemux (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.0-0.0ubuntu3

---------------
avidemux (1:2.5.0-0.0ubuntu3) karmic; urgency=low

  [ Christoph Korn ]
  * Also build the plugins (LP: #401386).

  [ Alessio Treglia ]
  * debian/control:
    - Build-Depends on libjack-dev to build with JACK support.
    - Remove avidemux fom avidemux-common's dependencies.
    - avidemux{-qt,-cli} runtime packages depend on avidemux-plugins.
  * debian/patches/avidemux-plugins-2.5.0-gcc4.4.patch:
    - Fix plugins build issues due to GCC4.4;
      taken from http://avidemux.org/admForum/viewtopic.php?id=6304.

 -- Alessio Treglia <email address hidden> Mon, 10 Aug 2009 14:52:00 +0200

Changed in avidemux (Ubuntu):
status: In Progress → Fix Released
dj_segfault (david-thekramers) wrote :

I have 1:2.5.1+repack-0ubuntu2.1 in Ubuntu 9.10 and am still experiencing this problem. And help/plugins shows the plugins, so that's not the problem.

 Decoder FCC: WMV1 (31564D57)
Searching decoder (400 x 304, extradataSize:0)...
[lavc] Build: 3416064
[lavc] Decoder init: CODEC_ID_WMV1 video decoder initialized!

 no B- frame with that codec

 Editor :Audio streamer initialized[ADM_ad_plugin]Format 0x160 : probing libADM_ad_faad.so score 0
[ADM_ad_plugin]Format 0x160 : probing libADM_ad_vorbis.so score 0
[ADM_ad_plugin]Format 0x160 : probing libADM_ad_a52.so score 0
[ADM_ad_plugin]Format 0x160 : probing libADM_ad_Mad.so score 0

 Unknown codec : 352[GTK] Changing size to 400 304
[GTK] Changing size to 400 304
[GTK] Changing size to 400 304

** conf updated **

 ********** Automation ended***********
[Audio Plugins] Found 4 plugins
[VideoEncoder Plugins] Found 6 plugins
[AudioDevice Plugins] Found 4 plugins
[AudioEncoder Plugins] Found 7 plugins

dj_segfault (david-thekramers) wrote :

Oh, sorry, I see that the fix was in a later version. Is this not going to be updated in Karmic though?

Ralf Oltmanns (ubuntu-abo) wrote :

I'm experiencing this problem still in 12.04 LTS with avidemux 2.5.4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers