[FFe request] Avidemux 2.4.1

Bug #192774 reported by echoes on 2008-02-17
4
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: avidemux

Avidemux 2.4.1 was released today. Please update the package.

Changelog:
* Support for x264’s new Hadamard Exhaustive Search method of motion estimation
* Decoder for Windows Media Video 9 Advanced Profile (WVC1)
* Re-enabled H.263 decoder (it was missing from the 2.4 release)
* Fixed loss of audio when saving large OpenDML AVI files
* Fixed various colour conversion issues with RGB codecs including BMP, Huffyuv, JPEG and PNG
* Updates to the following translations: Catalan, French, German, Italian, Russian and Spanish
* Win32 logging is now stored in an Avidemux folder under the user's profile. This allows Avidemux to operate under a non-administrator account.
* Win32 CLI version nows outputs to console
* New Quartz version for Mac
* Better SDL support for Mac Quartz and Qt4 versions (SDL windows are now embedded and acceleration is enabled for Qt4)
* Various video decoding fixes for PowerPC-based Macs
* Fixed freezing when opening files on Mac
* Fix corruption when encoding from a mp4/mov/3gp file.

Source:
http://downloads.sourceforge.net/avidemux/avidemux_2.4.1.tar.gz

Related branches

Murat Gunes (mgunes) wrote :

Since feature freeze in effect, this needs a freeze exception to go into Hardy.

https://wiki.ubuntu.com/FreezeExceptionProcess

Changed in avidemux:
importance: Undecided → Wishlist
Maia Everett (linneris) wrote :

This is mostly a bugfix release, except for the first two entries in the changelog - and the Hadamard Exhaustive Search isn't available in Ubuntu x264 anyway, as it's an unofficial patch at this point. I believe it might be worth getting into Ubuntu.

It's available on debian-multimedia.org, and I'll merge it if the motu-release team approves this exception.

Attaching diffstat for orig.tar.gz since 2.4.0.

Maia Everett (linneris) wrote :

Build log on Gutsy. Package installs and works correctly.

please remove me from the bug mailing list ..thanks!

and thanks for the help and the work you guys are doing

jon anderson
<email address hidden>

Scott Kitterman (kitterman) wrote :

Ack #2 and approved.

Changed in avidemux:
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

Sorry. Ack #1, approved yet.

Changed in avidemux:
status: Confirmed → New
StefanPotyra (sistpoty) wrote :

Hm... the glade file seems to indicate some UI changes, though the changed lines compared to the file size is still quite low, and I couldn't really estimate how much code glade produces for small changes. While the changes really sound more like adding features than fixing bugs, I guess the better qt4 support is still release worthy.

-> ACK #2 and approved.

Changed in avidemux:
status: New → Confirmed
Maia Everett (linneris) on 2008-02-22
Changed in avidemux:
assignee: nobody → sikon
status: Confirmed → In Progress
Maia Everett (linneris) wrote :

Uploaded.

Changed in avidemux:
assignee: sikon → nobody
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (10.4 KiB)

This bug was fixed in the package avidemux - 1:2.4.1-0.0ubuntu1

---------------
avidemux (1:2.4.1-0.0ubuntu1) hardy; urgency=low

  * Merged new upstream release from debian-multimedia.org (LP: #192774),
    remaining Ubuntu changes:
    + debian/control:
      - Set maintainer fields per specification.
      - Removed libamrnb-dev build-dependency.
      - Re-added chrpath build-dependency.
      - Corrected spelling: QT4 -> Qt 4.
    + debian/rules:
      - Strip rpath from avidemux2_qt4 (--disable-rpath won't work).

avidemux (1:2.4.1-0.0) unstable; urgency=low

  * New upstream release.

avidemux (1:2.4.0-0.3ubuntu2) hardy; urgency=low

  * Corrected the typo errors (LP: #189584)

avidemux (1:2.4.0-0.3ubuntu1) hardy; urgency=low

  * Merged new upstream release from debian-multimedia.org
    (LP: #178845, LP: #180393), remaining Ubuntu changes:
    + debian/control:
      - set maintainer fields per Ubuntu policy.
      - removed libamrnb-dev, not in Ubuntu and most likely
        will never be (due to being proprietary software).
      - build against current libx264-dev (LP: #177082).
      - build against current libfaac-dev (LP: #181389).
      - build-depend on chrpath to strip rpath from avidemux2_qt4.
    + debian/rules: strip rpath from avidemux2_qt4.
    + debian/source.lintian-overrides: re-added.

avidemux (1:2.4.0-0.3) unstable; urgency=low

  * Use configure and make instead of cmake.

avidemux (1:2.4.0-0.2) unstable; urgency=low

  * avidemux-common should replace avidemux.

avidemux (1:2.4.0-0.1) unstable; urgency=low

  * Should Build-Depends on libsamplerate0-dev
  * Upload in unstable.

avidemux (1:2.4.0-0.0) unstable; urgency=low

  * New upstream release.
  * Merge changes from Ubuntu.

avidemux (1:2.4~preview3-0.0ubuntu1) hardy; urgency=low

  * Upload to Ubuntu. (LP: #163287, LP: #126572)
  * debian/changelog: re-added Ubuntu releases.
  * debian/control:
    - Require debhelper >= 5.0.51 (for dh_icons) and imagemagick.
    - Build-depend on libsdl1.2-dev instead of libsdl-dev.
    - Build against newer libx264-dev. (LP: #138854)
    - Removed libamrnb-dev, not in Ubuntu yet.
  * debian/rules:
    - Install all icon sizes, using convert (upstream installs none).
    - Added missing calls to dh_installmenu, dh_installman, dh_icons and
      dh_desktop.
  * debian/menu, debian/avidemux-qt.menu:
    - Corrected package and executable names.
  * debian/avidemux-common.install: Install icons.
  * debian/avidemux.common.manpages: Install man/avidemux.1.
  * debian/links, debian/avidemux-cli.links, debian/avidemux-gtk.links:
    - Link manpages to avidemux.1.gz.
  * debian/install, debian/avidemux-qt.install, debian/avidemux-gtk.desktop,
    debian/avidemux-qt.desktop: Install desktop files.

avidemux (1:2.4~preview3-0.0) experimental; urgency=low

  * New upstream pre release uploaded to experimental.

avidemux (1:2.3.0-0.0ubuntu3) feisty; urgency=low

  * Fix race condition in po builds.

avidemux (1:2.3.0-0.0ubuntu2) feisty; urgency=low

  * Rebuild against newer libx264-dev (affects Ubuntu: #80387)
    - No source changes needed; avidemux properly compensates for newer API

avidemux (1:2.3.0-0.0ubuntu1) feisty; urgency...

Changed in avidemux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers