avidemux does not sync audio and video anymore in Ubuntu 14.04

Bug #1309966 reported by Papamatti on 2014-04-19
136
This bug affects 25 people
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
High
Unassigned

Bug Description

Avidemux cannot sync the audio stream anymore. If you open a video and you move the slider to any video position, audio starts alway at the beginnig of the file. It does not respect videocutting.

I created the video from a m2t dvb-s2 transportsteam and split it with projekt-x and combine them with mplex into a mpg-file. After that normally i edit this mpg-file with avidemux and save it as xvid/vorbis file into a mkv-container. This has worked in Ubuntu 12.04 flawlessly, but in 14.04 this is not possible anymore.

If I use dvbcut to cut the commercials out of the m2t file and save it as mpg, open it in avidemux and save it as xvid/vorbis in a mkv-container. playback of video and audio is absolutely not synchonous! (Video too fast, Audio at normal speed!).

This is a regression to avidemux in ubuntu 12.04 LTS.

tags: added: trusty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in avidemux (Ubuntu):
status: New → Confirmed
bneven (bneven) wrote :

Problem seems to happen only with MPEG-PS and MPEG-TS streams. If I take an MPEG-PS stream (MPEG2 video + MP2 audio, from DVB-T recording) and load it in Avidemux, audio does not follow the slider or cut points. Audio always starts from the beginning, irrelevant of the position of the slider, while video actually starts from the slider position as it should.

But, if I use Avidemux to save that same (whole) stream in AVI container (just copy audio and video, but put it in AVI container), then if I load that new AVI stream into Avidemux, everything seems to be working OK (audio follows slider and cut points correctly).

I also tried with a stream containing h264 video and AAC audio packed in MKV container and this too seems to be working OK in Avidemux.

The same problem happens in Linux Mint 17 too. In Mint 16 and 15 it was working fine.

Xavier Deloge (xavier-a) wrote :

Same behavior for me.
Avidemux 2.5.6 on Linux Mint 13 (Maya) - it's perfect.
Avidemux 2.5.6 on Ubuntu 14.04 - the problem occurs.

In my case, the conversion to AVI container crashs Avidemux after few minutes during the encoding process :

Crash

Segfault
 at line 0, file ??ADM_backTrack

Telecide::getFrameNumberNoAlloc(unsigned int, unsigned int*, ADMImage*, unsigned int*)
VideoCache::getImage(unsigned int)
Decimate::FindDuplicate(int, int*, double*, bool*)

AVDMVideoStreamCrop::getFrameNumberNoAlloc(unsigned int, unsigned int*, ADMImage*, unsigned int*)
AVDMVideoStreamResize::getFrameNumberNoAlloc(unsigned int, unsigned int*, ADMImage*, unsigned int*)
externalEncoder::encode(unsigned int, ADMBitstream*)
GenericAviSaveProcess::setupVideo(char*)
GenericAviSave::saveAvi(char const*)
A_Save(char const*)
A_SaveWrapper(char*)
FileSel_ReadWrite(void (*)(char const*), int, char const*, char const*)
avidemux2_gtk() [0x52ccfc]
HandleAction(Action)
g_closure_invoke

g_signal_emit_valist
g_signal_emit

I will continue to investigate to find a solution.

Nick (abcd-3) wrote :

Same problem with my installation.
checked it on 2 computers, both had worked before on 12.04, but after upgrade to 14.04 avidemux is broken.
I can cut video from the beginning, but audio does not get cut any more.
Still works fine on 12.04, I consider going back if it isn't fixed soon.
Is there a chance that it gets fixed anytime soon?

I found a workaround: copy to an avi container first then edit the avi

On 31 October 2014 03:16, Nick <email address hidden> wrote:

> Same problem with my installation.
> checked it on 2 computers, both had worked before on 12.04, but after
> upgrade to 14.04 avidemux is broken.
> I can cut video from the beginning, but audio does not get cut any more.
> Still works fine on 12.04, I consider going back if it isn't fixed soon.
> Is there a chance that it gets fixed anytime soon?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1309966
>
> Title:
> avidemux does not sync audio and video anymore in Ubuntu 14.04
>
> Status in “avidemux” package in Ubuntu:
> Confirmed
>
> Bug description:
> Avidemux cannot sync the audio stream anymore. If you open a video and
> you move the slider to any video position, audio starts alway at the
> beginnig of the file. It does not respect videocutting.
>
> I created the video from a m2t dvb-s2 transportsteam and split it with
> projekt-x and combine them with mplex into a mpg-file. After that
> normally i edit this mpg-file with avidemux and save it as xvid/vorbis
> file into a mkv-container. This has worked in Ubuntu 12.04 flawlessly,
> but in 14.04 this is not possible anymore.
>
> If I use dvbcut to cut the commercials out of the m2t file and save it
> as mpg, open it in avidemux and save it as xvid/vorbis in a mkv-
> container. playback of video and audio is absolutely not synchonous!
> (Video too fast, Audio at normal speed!).
>
> This is a regression to avidemux in ubuntu 12.04 LTS.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/avidemux/+bug/1309966/+subscriptions
>

Changed in avidemux (Ubuntu):
importance: Undecided → High

Same problem here. Worked perfectly in Ubuntu 12.04 but upgraded to 14.04 and this bug effectively destroys avidemux's usefulness to me. I've tried saving and reopening in avidemux as described but the timing is still slightly off, albeit 'fixable' in the software itself.

plata (plata) wrote :

As a workaround: You can use the Windows version of Avidemux through Wine. I installed the 32bit version with PlayOnLinux. Works fine.

Robert Voje (robert-voje-dk) wrote :

In my 14.04 Ubuntu (with Mint 17 Mate), the cut function are not removing the audio part of the clip, just the video.

And as for plata's tip on using wine, the Win32 version does not support loading TS files.

Robert Voje (robert-voje-dk) wrote :

Another note: Using Ross Gaylers tip and copying it to an avi container, it works better, but the audio is still out of sync by a few seconds.

Daniil Trishkin (dtrishkin) wrote :

I have same problem, could not cut video at all.

Papamatti (matti-lx) wrote :

I'm using now Ubuntu 15.10 and avidemux is working very well and way faster (!!!) thanks to ffmpeg instead of libav.

Timo Aaltonen (tjaalton) wrote :

seems to be fixed now, closing

Changed in avidemux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers