avidemux2_gtk not displayed in the file properties 'Open with' tab

Bug #1041144 reported by pataquets on 2012-08-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
avidemux (Ubuntu)
Undecided
pataquets
Precise
Low
pataquets
Quantal
Undecided
pataquets

Bug Description

[Original report]
If you want to associate files with applications not listed in the 'Properties'->'Open with' list, you can click a button below to display more of them. However, when you click it, Avidemux-GTK is not among the listed applications.

The following fix made it appear listed and selectable:
http://askubuntu.com/questions/82652/file-association-to-unlisted-application
If you want to associate files with applications not listed in the 'Properties'->'Open with' list, you can click a button below to display more of them. However, when you click it, Avidemux-GTK is not among the listed applications.

The following fix made it appear listed and selectable:
http://askubuntu.com/questions/82652/file-association-to-unlisted-application

[Test Case]
1. Invoke the 'Open with...' dialog by right-clicking on a file.
2. Click the 'Show more applications' button to reveal installed applications list.
3. Avidemux-GTK will not be in the list.

[Regression Potential]
Affectation to Avidemux desktop launcher and ability to launch Avidemux from menu.

Related branches

pataquets (pataquets) wrote :

Finally managed to create my first merge proposal. Sorry for the comment noise.
Merged against precise first because it is my testing environment. Not sure about which .desktop file to modify, still not familiar enough with packaging. Should I also modify debian one?
Merge workflow comments/mentoring is also welcomed.

Marc Deslauriers (mdeslaur) wrote :

This needs to be fixed in the development release first, before being SRUed into Precise.

Could you please create a merge proposal against the Quantal version? Thanks!

Changed in avidemux (Ubuntu Precise):
status: New → Confirmed
Changed in avidemux (Ubuntu Quantal):
status: New → Confirmed
status: Confirmed → Incomplete
pataquets (pataquets) wrote :

Hi, Marc.
Done, hope it's OK.
Thanks for your help.

Changed in avidemux (Ubuntu Quantal):
assignee: nobody → pataquets (pataquets)
Changed in avidemux (Ubuntu Precise):
assignee: nobody → pataquets (pataquets)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avidemux - 1:2.5.4-0ubuntu13

---------------
avidemux (1:2.5.4-0ubuntu13) quantal; urgency=low

  [ pataquets ]
  * Allow avidemux2_gtk to be selected from 'Open with' tab (LP: #1041144)
 -- Luke Yelavich <email address hidden> Wed, 12 Sep 2012 14:50:47 +1000

Changed in avidemux (Ubuntu Quantal):
status: Incomplete → Fix Released
pataquets (pataquets) on 2013-05-15
description: updated
Changed in avidemux (Ubuntu Precise):
importance: Undecided → Low
Sebastian Meyer (wastl) wrote :

Unfortunately, I can confirm this bug also for Ubuntu 14.04.1.

I fixed the issue as described in http://askubuntu.com/questions/82652/file-association-to-unlisted-application by adding the argument %U in the "Exec" line of /usr/share/applications/avidemux-gtk.desktop

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers