Unable to select an icon from the theme (trunk)

Bug #461187 reported by J.M. "Peng" Hardin on 2009-10-26
0
Affects Status Importance Assigned to Milestone
Desktop Agnostic Library for GLib-based Projects
Medium
Michal Hruby
avant-window-navigator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: avant-window-navigator

Since I started using the karmic trunk version of AWN I am unable to select an icon when creating or editing a launcher. When I click on the icon in the Desktop Entry Editor I am presented with a .png in my /home folder under from File (that has been deleted over a week ago), but when I click the radio button to select icons from the current theme I am presented with an empty window (see attachments). The issue occurs regardless of which GTK theme I am using.

Ubuntu Version: 9.10 (beta/RC, with all updates as of 11am EDT today)
AWN Version: Avant Window Navigator 0.3.9-rewrite-bzr1605-karmic1-1

STEPS:
1. Launch AWN-trunk
2. Open Awn Settings
3. Go to the Launchers pane and either click Add or select an existing launcher and click Edit
4. If adding a new launcher insert the appropriate information into the fields
5. Click the icon button
6. The Desktop Entry Editor opens with the From File panel

EXPECTED:
1. Click the From Theme radio button
2. Select the desired icon from the icons available in the active GTK theme

ACTUAL:
1. Click the From Theme radio button
2. No icons are presented from active GTK theme

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 6577f4a98123013ed895d57580291f00
CheckboxSystem: fc73f07fcd9845bb95fa3ca6b8be7ef2
Date: Mon Oct 26 11:19:47 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: avant-window-navigator (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: avant-window-navigator
Uname: Linux 2.6.31-14-generic i686

Related branches

J.M. "Peng" Hardin (bostonpeng) wrote :
J.M. "Peng" Hardin (bostonpeng) wrote :

Adding screenshot using the Dust Sand theme that shipped with Ubuntu 9.10 (beta/RC). Would also include a screenshot showing the Mac4Lin_Aqua theme (my normal theme) but it shows the same result.

Mark Lee (malept) wrote :

Note related to the package in Ubuntu proper.

Changed in avant-window-navigator (Ubuntu):
status: New → Invalid
Mark Lee (malept) wrote :

Well, technically you can select an icon category from the dropdown, but that's obviously not a discoverable action. What I'm going to attempt to do when I get some coding time is to have it default to a dropdown entry that says "Select Category" (which cannot be selected).

Changed in libdesktop-agnostic:
assignee: nobody → Mark Lee (malept)
importance: Undecided → Medium
milestone: none → 0.3.9
status: New → Confirmed
J.M. "Peng" Hardin (bostonpeng) wrote :

You read my mind, Mark. Once I was able to select an icon from the theme again I was going to see if I needed to file a bug against what a PITA it [was|is] to find a specific icon amongst the semi-sorted listing. I always hated having to muddle my way through the icons trying to find the one I wanted. I look forward to seeing your fix in the nightly updates.

Mark Lee (malept) wrote :

Yeah, pretty much the only reason why it's currently blank is because it takes a little time to load a category, and I didn't want to incur that cost when someone initially selects "From Theme".

Mark Lee (malept) on 2010-04-11
Changed in libdesktop-agnostic:
milestone: 0.3.90 → 0.4.0
Michal Hruby (mhr3) on 2011-02-13
Changed in libdesktop-agnostic:
status: Confirmed → Fix Committed
assignee: Mark Lee (malept) → Michal Hruby (mhr3)
Julien Lavergne (gilir) on 2011-03-12
Changed in libdesktop-agnostic:
milestone: 0.4.0 → 0.3.92
Michal Hruby (mhr3) on 2011-03-14
Changed in libdesktop-agnostic:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers