Python 2.6 and installation migration

Bug #335785 reported by Bernardo on 2009-02-28
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
avant-window-navigator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: synaptic

Yesterday, after i installed skype 2 forcing 32 bit architecture on my 9.04 64 bit, an update was performed by the system, in this update/upgrade, the system uninstalled avant manager, i don't understand why, but trying to re-install it, synaptic tell me that is not possible:

awn-manager:
 Depends: python-awn but it is not going to be installed

..so i try to install python-awn, but this is the message:

python-awn:
  Depends: python (<2.6) but 2.6.1-0ubuntu1 is to be installed

What can i do?

One more thing:

After the update, another thing is wrong: the pop-up notifications is working in general (system messages) but not working for the volume control and brighitness control, just i can see the black box but nothing more.

Thanks for help
Bernardo

ProblemType: Bug
Architecture: amd64
DistroRelease: /usr/bin/lsb_release:81: DeprecationWarning: the sets module is deprecated import sets Ubuntu 9.04
ExecutablePath: /usr/sbin/synaptic
Package: synaptic 0.62.5ubuntu1
ProcAttrCurrent: unconfined
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
Uname: Linux 2.6.28-8-generic x86_64

Bernardo (ettabyte) wrote :
Miloš Mandarić (mandzo18) wrote :

You probably did dist-upgrade. I run yesterday:

sudo apt-get dist-upgrade

and it also said it will remove avant.
You should always check before you do an upgrade.

Thank you Milos for reply!
So i understand well? The upgrade caused the uninstallation, but now, what
can i do?
1) i have to wait for a new version avant tha is supported by the new
version of python?
2) can i undo the upgrade?
3) have i to reinstall ubuntu 9.04?

i am a bit disoriented...
Thanks
Bernardo

2009/2/28 Miloš Mandarić <email address hidden>

> You probably did dist-upgrade. I run yesterday:
>
> sudo apt-get dist-upgrade
>
> and it also said it will remove avant.
> You should always check before you do an upgrade.
>
> --
> avant manager misteriously uninstalled after update
> https://bugs.launchpad.net/bugs/335785
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "synaptic" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: synaptic
>
> Yesterday, after i installed skype 2 forcing 32 bit architecture on my 9.04
> 64 bit, an update was performed by the system, in this update/upgrade, the
> system uninstalled avant manager, i don't understand why, but trying to
> re-install it, synaptic tell me that is not possible:
>
> awn-manager:
> Depends: python-awn but it is not going to be installed
>
> ..so i try to install python-awn, but this is the message:
>
> python-awn:
> Depends: python (<2.6) but 2.6.1-0ubuntu1 is to be installed
>
> What can i do?
>
> One more thing:
>
> After the update, another thing is wrong: the pop-up notifications is
> working in general (system messages) but not working for the volume control
> and brighitness control, just i can see the black box but nothing more.
>
> Thanks for help
> Bernardo
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: /usr/bin/lsb_release:81: DeprecationWarning: the sets module
> is deprecated import sets Ubuntu 9.04
> ExecutablePath: /usr/sbin/synaptic
> Package: synaptic 0.62.5ubuntu1
> ProcAttrCurrent: unconfined
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: synaptic
> Uname: Linux 2.6.28-8-generic x86_64
>

U Sub, 28. 02. 2009., u 14:09 +0000, Bernardo je napisao/la:
> Thank you Milos for reply!
> So i understand well? The upgrade caused the uninstallation, but now, what
> can i do?
> 1) i have to wait for a new version avant tha is supported by the new
> version of python?
> 2) can i undo the upgrade?
> 3) have i to reinstall ubuntu 9.04?
>
> i am a bit disoriented...
> Thanks
> Bernardo
>

1) yes
2) no
3) no

Well now you know you should always check before selecting 'Yes'.
If you must have avant you can always install it from source.

awn-manager still needs to be rebuilt against python 2.6 so that it can be installed.

Changed in synaptic:
status: New → Confirmed
Julien Lavergne (gilir) wrote :

python-awn need also to be modify to follow new python installation. Will be fix in the next upload of the package.

Julien Lavergne (gilir) on 2009-03-02
Changed in avant-window-navigator:
status: Confirmed → In Progress

> After the update, another thing is wrong: the pop-up notifications is working in general (system messages) but not working for the volume control and brighitness control, just i can see the black box but nothing more.

That is a separate issue unrelated to AWN:
https://bugs.launchpad.net/bugs/331311 . Please subscribe to that bug
and direct comments for that there, thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.3~bzr489-1ubuntu1

---------------
avant-window-navigator (0.3~bzr489-1ubuntu1) jaunty; urgency=low

  * Python 2.6 transition (lp: #335785).

 -- Michael Bienia <email address hidden> Thu, 05 Mar 2009 16:12:10 +0100

Changed in avant-window-navigator:
status: In Progress → Fix Released
Id2ndR (id2ndr) wrote :

There still is an issue with python-awn-extras.

Mystilleef (mystilleef) wrote :

Still can't install python-awn.

Julien Lavergne (gilir) wrote :

For python-awn-extras, the same fix need to be done for awn-extras-applets

@Mystilleef
Could you provide the log of the installation/upgrade please ?

Mystilleef (mystilleef) wrote :

@Julien

After an update python-awn installs now.

However, neither python-awnlib nor awn-applets-python-core installs.

azibioki@azibioki ~> sudo apt-get install awn-applets-python-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  awn-applets-python-core: Depends: python-awnlib (>= 0.3~bzr912) but it is not going to be installed
E: Broken packages

Mystilleef (mystilleef) wrote :

After an update all python awn packages install fine for me (i386 architecture).

Hopefully this package will be updated to version 0.3.2 sooner or later. The version I have is 0.3.1

Id2ndR (id2ndr) wrote :

Fixed for python-awn-extras few hours ago, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers