awn-applet-activation crashed with SIGSEGV in gdk_drawable_get_size()

Bug #332928 reported by Parent5446 on 2009-02-22
68
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Awn Extras
Critical
moonbeam
avant-window-navigator (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Iulian Udrea
awn-extras-applets (Ubuntu)
Medium
Unassigned
Declined for Jaunty by Iulian Udrea

Bug Description

Binary package hint: avant-window-navigator

For some reason, whenever AWN is started up, the "Shiny Desktop Switcher" applet fails to load and the crash report dialogue pops up. Instead of loading normally it just never appears. It can be easily restored by going into AWN's preferences and removing then re-adding the applet, but this is troublesome. So far, the only way to reproduce this problem is to log out and log back in (or restart the computer). I am currently using Ubuntu 9.04, and avant-window-manager version 0.3~bzr489~1build1.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/awn-applet-activation
Package: avant-window-navigator 0.3~bzr489-1build1 [modified: usr/bin/avant-window-navigator usr/bin/awn-applet-activation]
ProcCmdline: Shiny\ Switcher vation -p /usr/share/avant-window-navigator/applets/shinyswitcher.desktop -u 1235272557 -w 33554492 -o 0 -h 48
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: avant-window-navigator
StacktraceTop:
 gdk_drawable_get_size () from /usr/lib/libgdk-x11-2.0.so.0
 copy_pixmap ()
 create_containers ()
 _waited ()
 g_timeout_dispatch (source=0x93c01a8, callback=0x9384e08,
Title: awn-applet-activation crashed with SIGSEGV in gdk_drawable_get_size()
Uname: Linux 2.6.28-8-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin netdev plugdev powerdev sambashare scanner users video

Parent5446 (parent5446) wrote :

StacktraceTop:IA__gdk_drawable_get_size (drawable=0x938f948,
copy_pixmap (shinyswitcher=0x93b68e8, src=0x938f948)
create_containers (shinyswitcher=0x93b68e8)
_waited (shinyswitcher=0x93b68e8)
g_timeout_dispatch (source=0x93c01a8, callback=0x9384e08,

Changed in avant-window-navigator:
importance: Undecided → Medium
Julien Lavergne (gilir) wrote :

Thanks for your bug report.
Reported also with the stable 0.3.2. (see dupplicate bug).
Forwarded upstream for the retrace.

visibility: private → public
moonbeam (rcryderman) wrote :

It seems there is at least one configuration combination where this type of thing is occurring on startup. Of note in the retrace is that h=0 in the copy_pixmap function.

Changed in awn:
assignee: nobody → rcryderman
status: New → Triaged
Julien Lavergne (gilir) on 2009-03-29
Changed in avant-window-navigator (Ubuntu):
status: New → Invalid
moonbeam (rcryderman) wrote :

possible fix in rev 1140

Changed in awn-extras:
status: Triaged → In Progress
Julien Lavergne (gilir) wrote :

I uploaded a package with the fix in my PPA (https://launchpad.net/~gilir/+archive/ppa). Could you please test with it and report if there is still a bug ?
Also, could you please using "gconf-editor" and report your configuration of shinyswitcher ? (it's under the key apps/avant-window-navigator/applets/shinyswitcher/) ?
Thanks.

Changed in awn-extras-applets (Ubuntu):
assignee: nobody → gilir
status: New → In Progress
Justin Newton (justinnewinc) wrote :

Hi, I am new to ubuntu I am new and I like it so I thought it would be neat to help in the process.

After installing jaunty, and restarting at first the load screen was fine but when it got to where the log in screen in screen all it did is hang, and the screen was pure black with a small grey stripe on the top. I don't know if this has too do because im using a custom theme?? Oh, yeah also it never did ask me for user/pass it just went straight to the desktop.

And when it started atleast 10 pop-up box having to do with the awn-program pop ups came one after another until I killed the process.

Oh yeah, this may be the opposite of what anyone wishes for, but I was hoping that jaunty would start up with it owns theme and programs, I don't mind if that means if I have to replace everything on the panels or add a new theme if I don't like it, i'm just interested in seeing the difference in look between 8.10 and jaunty.

If there is anyway I can start new without having to delete partition, resize or mess with anything more please let me know. I would be happy just too see the panels, and the wallpaper be update sort of the way windows does when you update to there new OS. please let me know if I can do anything like this .... <email address hidden>.

thanks.

iMac (imac-netstatz) wrote :

I experience this problem also so I will just continue this thread; gconf output is below. (If there an easy way to export pls let me know.. no obvious cut 'n paste from gconf as far as I can see).

applet_border_colour:00000088
applet_border_width:1
applet_scale:0.80000001192092896
background_alpha_active:0.94999998807907104
background_alpha_inactive:0.55000001192092896
cache_expiry:7
columns:4
desktop_colour:00000088
grab_wallpaper:[checked]
mousewheel:1
queued_render_timer:100
rows:1
scale_icon_factor:0.75
scale_icon_mode:2
scale_icon_position:3
scale_icon_mode:3
win_active_icon_alpha:0.64999997615814209
win_grab_method:0
win_grab_mode:3
win_inactive_icon_alpha:1

Desktop is ATI fglrx/compiz at 1680x1050

Recently I changed maximized windows to appear behind the dock icons, though I do not think this has impacted this issue as there are no windows maximized/open when the crash happens on login.

I have a console output screenlet on my desktop, and pull screenlets from Ubuntu-Tweak (along with AWN unstable). Hmm.. maybe I do not qualify with AWN unstable sources ... I will still finish my post.

Also, when I upgraded from intrepid, the -extras did not get installed, so I had an incomplete dock with missing applets configured that resulted in other crashes that were fixed by adding the missing packages (would have been nice to have a graceful notification - likely in the roadmap) I am not certain if the shinyswitcher was one of those that was missing initially due to the missing packages, but I think it may have been.

I will give the PPA a shot and report back any findings; I will also roll back to jaunty vanilla first (remove the ubuntu-tweak sources and force the downgrade) and confirm it still exists.

root@repo:~# dpkg -l | grep awn
ii awn-applets-c-core 0.3.2.1-0ubuntu2 A collection of applets for avant-window-nav
ii awn-applets-c-extras 0.3.2.1-0ubuntu2 A collection of applets for avant-window-nav
ii awn-applets-python-core 0.3.2.1-0ubuntu2 A collection of applets for avant-window-nav
ii awn-applets-python-extras 0.3.2.1-0ubuntu2 A collection of applets for avant-window-nav
ii awn-manager 0.3.2-0ubuntu1 A preferences manager for avant-window-navig
ii libawn-extras0 0.3.2.1-0ubuntu2 A library for avant-window-navigator's apple
ii libawn0 0.3.2-0ubuntu1 library for avant-window-navigator
ii python-awn 0.3.2-0ubuntu1 Python bindings for avant-window-navigator l
ii python-awn-extras 0.3.2.1-0ubuntu2 Python bindings for avant-window-navigator's
ii python-awnlib 0.3.2.1-0ubuntu2 Python utilities for avant-window-navigator'

iMac (imac-netstatz) wrote :

So it looks like the version I was running with this bug was in fact the Jaunty version as noted above by versions; Nothing new was coming from my ubuntu-tweak AWN source. Also, I automatically received Julien's packages via the PPA, after upgrading after that last post, as it is the one I use for my screentlets.

Yes, it does resolve the problem. This explains why my other laptop (that shares home directories/gconf, users, etc) was having no issues, as I had updated it already from your source.

thanks,
iMac

Julien Lavergne (gilir) wrote :

Thanks a lot for the testing.
I'll commit the fix in the official Ubuntu package.

Julien Lavergne (gilir) wrote :

Attached is a debdiff to fix this bug. This patch also fix the bug #347046 which is similar.

Testing package is available in my PPA : https://launchpad.net/~gilir/+archive/updates

Changed in awn-extras-applets (Ubuntu):
assignee: gilir → nobody
importance: Undecided → Medium
status: In Progress → Confirmed
moonbeam (rcryderman) on 2009-04-05
Changed in awn-extras:
status: In Progress → Fix Committed
Mark Lee (malept) on 2009-04-05
Changed in awn-extras:
importance: Undecided → Critical
milestone: none → 0.3.2.2
iMac (imac-netstatz) wrote :

I just experienced another crash today after some time without re-occurance. It appears likely that it may be something new/different, but I can not be sure, as it is the same applet disappearing. All I have is a syslog message.

awn-applet-acti[7385] general protection ip:7f65fabc80ce sp:7fff04944d90 error:0 in libgdk-x11-2.0.so.0.1600.0[7f65faba6000+9d000]

moonbeam (rcryderman) wrote :

iMac,

Could you open up a new bug at https://bugs.launchpad.net/awn-extras (assuming you're using the ppa version of awn now) for your most recent post. Definitely a different issue. The syslog message doesn't give me a lot to go on but it would still be a good idea to get a bug opened.

If you could also take a look in ~/.xsession-errors for any other error message then those would be appreciated. Maybe just doing a

grep 7385 ~/.xsession-errors

and see if anything shows up. If it's awn releated then please put it into the bug. Also, include Window manager (compiz or not), the fact that you're using Jaunty, Video drivers, the awn packages in use etc.

Thanks,

moonbeam (rcryderman) wrote :

Julien,

I would suggest using rev 1162 of extras trunk in addition to the previous patches. I believe rev 1162 fixes the fundamental issue.

Julien Lavergne (gilir) wrote :

Updated debdiff attached.

Julien Lavergne (gilir) on 2009-04-15
Changed in awn-extras-applets (Ubuntu):
status: Confirmed → New
Iulian Udrea (iulian) wrote :

I would like to see some testing before approving it.

Iulian: I didn't see this before I sent my ack. He's been testing this for
a while and the patch is upstream, so I'm pretty sure it's OK. Can you
agree on going forward on that basis?

...... Original Message .......
On Wed, 15 Apr 2009 19:35:43 -0000 Iulian Udrea <email address hidden> wrote:
>I would like to see some testing before approving it.
>
>--
>awn-applet-activation crashed with SIGSEGV in gdk_drawable_get_size()
>https://bugs.launchpad.net/bugs/332928
>You received this bug notification because you are a member of MOTU
>Release Team, which is a direct subscriber.
>

Julien Lavergne (gilir) wrote :

Updated debdiff to fix a bug in python-awn-extras.

A version is available in my PPA (https://edge.launchpad.net/~gilir/+archive/updates). Some quick testing on modified applets don't show for me any regression.

Iulian Udrea (iulian) wrote :

Ack

Changed in awn-extras-applets (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

Uploaded, now needs AA acceptance. Thanks for your work here.

Changed in awn-extras-applets (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awn-extras-applets - 0.3.2.1-0ubuntu3

---------------
awn-extras-applets (0.3.2.1-0ubuntu3) jaunty; urgency=low

  [ Julien Lavergne ]
  * debian/patches/90-shinyswitcher-null-crash-1140.patch
   - From upstream (r1140): Fix for various crash for some configurations.
     (LP: #332928) (LP: #347046).
  * debian/patches/91-shiny-shinyswitcher-init-wallpaper-1162.patch:
   - From upstream (r1162): Initialize wallpaper variable to avoid a
     possible crash.
  * debian/patches/92-notification-daemon-disable-notify-osd-1160-1161.patch:
   - From upstream (r1160 and r1161): Disable notify-osd when
     awn-notification-daemon is actived. (LP: #357273)
  * debian/awn-applets-python-extras.install: Enable pynot applets with
    transparency support (LP: #353443).
  * debian/control:
   - Add description for pynot-rgba applet.
   - Add missing XB-Python-Version for python-awn-extras.

  [ Iain Lane ]
  * Add dependency on python-xlib for pynot-rgba plugin

 -- Julien Lavergne <email address hidden> Wed, 15 Apr 2009 20:29:49 +0200

Changed in awn-extras-applets (Ubuntu):
status: Fix Committed → Fix Released
Mark Lee (malept) wrote :

Fix released in Awn Extras 0.3.2.2.

Changed in awn-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers