New upstream release (version 0.3.2)

Bug #327443 reported by Nick Ellery on 2009-02-10
4
Affects Status Importance Assigned to Milestone
avant-window-navigator (Debian)
Fix Released
Undecided
Unassigned
avant-window-navigator (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: avant-window-navigator

A new upstream release, version 0.3.2 of AWN is available.

Mark Lee (malept) wrote :

We already know, thanks. Julien (the maintainer of the Awn/Awn Extras packages for *both* Debian and Ubuntu) is a member of the upstream teams as well, and even generated/signed the 0.3.2 source tarballs.

(This notice also applies to the Debian bug you filed.)

Changed in avant-window-navigator:
assignee: nobody → gilir
status: New → Confirmed
Changed in avant-window-navigator:
importance: Undecided → Wishlist
status: Confirmed → Triaged
Julien Lavergne (gilir) wrote :

Freeze exception request :

I would like to propose a freeze exception for the 0.3.2 release.

The actual version in Jaunty is a snapshot of the development trunk. The difference between this snapshot and the 0.3.2 release is mostly bugfix changes.(I will post the Changelog diff).

The actual upload to Debian is blocked for various reason, and since the package FTBFS with python 2.6, I prefer to upload it now in Ubuntu.

This upload should fix 3 bugs and I think many other errors reported by apport (g_closure_invoke() and g_cclosure_marshal_VOID() crash).

The upstream tarball is available with the watch file.

Thanks.

Julien Lavergne (gilir) wrote :
Julien Lavergne (gilir) wrote :
Julien Lavergne (gilir) on 2009-03-02
Changed in avant-window-navigator:
assignee: gilir → nobody
status: Triaged → Confirmed
Iulian Udrea (iulian) wrote :

Hello Julien,

What testing have you done?

Could you please attach both build and install logs to this bug report?

I've just changed the status back to NEW as we use CONFIRMED when the exception is granted.

Changed in avant-window-navigator:
status: Confirmed → New
Luca Falavigna (dktrkranz) wrote :

Fine for me, ACK #1.

Julien Lavergne (gilir) wrote :

I tried to install, and run it without problem.
here is still issues if you run applets because they also need to be upgrade to the new version.

You can find testing debs in my PPA (https://edge.launchpad.net/~gilir/+archive/ppa).
Build log : http://launchpadlibrarian.net/23325897/buildlog_ubuntu-jaunty-amd64.avant-window-navigator_0.3.2-0ubuntu1_FULLYBUILT.txt.gz

Julien Lavergne (gilir) wrote :
Iulian Udrea (iulian) wrote :

ACK #2

FFe granted.

Changed in avant-window-navigator:
status: New → Confirmed
Julien Lavergne (gilir) wrote :

Update debian/changelog with last update in Ubuntu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.3.2-0ubuntu1

---------------
avant-window-navigator (0.3.2-0ubuntu1) jaunty; urgency=low

  * New upstream release (Closes : #514681) (LP: #327443)
   - Add a script to delay the start of awn when using the autostart.
     (Closes: #493640)
   - Fix awn-manager permission when trying to edit some desktop file
    (LP: #260987)
   - Update position on screen resolution changes (LP: #276734)
  * debian/awn.wrapper
   - A script to update applets path using awn-applets-migration script.
  * debian/*.install:
   - Add the themes directory to avant-window-navigator-data.install.
   - Add awn-autostart to avant-window-navigator.install.
   - Add awn-applets-migration to awn-manager.install.
   - Remove usr/bin/avant-window-navigator, handle by debian/rules.
   - Install python bindings in *-packages instead of site-packages only,
     needed for the python migration in squeeze (LP: #335785).
  * debian/control:
   - Add missing ${misc:Depends}.
   - Bump Build-Depends and Depends for vala to (>= 0.5.4).
   - Set awn-manager as Depends rather than Recommends, needed by the
     awn-applets-migration script.
   - Remove unnecessary "Section: gnome"
   - Note that the libawn0-dbg contains debuggins symbols.
   - Set Build-Depends on python (>= 2.5) instead of hardcoding the python
     version.
  * debian/awn-autostart.1 & debian/awn-applets-migrations:
   - Add new man pages.
  * debian/avant-window-navigator.links
   - Symlink awn.1 with avant-window-navigator.1
  * debian/rules:
   - Move avant-window-navigator to awn, and copy awn.wrapper to
     avant-window-navigator
   - Add new man pages.
  * debian/patches/
   - 00-wm-behavior.patch : Don't bring the windows to the current workspace
     when the icon of the bar is clicked. Keep the same behavior that the
     gnome-panel applet.
   - 01-tasks-have-arrow.patch: Set the option "Tasks have arrow" by default.
   - 03-python-import.path : Update.
  * debian/copyright
   - Replace (C) by ©.

 -- Julien Lavergne <email address hidden> Mon, 19 Jan 2009 19:35:52 +0100

Changed in avant-window-navigator:
status: Confirmed → Fix Released
Changed in avant-window-navigator:
status: Unknown → New
Luca Falavigna (dktrkranz) wrote :

Unsubscribing motu-release, there are no current tasks available.

Artur Rona (ari-tczew) wrote :

 avant-window-navigator (0.3.2.1-1) unstable; urgency=low

   * New Upstream Version.
   * debian/control
    - Remove depends on python-gnome2 and python-gnome2-desktop for
      awn-manager, not needed anymore.
    - Add python-gtk2 as depends for python-awn.
    - Remove depends on avant-window-navigator for awn-manager to avoid
      circular dependency. This is unnecessary until awn depends on awn-manager
      for the migration script. (Closes: #520120).
    - Add libgnome-desktop-dev and libdbus-glib-1-dev as depends for libawn-dev.
    - Switch from python-central to python-support.
    - Remove X{B,S}-Python-Version.
    - Bump build-depends on debhelper to (>= 7).
    - Remove build-depends on cdbs.
    - Build depends on quilt.
    - Add Vcs fields.
    - Move libawn-dbg section to debug.
    - Bump Standards-Version to 3.8.1 (no change needed).
   * debian/rules:
    - Rewrite to drop the use of cdbs and build python bindings for all versions
      of python.
    - Switch from python-central to python-support.
   * debian/pycompat:
    - Remove.
   * debian/pyversions:
    - Add, python >= 2.4 is supported.
   * debian/compat:
    - Bump to 7.
   * debian/*.manpages:
    - Add for avant-window-navigator and awn-manager.
   * debian/README.source
    - Replace since the package use quilt.
   * debian/patches
    - Switch to use quilt.
   * debian/preinst
    - add preinst maintainer script to clean after pycentral.

 -- Julien Lavergne <email address hidden> Wed, 06 May 2009 09:54:52 +0200

tags: added: upgrade
Changed in avant-window-navigator (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.