Icons located wrong after switching to new resolution

Bug #276734 reported by Martijn van Iersel on 2008-10-01
10
Affects Status Importance Assigned to Milestone
Awn
Low
Unassigned
avant-window-navigator (Ubuntu)
Undecided
Unassigned

Bug Description

I noticed that after attaching an external monitor, which causes the resolution of my desktop to go from 1024x768 to 1280x1024, the icons on the avant window manager are in the wrong position, as though they are stuck on their old location (See screenshot). The icons sometimes reappear at the right position after an indeterminate period (could be seconds, could be half an hour).

I think I managed to fix the issue by forcing a location update after screen resize. See attached debdiff.

This is for hardy, I haven't checked yet how the situation is on intrepid.

description: updated
Julien Lavergne (gilir) wrote :

Thanks for your report.
I'm forwarding it upstream to have their opinion.

Mark Lee (malept) wrote :

It's certainly a minimal patch. Anyone want to test it?

Here is some info on how I could consistently reproduce the glitch (which may help with testing)

* start avant-window-manager on laptop without external monitor plugged (screen resolution 1024x768)
* plug external monitor
* run in terminal
xrandr --output LVDS --mode 1024x768 --output VGA --mode 1280x1024 --above LVDS

In this case LVDS is the laptop screen and VGA is the external monitor
This will turn on the external display and cause avant-window-manager to jump there, with the icons in the wrong position.

s/avant-window-manager/avant-window-navigator/ of course

Julien Lavergne (gilir) wrote :

I apply the patch and build a package for Intrepid on my PPA (https://edge.launchpad.net/~gilir/+archive). Could someone can test the new package and see if the bug still here ?

Thanks.

Julien Lavergne (gilir) wrote :

At least, I can confirm that when you change the resolution of the screen, the bar and icons are now together after the resize.

Mikko Rönkkö (mikko-ronkko) wrote :

For me, the problem persists with the latest packages from the repositories. See the screenshot.

Julien Lavergne (gilir) wrote :

Thanks for the test. Could you just confirm the version of the package you used, I want to be sure your using the right package (because I mess up versions in my PPA earlier).

Thanks.

Julien Lavergne (gilir) on 2008-11-01
Changed in avant-window-navigator:
status: New → Incomplete
Julien Lavergne (gilir) wrote :

Thanks for the patch, commited on r513

Changed in awn:
importance: Undecided → Low
milestone: none → 0.3.2
status: New → Fix Committed

Nice, you're welcome

Julien Lavergne (gilir) wrote :

Will be fix in Ubuntu when 0.3.2 will be upload.

Changed in avant-window-navigator:
status: Incomplete → In Progress
moonbeam (rcryderman) on 2009-02-09
Changed in awn:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.3.2-0ubuntu1

---------------
avant-window-navigator (0.3.2-0ubuntu1) jaunty; urgency=low

  * New upstream release (Closes : #514681) (LP: #327443)
   - Add a script to delay the start of awn when using the autostart.
     (Closes: #493640)
   - Fix awn-manager permission when trying to edit some desktop file
    (LP: #260987)
   - Update position on screen resolution changes (LP: #276734)
  * debian/awn.wrapper
   - A script to update applets path using awn-applets-migration script.
  * debian/*.install:
   - Add the themes directory to avant-window-navigator-data.install.
   - Add awn-autostart to avant-window-navigator.install.
   - Add awn-applets-migration to awn-manager.install.
   - Remove usr/bin/avant-window-navigator, handle by debian/rules.
   - Install python bindings in *-packages instead of site-packages only,
     needed for the python migration in squeeze (LP: #335785).
  * debian/control:
   - Add missing ${misc:Depends}.
   - Bump Build-Depends and Depends for vala to (>= 0.5.4).
   - Set awn-manager as Depends rather than Recommends, needed by the
     awn-applets-migration script.
   - Remove unnecessary "Section: gnome"
   - Note that the libawn0-dbg contains debuggins symbols.
   - Set Build-Depends on python (>= 2.5) instead of hardcoding the python
     version.
  * debian/awn-autostart.1 & debian/awn-applets-migrations:
   - Add new man pages.
  * debian/avant-window-navigator.links
   - Symlink awn.1 with avant-window-navigator.1
  * debian/rules:
   - Move avant-window-navigator to awn, and copy awn.wrapper to
     avant-window-navigator
   - Add new man pages.
  * debian/patches/
   - 00-wm-behavior.patch : Don't bring the windows to the current workspace
     when the icon of the bar is clicked. Keep the same behavior that the
     gnome-panel applet.
   - 01-tasks-have-arrow.patch: Set the option "Tasks have arrow" by default.
   - 03-python-import.path : Update.
  * debian/copyright
   - Replace (C) by ©.

 -- Julien Lavergne <email address hidden> Mon, 19 Jan 2009 19:35:52 +0100

Changed in avant-window-navigator:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers