Avahi daemon interacts badly with network-manager

Bug #82287 reported by Vincenzo Ciancia on 2007-01-30
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
avahi (Ubuntu)
Undecided
Trent Lloyd
Nominated for Feisty by Massimo Forti

Bug Description

Binary package hint: avahi-daemon

avahi-daemon is installed by default in feisty. Installing networkmanager, even if removing static stanzas from /etc/network/interfaces, will not make these interfaces available to networkmanager. Running "ifconfig" shows that these interfaces have aliases of the form eth*:avahi and networkmanager does not manage these.

I have tried again, and there where "eth0:avahi", "eth0" and "eth1" already up, but no "eth1:avahi". However, networkmanager didn't even attempt to scan available wireless networks (eth1 is my wireless card) until I wrote "ifdown eth1". This all just after boot. Maybe network-manager and avahi-daemon are conflicting packages and not marked so?

Scott Bronson (bronson) wrote :

I find it very surprising that this bug is still Unconfirmed. This is a major problem!

After installing release Fesity on my T-42p laptop, network manager refused to show any wireless networks until I inserted an "exit 0" at the top of /etc/init.d/avahi-daemon. This is bone stock Feisty, straight off the release CD. Not many Ubuntu users are going to be able to figure this out on their own!

Trent Lloyd (lathiat) wrote :

This is odd... there is no reason avahi-daemon should affect Network managers access in any way.
I will attempt to find out how you can find some debug info out.

Trent Lloyd (lathiat) on 2007-04-25
Changed in avahi:
assignee: nobody → lathiat
Massimo Forti (slackwarelife) wrote :

This link report the same bug:

https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/94940

You can see it.

thanks

Massimo Forti (slackwarelife) wrote :

Now We can try to resolve it doing these steps:

1) open /etc/network/intefaces and put # before the line after "lo" like this:

#/etc/network/interfaces
auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

#auto ath1
#iface ath1 inet dhcp

#auto ath2
#iface ath2 inet dhcp

#auto wlan0
#iface wlan0 inet dhcp

2) open networkmanager and enable roaming mode for all your interfaces

3) modify the nsswitch.conf file to:

         hosts: files mdns4_minimal [NOTFOUND=return] dns

thanks

Vincenzo Ciancia (vincenzo-ml) wrote :

Seems solved to me in hardy anyone can comment?

Changed in avahi:
status: New → Incomplete
Loye Young (loyeyoung) wrote :

>Seems solved to me in hardy anyone can comment?

>I have tried again, and there where "eth0:avahi", "eth0" and "eth1" already up, but no "eth1:avahi".

This is because avahi can only configures one interface. To do otherwise would require separate resolver caches for each network interface, in accordance with RFC4795 (http://www.ietf.org/rfc/rfc4795.txt) at Sections 4.3 and 5.4. Implementing such behavior would increase vulnerabilities to denial of service (id. at Section 5.1) and spoofing (id. at Section 5.3) man-in-the-middle attacks and would reduce resolver performance (see manpage of resolv.conf). The security vulnerabilities can be mitigated by following the guidelines suggested in RFC4795 at 5.2, but will not be entirely eliminated, especially in the context of internet cafes and public wifi zones.

>there is no reason avahi-daemon should affect Network managers access
There is an indirect connection between the two. The problem centers around the way avahi-autoipd interacts with dhcdbd, which both ignore or interfere with the configuration found in /etc/network/interfaces. More generally and fundamentally, networking is unstable in the default installation because IP addresses are allocated using three parallel systems that don't work together very well: dhclient/ifupdown, dhclient/dhcdbd, and avahi-daemon/avahi-autoipd.

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://www.iycc.biz

Daniel T Chen (crimsun) on 2008-09-20
Changed in avahi:
status: Incomplete → Confirmed
Luke Plant (spookylukey) wrote :

I'm seeing this in hardy (though I never remember seeing it before). I'm used a wired connection to a router, and every so often my internet connection disappears. When this happens, I find "eth0:avahi" in the output of ifconfig, and the "eth0" line has no "inet addr" line (only "inet6"). Doing ifdown/ifup solves it temporarily.

I tried killing NetworkManager in case it was interfering, but it made no difference.

I'm don't currently how to set networkmanager to roaming, as I'm on KDE, and the program that controls it, knetworkmanager, only seems to handle wireless connections.

summary: - [feisty] avahi daemon interacts badly with network-manager
+ Avahi daemon interacts badly with network-manager
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions