avahi-daemon hangs 'starting up' with v2.6.38 based kernels

Bug #704372 reported by Andy Whitcroft on 2011-01-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Avahi
Fix Released
Unknown
Debian
Fix Released
Unknown
avahi (Ubuntu)
High
Unassigned
Lucid
Undecided
Unassigned
Natty
High
Unassigned
linux (Ubuntu)
Undecided
Andy Whitcroft
Lucid
Undecided
Unassigned
Natty
Undecided
Andy Whitcroft

Bug Description

A change in the mainline kernel to fix a bug in netlink request flag handling has exposed a corresponding bug in the use of netlink within avahi. This leads to the daemon hanging during initialisation appearing as below:

    $ ps -ef | grep avahi
    avahi 2497 1 0 11:26 ? 00:00:00 avahi-daemon: starting up

This situation persists indefinatly. All requests timeout and the machine is not visible on the greater network.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: avahi-daemon 0.6.28-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-1.27~masterplay201101171654-generic 2.6.38
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Tue Jan 18 11:27:48 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: avahi

Andy Whitcroft (apw) wrote :
Andy Whitcroft (apw) wrote :

I have filed a bug with avahi upstream, and attached the patch there: http://avahi.org/ticket/328

Andy Whitcroft (apw) wrote :

Avahi uses netlink to determine the list of interfaces and the list of addresses in the system. When doing so we perform a NLM_F_ROOT search. Previously this would (incorrectly) return all matches due to a bug in the kernel decoding of the NLM_F_* flags. Following the commit below this is now corrected leading the avahi daemon to hang on start:

    commit 0ab03c2b1478f2438d2c80204f7fef65b1bca9cf
    Author: Jan Engelhardt <jengelh@…>
    Date: Fri Jan 7 03:15:05 2011 +0000

        netlink: test for all flags of the NLM_F_DUMP composite

Andy Whitcroft (apw) wrote :

See the lp:~apw/avahi/fix-netlink-wildcard which contains a local application of the fix.

Paul Sladen (sladen) on 2011-01-18
Changed in avahi (Ubuntu Natty):
status: New → Confirmed
Changed in avahi (Ubuntu Lucid):
status: New → Incomplete
Changed in avahi (Ubuntu Natty):
importance: Undecided → High
status: Confirmed → Triaged
Paul Sladen (sladen) wrote :

People expect natty to be broken, the bigger concern is if this kernel gets backported to 10.04 LTS; then the avahi fix probably needs to have gone back first.

Changed in avahi:
status: Unknown → New
Changed in debian:
status: Unknown → Confirmed
Changed in avahi (Ubuntu Natty):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Andy Whitcroft (apw) on 2011-02-11
Changed in linux (Ubuntu Natty):
status: New → Fix Released
assignee: nobody → Andy Whitcroft (apw)
Changed in linux (Ubuntu Lucid):
status: New → Invalid
Changed in avahi (Ubuntu Natty):
assignee: Canonical Kernel Team (canonical-kernel-team) → nobody
Changed in avahi:
status: New → Fix Released
Changed in debian:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the issue has been fixed in 0.6.29 which is the current natty version

Changed in avahi (Ubuntu Natty):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in avahi (Ubuntu Lucid):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.