autotalent utilizes uninitialized/bad variables, which can cause crashes

Bug #1299667 reported by Ronald J. Wright
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
autotalent (Ubuntu)
Undecided
Unassigned

Bug Description

I was using the autotalent LADSPA plugin with Audacity, and I noticed that it kept crashing occasionally. I used gdb to track down the cause of the crashes, and I noticed that there were two problems with autotalent:

1) A potential division by zero during normalization of audio data may occur, and
2) Several uninitialized Autotalent struct member variables may be used.

Attached is a patch that addresses these problems. I no longer notice Audacity crashing with the patched plugin.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: autotalent 0.2-2
ProcVersionSignature: Ubuntu 3.11.0-18.32-generic 3.11.10.4
Uname: Linux 3.11.0-18-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Sat Mar 29 21:17:09 2014
Dependencies:
 gcc-4.8-base 4.8.1-10ubuntu9
 libc6 2.17-93ubuntu4
 libgcc1 1:4.8.1-10ubuntu9
 multiarch-support 2.17-93ubuntu4
InstallationDate: Installed on 2013-02-28 (394 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: autotalent
UpgradeStatus: Upgraded to saucy on 2014-01-22 (66 days ago)

Related branches

Revision history for this message
Ronald J. Wright (logiconcepts819) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Patch that addresses the aformentioned problems." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Fixed in Debian.
Thanks.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autotalent - 0.2-4

---------------
autotalent (0.2-4) unstable; urgency=low

  * Add patch to prevent SIGSEGV. (LP: #1299667)
  * Bump Standards.

 -- Alessio Treglia <email address hidden> Wed, 18 Jun 2014 13:12:11 +0100

Changed in autotalent (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments