Can't increase the wait_for_ssh timeout

Bug #1488358 reported by Leo Arias on 2015-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
autopkgtest (Ubuntu)
Medium
Unassigned

Bug Description

I have a test that I run with adt-virt-ssh that is taking long to reboot, but there's no way to increase the timeout for the ssh connection in adt-run.
Please, make the wait_for_ssh timeout an argument that can be configured when calling the test run.

Related branches

Martin Pitt (pitti) on 2015-08-25
Changed in autopkgtest (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

What times out exactly? Does it take > 5 minutes for the target to shut down, or > 5 minutes for the target to come back up? Which runner are you using (ssh/qemu/lxc/etc.)? Can you please attach a log with --debug on both adt-run and the adt-virt-* you are using? Thanks!

Changed in autopkgtest (Ubuntu):
status: Triaged → Incomplete
Leo Arias (elopio) wrote :

Sorry, yesterday I left the test running in a loop to see if we hit the issue, because I was not sure if the machine booted. Now I have more information.

This is snappy and we are testing the failover boot. So the target shuts down, restarts, it fails to boot, switches to the previous partition and boots again. Here is the full log: http://paste.ubuntu.com/12193270/

It's taking less than 80 seconds to boot. We are using the adt-virt-ssh, and it fails on wait_for_ssh, which seems to have a timeout of 300. So I'm confused.

Here's the machine log: http://paste.ubuntu.com/12193252/

I didn't run it with -d for adt-virt-ssh, so I'll trigger the loop again.

Leo Arias (elopio) wrote :

That was fast. Here's the log with ssh -d:
http://paste.ubuntu.com/12193540/

Leo Arias (elopio) wrote :

Ok, now I saw it while it timed out.
Here's the adt-run log: http://paste.ubuntu.com/12194656/
Here's the test bed log: http://paste.ubuntu.com/12194655/

The test bed prints:
[ 43.036745] systemd[1]: Started udev Coldplug all Devices.

And gets stuck there for more seconds.

That's when adt-run prints:
<VirtSubproc>: failure: Timed out on waiting for ssh connection

After some more time, the machine prints:
Ubuntu Wily Werewolf (development branch) snappy-rolling-edge ttyS0

And I can ssh into it.

So, we need to increase the wait_for_ssh timeout.

summary: - Can't increase the reboot timeout
+ Can't increase the wait_for_ssh timeout
description: updated
Changed in autopkgtest (Ubuntu):
status: Incomplete → Confirmed
Leo Arias (elopio) wrote :
Martin Pitt (pitti) wrote :
Changed in autopkgtest (Ubuntu):
status: Confirmed → Fix Committed

The attachment "timeout.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autopkgtest - 3.17.1

---------------
autopkgtest (3.17.1) unstable; urgency=medium

  * Add new private python modules to Makefile, to actually ship them.
  * tests/adt-run: Fix test regression when $ADT_TEST* are not set.

 -- Martin Pitt <email address hidden> Tue, 15 Sep 2015 08:38:54 +0200

Changed in autopkgtest (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers