Ubuntu

autopkgtest should provide apt debug log

Reported by Ian Jackson on 2007-08-29
4
Affects Status Importance Assigned to Milestone
autopkgtest (Ubuntu)
Medium
Ian Jackson

Bug Description

Binary package hint: autopkgtest

14:28 <seb128> iwj: bug #135519, do you think those bugs could have an apt
               debug log or something like that?
14:28 <ubotu> Launchpad bug 135519 in compiz "autopkgtest gutsy compiz amd64:
              erroneous package!" [High,New] https://launchpad.net/bugs/135519
14:28 <seb128> iwj: the bug has been opened on compiz but the issue is
               libcompizconfig0 not being installable and there is no detail (I
               think that's a transitional issue, mvo uploaded a new stack with
               Breaks use today)
14:28 <iwj> seb128: I could probably organise that. How would I acquire one ?
14:29 <seb128> iwj: probably by setting Debug::pkgProblemResolver to true in
               the apt configuration
14:29 <iwj> seb128: Right, if it's just a transitional problem feel free to
            close the bug with `this is fixed now we think'.
14:30 <seb128> iwj: is there a way to determine that the bug is a "package not
               installable" and do a new try with this one set in this case?
14:30 <iwj> The tester can't really tell if uninstallability is just transient
            or not.
14:30 <iwj> I think it would be better just to turn on the debugging in general.
14:30 <seb128> mvo: ^ what do you think?
14:30 <iwj> Or to capture it and suck it out.
14:30 <iwj> I mean, suck it out if the installation fails.
14:31 <seb128> right, that would be nice
14:34 <seb128> mvo: would it be possible to make apt smarter about displaying
               errors?
14:34 <seb128> it display package is not installable because <list of depends
               not installable>
14:34 <seb128> but doesn't mention where is the issue in the list of depends
14:34 <seb128> and what prevents it to be installed
14:34 <mvo> seb128: probably

Ian Jackson (ijackson) on 2007-08-29
Changed in autopkgtest:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → ijackson
Ian Jackson (ijackson) wrote :

Following discussion on irc, and tests, this can be achived by setting
 Debug::pkgProblemResolver=true
and this should be done globally for all of autopkgtest's apt invocations.

Ian Jackson (ijackson) wrote :

This has been enabled for some time now.

Changed in autopkgtest:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers