Autokey crashes on post-install, "stop" action checks the return message rather than the return code.

Bug #479131 reported by cinqueggi
142
This bug affects 23 people
Affects Status Importance Assigned to Milestone
AutoKey
Unknown
Unknown
autokey (Ubuntu)
Medium
Unassigned
Karmic
Medium
Unassigned

Bug Description

Binary package hint: autokey

everytime i install something...at 87% there is an autokey error

ProblemType: Package
Architecture: i386
Date: Mon Nov 9 13:40:30 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: autokey 0.54.5-1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: autokey
Title: package autokey 0.54.5-1 failed to install/upgrade: il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
Uname: Linux 2.6.31-14-generic i686

:: SRU Request ::
This bug is SRU-worthy because it blocks uninstallation on non-english locales. It is fixed in 0.61.0a-1, which was just installed into Lucid. The bug is a one line fix where we check errno rather than the error string.

Regression potential: none

:: TEST CASE ::

:: WHAT HAPPENS CURRENTLY ::
root@karmic-vm:~# echo $LANG
en_US.UTF-8
root@karmic-vm:~# invoke-rc.d autokey start
root@karmic-vm:~# pkill -9 -f autokey
root@karmic-vm:~# LC_ALL=fr_FR.UTF-8 invoke-rc.d autokey stop
[Errno 3] Aucun processus de ce type
invoke-rc.d: initscript autokey, action "stop" failed.
root@karmic-vm:~#

And if the pid file is still there, autokey refuses to start.
root@karmic-vm:~# LC_ALL=fr_FR.UTF-8 invoke-rc.d autokey start
pidfile /tmp/autokey-daemon.pid already exist. Daemon already running?
invoke-rc.d: initscript autokey, action "start" failed.

:: WHAT SHOULD HAPPEN::
root@Opus:~# invoke-rc.d autokey start
root@Opus:~# pkill -9 -f autokey
root@Opus:~# LC_ALL=fr_FR.UTF-8 invoke-rc.d autokey stop

Revision history for this message
cinqueggi (thegreatest5555) wrote :
Luke Faraone (lfaraone)
Changed in autokey (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Luke Faraone (lfaraone)
summary: - always an autokey error!
+ Autokey crashes on post-install, should "restart" if daemon already
+ running
Revision history for this message
Luke Faraone (lfaraone) wrote : Re: Autokey crashes on post-install, should "restart" if daemon already running

As a workaround until we release a fix, can you tell me if the following works when run in the terminal:
 sudo /etc/init.d/autokey stop
 sudo dpkg --configure -a

Revision history for this message
Luke Faraone (lfaraone) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. I wasn't able to reproduce your problem when I reinstalled the autokey package. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?
* Did you install autokey from another source prior to upgrading to Karmic?

This will help us to find and resolve the problem.

Changed in autokey (Ubuntu):
status: New → Incomplete
Revision history for this message
pcpcpc75 (pcpcpc75) wrote :

Hello Luke Faraone, thank you for your time. Here about terminal instruction....

k@ubuntu:~$ sudo /etc/init.d/autokey stop
[Errno 3] Nessun processo
k@ubuntu:~$ sudo dpkg --configure -a
k@ubuntu:~$

About your question.....

1 - I can't try if this is reproducible. I can't uninstall, reinstall this pack. Every time feedback the same message error.
2 - NN
3 - I installed autokey directly in Karmic, from pack-service.

P.

Revision history for this message
Luke Faraone (lfaraone) wrote :

Looks like this is a localization bug. Replace the "stop" command above with this:
 LC_ALL=en_US.UTF-8 sudo /etc/init.d/autokey stop

and tell me if that works for you.

summary: - Autokey crashes on post-install, should "restart" if daemon already
- running
+ Autokey crashes on post-install, "stop" action checks the return message
+ rather than the return code.
Changed in autokey (Ubuntu):
status: Incomplete → In Progress
Luke Faraone (lfaraone)
Changed in autokey (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autokey - 0.61.0a-1

---------------
autokey (0.61.0a-1) unstable; urgency=low

  * New upstream version
  * Patch daemon.py to fix bugs in non-english locales (LP: #479131)
 -- Ubuntu Archive Auto-Sync <email address hidden> Mon, 21 Dec 2009 10:43:10 +0000

Changed in autokey (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Luke Faraone (lfaraone) wrote :

This bug is SRU-worthy because it blocks uninstallation on non-english locales. It is fixed in 0.61.0a-1, which was just installed into Lucid. The bug is a one line fix where we check errno rather than the error string.

Regression potential: none

:: TEST CASE ::
root@karmic-vm:~# echo $LANG
en_US.UTF-8
root@karmic-vm:~# invoke-rc.d autokey start
root@karmic-vm:~# pkill -9 -f autokey
root@karmic-vm:~# LC_ALL=fr_FR.UTF-8 invoke-rc.d autokey stop
[Errno 3] Aucun processus de ce type
invoke-rc.d: initscript autokey, action "stop" failed.
root@karmic-vm:~#

And if the pid file is still there, autokey refuses to start.
root@karmic-vm:~# LC_ALL=fr_FR.UTF-8 invoke-rc.d autokey start
pidfile /tmp/autokey-daemon.pid already exist. Daemon already running?
invoke-rc.d: initscript autokey, action "start" failed.

Revision history for this message
John Dong (jdong) wrote :

ACK from ubuntu-sru for the contents of the patch. Please fix the version number and upload target suite before uploading, thanks!

Revision history for this message
Luke Faraone (lfaraone) wrote :
description: updated
Revision history for this message
Jonathan Riddell (jr) wrote :

accepted into karmic-proposed, please test

Changed in autokey (Ubuntu Karmic):
status: New → In Progress
tags: added: verification-needed
Luke Faraone (lfaraone)
Changed in autokey (Ubuntu Karmic):
importance: Undecided → Medium
Luke Faraone (lfaraone)
tags: added: verification-failed
removed: verification-needed
Revision history for this message
Luke Faraone (lfaraone) wrote :

Attach debdiff which *actually* fixes the bug. Personally verified as working.

description: updated
Revision history for this message
Luke Faraone (lfaraone) wrote :
Revision history for this message
John Dong (jdong) wrote :

ACK from SRU for updated debdiff

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in autokey (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Verification succeeded with karmic-proposed.
test log attached. Thanks

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autokey - 0.54.5-1ubuntu0.2

---------------
autokey (0.54.5-1ubuntu0.2) karmic-proposed; urgency=low

  * Include simple-patchsys in debian/rules so prior patch is applied. (LP: #479131)
 -- Luke Faraone <email address hidden> Sat, 16 Jan 2010 10:17:12 -0500

Changed in autokey (Ubuntu Karmic):
status: Fix Committed → Fix Released
merote (merote)
Changed in autokey (Ubuntu):
assignee: Luke Faraone (lfaraone) → nobody
Revision history for this message
marcos.tc (marcos-tc) wrote :

This error occurs on version autokey_0.54.5-lubuntu0.2_all.deb
pt_BR.UTF-8

Erro ao atualizar utilizando gerenciador de atualizações
E: /var/cache/apt/archives/autokey_0.54.5-1ubuntu0.2_all.deb: sub-processo novo script pre-removal retornou estado de saída de erro 1

invoke-rc.d: initscript autokey, action "stop" failed
dpkg: aviso antigo script pre-removal retornou um erro 1 como status de saída
dpkg - tentando script do novo pacote em vez disso ...
[Errno 3] Processo inexistente
invoke-rc.d: initscript autokey, action "stop" failed.
dpkg: ero processando /var/cache/apt/archives/autokey_0.54.5-lubuntu0.2_all.deb (--unpack):
sub-processo novo script pre-removal retornou estado de saída de erro 1
pidfile /tmp/autokey-daemon.pid already exist. Daemon already running?
invoke-rc.d: initscript autokey, action "start" failed.
dpkg: erro enquanto efetuava a limpeza:
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/autokey_0.54.5-lubuntu0.2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Um pacote falhou na instalação. Tentando recuperar:
dpkg: erro processando autokey (--configure):
 O pacote está em um estado de inconsistência muito ruim - você deveria
reinstalá-lo antes de tentar uma configuração.
Erros foram encontrados durante o processamento de:
autokey

pionero (pionero-gmail)
Changed in autokey (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

Please don't change bug status without explanation.

Changed in autokey (Ubuntu):
status: Fix Committed → Fix Released
drogs45 (drogs45)
Changed in autokey (Ubuntu):
status: Fix Released → Fix Committed
Steve Langasek (vorlon)
Changed in autokey (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.