autokey-gtk crashed with TypeError in on_delete_item(): function takes at most 0 arguments (2 given)

Bug #1138033 reported by Sasa Paporovic on 2013-03-01
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
AutoKey
Unknown
Unknown
autokey (Debian)
Fix Released
Unknown
autokey (Ubuntu)
Medium
Luke Faraone

Bug Description

autokey crashed on deleting a script right after created it.

Steps to reproducing:

1.Start autokey
2.Use File ->New -> Script
3.See a new script apeearing in the sidebar called "New Script"
4.Right mouse click on it -> delete script
5.See autokey crashing

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: autokey-gtk 0.90.1-1.1
ProcVersionSignature: Ubuntu 3.5.0-26.40-generic 3.5.7.6
Uname: Linux 3.5.0-26-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Fri Mar 1 16:38:04 2013
ExecutablePath: /usr/bin/autokey-gtk
InstallationDate: Installed on 2013-01-13 (47 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/autokey-gtk
ProcEnviron:
 PATH=(custom, no username)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/autokey-gtk']
SourcePackage: autokey
Title: autokey-gtk crashed with TypeError in on_delete_item(): function takes at most 0 arguments (2 given)
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/autokey/gtkui/configwindow.py", line 1156, in on_delete_item
     refs.append(Gtk.TreeRowReference(theModel, path))
 TypeError: function takes at most 0 arguments (2 given)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Sasa Paporovic (melchiaros) wrote :
information type: Private → Public
tags: removed: need-duplicate-check
Changed in autokey (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in autokey (Ubuntu):
status: New → Confirmed

I'm running Ubuntu 13.10 Desktop 64bit.

AutoKey-GTK won't allow me to delete scripts or phrases. I can rename them, but when I try to delete, nothing happens.

tags: added: saucy
Luke Faraone (lfaraone) on 2013-10-07
Changed in autokey (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Changed in autokey (Debian):
status: Unknown → New
Changed in autokey (Debian):
status: New → Fix Committed
Changed in autokey (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.