autofs.schema in wrong location

Bug #699855 reported by m00dawg on 2011-01-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
autofs5 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: autofs5

The autofs5-ldap package is installed the autofs.schema in /etc/ldap when it should actually go in /etc/ldap/schema:

root@domainator:~# apt-get install autofs-ldap
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  autofs5 autofs5-ldap
The following NEW packages will be installed:
  autofs-ldap autofs5 autofs5-ldap
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/786kB of archives.
After this operation, 2,015kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package autofs5.
(Reading database ... 49945 files and directories currently installed.)
Unpacking autofs5 (from .../autofs5_5.0.5-0ubuntu2_amd64.deb) ...
Selecting previously deselected package autofs5-ldap.
Unpacking autofs5-ldap (from .../autofs5-ldap_5.0.5-0ubuntu2_amd64.deb) ...
Selecting previously deselected package autofs-ldap.
Unpacking autofs-ldap (from .../autofs-ldap_5.0.5-0ubuntu2_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up autofs5 (5.0.5-0ubuntu2) ...

Creating config file /etc/auto.master with new version

Creating config file /etc/auto.net with new version

Creating config file /etc/auto.misc with new version

Creating config file /etc/auto.smb with new version

Creating config file /etc/default/autofs with new version
autofs start/running, process 5763
Setting up autofs5-ldap (5.0.5-0ubuntu2) ...
Setting up autofs-ldap (5.0.5-0ubuntu2) ...
root@domainator:~# ls /etc/ldap/autofs.schema
/etc/ldap/autofs.schema
root@domainator:~# ls /etc/ldap/schema/autofs.schema
ls: cannot access /etc/ldap/schema/autofs.schema: No such file or directory

Related branches

James Page (james-page) on 2011-01-20
tags: added: maverick
James Page (james-page) wrote :

Confirmed on maverick - this will impact both maverick and natty.

It does not impact core functionality as schemas still have to be loaded into an ldap server manually but it would be nice if they where all located in /etc/ldap/schemas.

tags: added: natty
Changed in autofs5 (Ubuntu):
status: New → Confirmed
James Page (james-page) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in autofs5 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
m00dawg (tim-moocowproductions) wrote :

I am happy to help! Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autofs5 - 5.0.5-0ubuntu5

---------------
autofs5 (5.0.5-0ubuntu5) natty; urgency=low

  * Improve autofs.conf upstart script. Prevent race
    when trying to start networking. (LP: #733914)
  * debian/autofs5-ldap.install: Install schema in the right place.
    (LP: #699855)
  * Suggest smbfs if you want to use cifs. (LP: #579857)
  * Dropped 13ldap_module_linkage.dpatch no longer needed.
  * Refresh with missing upstream patches.
 -- Chuck Short <email address hidden> Sat, 02 Apr 2011 22:25:34 -0400

Changed in autofs5 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers