Ubuntu

package autofs5 5.0.4-3.1ubuntu4 failed to install/upgrade: trying to overwrite '/usr/sbin/automount', which is also in package autofs 0:4.1.4+debian-3ubuntu1

Reported by peter swain on 2010-02-11
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
autofs5 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: autofs5

looks like it needs a "Replaces: autofs" property, to make old one go away first.
Or is autofs just a metapackage requring autofs4 or autofs5?

I'd used apt-get dist-upgrade, so was prepared for this type of error, autofs5 was reported "held back" by apt-get upgrade, but it was a convenient time to pull in some pending upgrades

cured by apt-get install -f

ProblemType: Package
Architecture: amd64
Date: Thu Feb 11 09:48:09 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: trying to overwrite '/usr/sbin/automount', which is also in package autofs 0:4.1.4+debian-3ubuntu1
Package: autofs5 5.0.4-3.1ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-12.17-server
SourcePackage: autofs5
Title: package autofs5 5.0.4-3.1ubuntu4 failed to install/upgrade: trying to overwrite '/usr/sbin/automount', which is also in package autofs 0:4.1.4+debian-3ubuntu1
Uname: Linux 2.6.32-12-server x86_64

Related branches

peter swain (swine) wrote :
Changed in autofs5 (Ubuntu):
status: New → Confirmed
Chuck Short (zulcss) wrote :

This should be fixed in lucid now.

Regards
chuck

Changed in autofs5 (Ubuntu):
status: Confirmed → Fix Released
Simon Huerlimann (huerlisi) wrote :

Hi Chuck

Reopened as it's not fixed, yet. Looking at the debdiff it looks like the fix didn't make it into the package?

See http://launchpadlibrarian.net/39042043/autofs5_5.0.4-3.1ubuntu3_5.0.4-3.1ubuntu4.diff.gz

Only the changelog and the maintainer changed, no dependency or conflict changes...

Changed in autofs5 (Ubuntu):
status: Fix Released → Confirmed
Praxis (ebiow) wrote :

I did a distro upgrade from karmic to lucid without using the upgrade manager. I just replaced karmic with lucid in my sources.list, updated, and did a apt-get dist-upgrade. So medibuntu, partner, backports, updates, restricted & multiverse were enabled during the upgrade as well. I did this because I already had the debs on my local server using approx and didn't want to have to download them again.

Two packages hung up, autofs/autofs5 & libanyevent-perl. I removed those and a a couple of programs that depended upon them with 'apt-get remove' and the dist-upgrade continued. Or at least the machine thrashed around and installed a bunch of programs. I had to continue with 'apt-get dist-upgrade' after both rounds of program removals and subsequent upgrades. When I finished upgrading I rebooted but couldn't log in to KDE, I was bounced back to the KDM. So I'm now using Gnome, but I got a warning that that I didn't have autofs and libanyevent, so I sent the automated bug report (I believe) and was escorted to this page. Now that I'm back in the GUI I successfully installed autofs and libanyevent-perl, so I'll try KDE again.

 BTW, I updated another machine with a similar process a couple of days ago and had a similar experience, again, those two packages required manual removal for the upgrade to lucid to go throw. Perhaps I'm just having these issues because I have so many extraneous repositories enabled during my upgrade.

Chuck Short (zulcss) on 2010-06-30
Changed in autofs5 (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autofs5 - 5.0.5-0ubuntu2

---------------
autofs5 (5.0.5-0ubuntu2) maverick; urgency=low

  [Joel Ebel]
  * debian/patches/16group_buffer_size.patch: Increase group buffer size
    geometrically rather than linearly when its found to be small.
    (LP: #591100)

  [Chuck Short]
  * debian/control: Fix conflict resolution. (LP: #520601)
 -- Chuck Short <email address hidden> Wed, 30 Jun 2010 08:06:45 -0400

Changed in autofs5 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers