Autofs5 fails on cascading/hierarchical mounts

Bug #588523 reported by dezibelz
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
autofs (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: autofs

We use cascading mounts to reduce the number of NFS mounts. Consider the following situation: When a user accesses /home/<username>, all homes exported on our file server should be mounted at /net/user (via NFS) if it didn't happen earlier. After that, the directory /net/user/<username> should be bind to /home/<username> (via a local bind mount). This cascading automount configuration could look as follows (In reality, we use autofs5-ldap and LDAP maps, but I checked with the following configuration as well):

Contents of auto.master:
/- auto.direct
/home auto.home

Contents of auto.direct:
/net/user -rw fileserver:/home/user

Contents of auto.home:
* -rw :/net/user/&

Expected behavior: As described above.

Observed behavior: Bind mounts fails with the package autofs5_5.0.4-3.1ubuntu5_i386 in lucid because the NFS mount is not executed beforehand (the debug logs tell about a non-existing special device).
However, everything works as expected if using the compile option
DISABLE_MOUNT_LOCKING
and building adapted autofs5 packages.

This is the resulting automount:
$ automount -V
Linux automount version 5.0.4

Directories:
 config dir: /etc/default
 maps dir: /etc
 modules dir: /usr/lib/autofs

Compile options:
  DISABLE_MOUNT_LOCKING ENABLE_FORCED_SHUTDOWN ENABLE_IGNORE_BUSY_MOUNTS
  WITH_HESIOD WITH_LDAP WITH_SASL LIBXML2_WORKAROUND

$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

Related branches

dezibelz (dezibelz)
description: updated
Revision history for this message
Scott Moser (smoser) wrote :

Did this work with previous versions of Ubuntu ?

Revision history for this message
dezibelz (dezibelz) wrote :

With Ubuntu 9.10 "karmic", we used autofs4: autofs_4.1.4+debian-2.1ubuntu2_i386.deb. Cascading mounts worked with this package.
user@karmic:# automount -V
Linux automount version 4.1.4

For example, with openSUSE 11.1 and with autofs5, cascading mounts are also possible in the default configuration. openSUSE uses the following compile opitions:
user@suse:# automount -V

Linux automount version 5.0.3

Directories:
 config dir: /etc/sysconfig
 maps dir: /etc
 modules dir: /usr/lib64/autofs

Compile options:
  DISABLE_MOUNT_LOCKING ENABLE_FORCED_SHUTDOWN ENABLE_IGNORE_BUSY_MOUNTS
  WITH_LDAP WITH_SASL

Chuck Short (zulcss)
Changed in autofs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Brice Arnould (un-brice) wrote :

I Think it has been fixed in autofs5.0.5 (natty) by this patch :
http://git.kernel.org/?p=linux/storage/autofs/autofs.git;a=commitdiff;h=6c21fce31efe5206355af2e03422708cff29d501

Could somebody test it ?

Revision history for this message
KennoVO (kenno-xs4all) wrote :

We tried autofs5.0.5 (natty) and autofs5.0.6 (oneiric), but the problem persisted (on 32-bit Lucid). Then we tried autofs4.1.4 (karmic) - same version as mentioned by dezibelz - and the problems went away (still on 32-bit Lucid). But it's obviously not ideal to be running an old unsupported version like that...

Anyhow, bottom line is that it's not fixed yet.

Revision history for this message
KennoVO (kenno-xs4all) wrote :

By the way, importance = Wishlist ??? This is clearly a regression, ie. something that used to work as expected, and now doesn't work as expected anymore. Set the importance as low as you want, but please don't make it look like a feature request!

Furthermore, the "bug heat" and # of people affected by this bug are in fact higher than most of the "importance=Low" bugs in autofs ...

BTW. using version 4 as a workaround is even worse than I thought because it doesn't support "direct mapping".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers