AutoFS direct maps not working with NFSv4 exports

Bug #369682 reported by David Dana on 2009-04-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
autofs (Ubuntu)
Low
Unassigned

Bug Description

I'm running Ubuntu 9.04 AMD64, and I've run into a problem trying to use AutoFS to mount exports on my Ubuntu 8.10 server (with OpenLDAP for user auth). I used to have this entry in fstab which worked fine:

files.example.com:/ /shared nfs4 rw,soft,intr,_netdev,auto 0 0

That entry mounted all of my exports under /shared exactly like it's supposed to. In /etc/auto.master, I have:

/- /etc/auto.shared

This should use the map file to create a direct map, and in the map file I have:

/shared -fstype=nfs4,rw,soft,intr,_netdev files.example.com:/

I'm not sure of the options here, but I have tried many variations on both of these files. I could not get a direct map to work. I had no errors in syslog or daemon.log. However, indirect maps do work with "/shared" in the master and "test" as the key in the map file.

David Dana (danadf) on 2009-04-30
description: updated
Hector Caicedo (hcaicedo) wrote :

Same here Ubuntu 9.04 AMD64... Use to work but, no longer working since upgrade

David Dana (danadf) wrote :

I was not able to find any solution for AutoFS direct maps, and I can confirm the problem is still present on 9.04 32 and 64-bit. I also had a hard time finding documentation on direct maps, and it's unclear if the current kernel and autofs package support this.

My workaround was to set up an indirect map, and place a Gnome launcher on each user's desktop. My documentation for that is here, https://www.danacomputing.com/wiki/doku.php?id=ubuntu_9.04_nfs_client_setup, but hopefully a better solution can be found.

Chuck Short (zulcss) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in autofs (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Chuck Short (zulcss) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

David Dana (danadf) wrote :

Well, to be blunt, you are the person we haven't heard from in a while. I posted this bug report six months ago, and the only reason you are even making comments here is because Karmic Koala is about to be released - no one even took the time to look at the problem. Six months is an order of magnitude greater than the time any sane person would wait before realizing support was non-existent. GFY.

Chuck Short (zulcss) on 2009-10-29
Changed in autofs (Ubuntu):
status: Incomplete → Won't Fix

this bug is still present in karmic
lines in auto.master starting with /- seem to be just ignored

Changed in autofs (Ubuntu):
status: Won't Fix → Confirmed
Jeffrey Baker (jwbaker) wrote :

Hi there. Isn't this caused by DISABLE_DIRECT=1 in /etc/default/autofs ?

Indeed, a default install of karmic->autofs has
    DISABLE_DIRECT=1
in /etc/default/autofs
This is also documented in /usr/share/doc/autofs/README.direct

A workaround might be to use autofs5.

According to the original poster the behaviour changed at some point in time. The reason remains unclear to me after having looked at the last 4 package versions.

This bug should be closed as invalid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers