Not working properly with compile options "-symbolic-functions"

Bug #1470687 reported by Seyeong Kim on 2015-07-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
autofs (Ubuntu)
Undecided
Seyeong Kim
Trusty
Undecided
Seyeong Kim
Utopic
Undecided
Seyeong Kim
Vivid
Undecided
Seyeong Kim

Bug Description

SRU Justification

[Impact]

Can't use ${VARIABLE} on config file with -Dvar=value

Actually this is not a direct cause. but one of symptoms.

It's affected from Trusty to Wily ( Precise is ok )

[Test Case]

set NFS server
  - /export/test1
  - /export/test2
  - /export/test-wily ( has README file )

set NFS client
  - insert "/test /etc/auto.test" on the bottom of /etc/auto.master
  - insert "test autofs_nfs:/export/${TESTVAR}
  - run "automount -DTESTVAR=test-wily --pid-file=/var/run/autofs.pid -d -f -v"
  - go /test, run ll test
  - can see whole subdirectories on /export, should see only files in /export/test-wily

[Regression Potential]

[Other Info]

After analyzing the codes and build,

I found that it's ok with result of "make" command.

but doesn't work with "debuild" command.

so I suspected compile option

I changed override_dh_auto_build part on debian/rules to below

-----
override_dh_auto_build:
        CFLAGS="$(CFLAGS) $(CPPFLAGS) -fgnu89-inline" \
        LDFLAGS="-Wl,-z,relro" \ <<
        dh_auto_build
-----

then debuild, it works

with -symbolic-functions option, static global variable in shared library can't be used properly.. they lose some variables or element in list as I tested.

I'm curious whether it's affected all other pkg.. because it's compiler option problem

Related branches

Seyeong Kim (seyeongkim) on 2015-07-02
description: updated
description: updated
description: updated
description: updated
Seyeong Kim (seyeongkim) on 2015-07-02
description: updated
Seyeong Kim (seyeongkim) wrote :

The attachment "wily-remove-symbolic-funcions.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Seyeong Kim (seyeongkim) wrote :
Seyeong Kim (seyeongkim) wrote :
Seyeong Kim (seyeongkim) wrote :
Seyeong Kim (seyeongkim) on 2015-07-06
Changed in autofs (Ubuntu Trusty):
status: New → In Progress
Changed in autofs (Ubuntu Utopic):
status: New → In Progress
Changed in autofs (Ubuntu Vivid):
status: New → In Progress
Changed in autofs (Ubuntu):
status: New → In Progress
assignee: nobody → Seyeong Kim (xtrusia)
Changed in autofs (Ubuntu Trusty):
assignee: nobody → Seyeong Kim (xtrusia)
Changed in autofs (Ubuntu Utopic):
assignee: nobody → Seyeong Kim (xtrusia)
Changed in autofs (Ubuntu Vivid):
assignee: nobody → Seyeong Kim (xtrusia)
Chris J Arges (arges) wrote :

Before I sponsor this, I'd like to know which static variables are needed exactly? Instead of hardcoding LDFLAGS, perhaps we should fix the specific file that is not working correctly. Does upstream autofs work with -symbolic-functions?

Chris J Arges (arges) wrote :

I also just merged autofs 5.1.1-1ubuntu1 into wily. Can you test this package to see if its affected by the same issue?
Thanks

Chris J Arges (arges) wrote :

Well bug 1472115 was caused by the wily 5.1.1-1ubuntu1 upload. Dropping -Bsymbolic-functions from LDFLAGS fixes the issues.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autofs - 5.1.1-1ubuntu2

---------------
autofs (5.1.1-1ubuntu2) wily; urgency=low

  * Add LDFLAGS to avoid issues with accessing global variables in
    shared libraries (LP: #1470687, LP: #1472115).

 -- Stefan Bader <email address hidden> Tue, 07 Jul 2015 16:28:53 +0200

Changed in autofs (Ubuntu):
status: In Progress → Fix Released
Chris J Arges (arges) wrote :

Sponsored for T/U/V.

Hello Seyeong, or anyone else affected,

Accepted autofs into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/autofs/5.0.7-3ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in autofs (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in autofs (Ubuntu Utopic):
status: In Progress → Fix Committed
Chris J Arges (arges) wrote :

Hello Seyeong, or anyone else affected,

Accepted autofs into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/autofs/5.0.8-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris J Arges (arges) wrote :

Hello Seyeong, or anyone else affected,

Accepted autofs into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/autofs/5.0.8-1ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in autofs (Ubuntu Vivid):
status: In Progress → Fix Committed
Seyeong Kim (seyeongkim) wrote :

vivid
ii autofs 5.0.8-1ubuntu3.2 amd64 kernel-based automounter for Linux

utopic
ii autofs 5.0.8-1ubuntu1.3 amd64 kernel-based automounter for Linux

trusty
ii autofs 5.0.7-3ubuntu3.2 amd64 kernel-based automounter for Linux

It works

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autofs - 5.0.7-3ubuntu3.2

---------------
autofs (5.0.7-3ubuntu3.2) trusty; urgency=medium

  [ Stefan Bader ]
  * Add LDFLAGS to avoid issues with accessing global variables in
    shared libraries (LP: #1470687).

 -- Chris J Arges <email address hidden> Tue, 07 Jul 2015 12:47:34 -0500

Changed in autofs (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for autofs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autofs - 5.0.8-1ubuntu1.3

---------------
autofs (5.0.8-1ubuntu1.3) utopic; urgency=medium

  [ Stefan Bader ]
  * Add LDFLAGS to avoid issues with accessing global variables in
    shared libraries (LP: #1470687).

 -- Chris J Arges <email address hidden> Tue, 07 Jul 2015 12:41:12 -0500

Changed in autofs (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autofs - 5.0.8-1ubuntu3.2

---------------
autofs (5.0.8-1ubuntu3.2) vivid; urgency=medium

  [ Stefan Bader ]
  * Add LDFLAGS to avoid issues with accessing global variables in
    shared libraries (LP: #1470687).

 -- Chris J Arges <email address hidden> Tue, 07 Jul 2015 12:35:22 -0500

Changed in autofs (Ubuntu Vivid):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

Did this patch get sent upstream? We're still having to maintain the Ubuntu delta here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers