autofs failed to mount .hidden

Bug #1050021 reported by Ales on 2012-09-12
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
autofs (Ubuntu)
High
Unassigned

Bug Description

I use autofs to mount network drive via NFS (Ubuntu 12.04 with all updates).

Configuration files:
 /etc/auto.master:
------------------------
 /media /etc/auto.nfs --timeout 10

/etc/auto.nfs:
----------------
myshare -fstype=nfs4,soft,intr 192.168.1.1:/

I made the directory /media/myshare in advance.

First a stopped service: "service autofs stop" and run "automount -f -v" to see its messages.
Than I tried to access /media/myshare. ls is OK, mc from console too but when I do it with nautilus I get " failed to mount /media/.hidden" and nothing else happens. What is interesting, sometimes the first attempt works but the second fails and myshare directory is deleted!

This is the situation on Ubuntu 12.04. At the same time the same configuration works perfectly on Kubuntu 12.04 with Krusader and Dolphin. Any ideas or workarounds?

Note: what is wrong with autofs? There is an old "syntax error" bug (https://bugs.launchpad.net/ubuntu/+source/autofs5/+bug/488696) that I had to fix first and now this one I don't know what to do about.

Changed in autofs (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in autofs (Ubuntu):
status: New → Confirmed
Steffen Heyne (steffen-heyne) wrote :

I'm currently playing around with autofs in order to mount nfs shares from my home NAS. Everything works fine on the terminal, but when I'm using Nautilus as first-time access there is a problem with this .hidden directory. My share gets mounted to the .hidden dir instead to the name I provided with the automount map.

darthanubis (darthanubis) wrote :

put a / after media in auto.master as the mount point like so "/media/"

I resolved this on my machine. Can not get auto.net to work though yet.

Frédéric Nass (nass) wrote :

Hi,

I confirm this bug. I'ts a real pain. Even more when using executable maps as we do, because autofs blindly obeys to mounting a share that doesn't exist on the server side (shouldn't autofs know it ?).

Here's our executable /etc/auto.nfs map :

#!/bin/bash
user_group=$(id -n -g $1)
echo "-fstype=nfs4,rw,sec=krb5 server:/home/NFS/$user_group/$1"

It works fine when the map is called with username when mounting its home directory. But sometimes, it's Kate (text editor) that's trying to access /home/.kateprojekt or /home/.kateconfig files instead of /home/user1/.kateprojekt and /home/user1/.kateconfig and then it fails. It's worse than that : it freezes the text editor and even the whole KDE desktop.

That's what autofs is triyng to mount in this particular situation : /home/NFS//.kateprojekt on /home/

Tried this with Ubuntu 13.04 server and client and Fedora 19 too and same errors happens. On Fedora 19 I even get error about /home/.Trash and /home/.Trash-xxxxx and /home/.hidden etc....

I'm now on production with all my students and teachers beeing impacted by this bug.

There seems to be 2 problems here :

1. Autofs should better handle mount errors.
2. Kate should record its configuration in the right path : /home/user1/.kateprojekt and not /home/.kateprojekt

Hope someone pays attention to this and fix this really soon. Let me know if I can help / try your fixing.

Frédéric.

automount key ".hidden" not found in map source(s).

Using autofs-ldap, auto.master etc in LDAP.

User can access auto mounts via terminal fine. Nautilus just sits there doing nothing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers