[needs 2.68] autotools give false warning on AC_INIT

Bug #641611 reported by Sergey V. Udaltsov
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
autoconf (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: autoconf

Trying to build any project with bugzilla address, I am getting warnings.

From configure.in:
AC_INIT(libgnomekbd, 2.31.92, [http://bugzilla.gnome.org/enter_bug.cgi?product=libgnomekbd])

The warnings:

Running aclocal-1.11...
configure.in:4: warning: AC_INIT: not a literal: http://bugzilla.gnome.org/enter_bug.cgi?product=libgnomekbd
Running autoconf...
configure.in:4: warning: AC_INIT: not a literal: http://bugzilla.gnome.org/enter_bug.cgi?product=libgnomekbd
Running autoheader...
configure.in:4: warning: AC_INIT: not a literal: http://bugzilla.gnome.org/enter_bug.cgi?product=libgnomekbd
Running automake-1.11...
configure.in:4: warning: AC_INIT: not a literal: http://bugzilla.gnome.org/enter_bug.cgi?product=libgnomekbd

It worked fine in 10.04

Revision history for this message
Oibaf (oibaf) wrote :

That's a bug in autoconf that was fixed in autoconf 2.68:

http://lists.gnu.org/archive/html/autotools-announce/2010-09/msg00000.html

** AC_INIT again allows URLs with '?' for its BUG-REPORT argument.
   Regression introduced in 2.66.

More details at:
http://savannah.gnu.org/support/?107450

summary: - autotools give false warning on AC_INIT
+ [needs 2.68] autotools give false warning on AC_INIT
Changed in autoconf (Ubuntu):
status: New → Confirmed
Revision history for this message
Oibaf (oibaf) wrote :

Fixed in oneiric.

Changed in autoconf (Ubuntu):
status: Confirmed → Fix Committed
Oibaf (oibaf)
Changed in autoconf (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers