autoconf in karmic depends on m4 1.4.13

Bug #459422 reported by Mikael Magnusson on 2009-10-23
This bug affects 4 people
Affects Status Importance Assigned to Milestone
autoconf (Ubuntu)
Nominated for Karmic by dn

Bug Description

Binary package hint: autoconf

autoconf 2.64-1ubuntu1 requires m4 (>= 1.4.13) when built on a system with m4 1.4.13 or later. Since it checks for --gnu support in m4 during build time.

Description: Ubuntu 9.04
Release: 9.04

autoconf 2.64-1ubuntu1
m4 1.4.11-1

No errors from autoconf (when running autoconf in a source tree with working
$ autoconf

$ autoconf
/usr/bin/m4: unrecognized option '--gnu'
Try `/usr/bin/m4 --help' for more information.
autom4te: /usr/bin/m4 failed with exit status: 1

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: wl
Package: autoconf 2.64-1ubuntu1
PackageArchitecture: all
 PATH=(custom, user)
SourcePackage: autoconf
Uname: Linux 2.6.28-15-generic i686

Related branches

Mikael Magnusson (mikma) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autoconf - 2.64-4ubuntu1

autoconf (2.64-4ubuntu1) lucid; urgency=low

  * Merge from debian testing, remaining changes: LP: #478334
    - bin/ Check whether libtoolize supports --install, if it
      does, libtoolize is safe to run at all times since it will not install
      new files unless --install is passed to it as well.
  * Fixes autoconf requires m4 LP: #459422
  * Fixes autoconf suggests installing autobook LP: #372701

autoconf (2.64-4) unstable; urgency=low

  * Add back Suggests: autoconf-archive removed in 2.64-3. I did check
    whether that package still existed, but somehow I got it
    wrong--perhaps a typo. Thanks to Guillem Jover <email address hidden>
    for pointing out my mistake.

autoconf (2.64-3) unstable; urgency=low

  * Remove Suggests: autobook, autoconf-archive, because these packages
    are no longer in Debian. Thanks to Vincent Bernat <email address hidden>
    for pointing this out. Closes: #548025.

autoconf (2.64-2) unstable; urgency=low

  * Require m4 version 1.4.13 or later for both build and installation.
    GNU m4 1.4.13 adds a "--gnu" option that Autom4te uses at runtime if
    it was found to work at build time, so these dependencies ensure
    consistency. Thanks to Martin Casado <email address hidden> for
    reporting the problem.
 -- Bhavani Shankar <email address hidden> Sun, 08 Nov 2009 18:57:54 +0530

Changed in autoconf (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers