autoconf description still suggest installing autobook

Bug #372701 reported by Dimitrios Symeonidis on 2009-05-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
autoconf (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: autoconf

Doing "aptitude show autoconf" in Jaunty, I still see:
 For an extensive library of additional Autoconf macros, install the `autoconf-archive' package. For a book that explains
 how to use Autoconf, Automake, and Libtool in conjunction, install the `autobook' package.

The autobook package has been orphaned upstream, since it's not maintained since 2005, and it's not included in Jaunty or Karmic. We should change the package description of autoconf and autoconf-doc

Related branches

Dimitrios Symeonidis (azimout) wrote :

importance=low

Changed in autoconf (Ubuntu):
importance: Undecided → Low
shankao (shankao) on 2009-10-07
Changed in autoconf (Ubuntu):
assignee: nobody → shankao (shankao)
status: New → In Progress
shankao (shankao) wrote :

Removed in autoconf

Changed in autoconf (Ubuntu):
assignee: shankao (shankao) → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autoconf - 2.64-4ubuntu1

---------------
autoconf (2.64-4ubuntu1) lucid; urgency=low

  * Merge from debian testing, remaining changes: LP: #478334
    - bin/autoreconf.in: Check whether libtoolize supports --install, if it
      does, libtoolize is safe to run at all times since it will not install
      new files unless --install is passed to it as well.
  * Fixes autoconf requires m4 LP: #459422
  * Fixes autoconf suggests installing autobook LP: #372701

autoconf (2.64-4) unstable; urgency=low

  * Add back Suggests: autoconf-archive removed in 2.64-3. I did check
    whether that package still existed, but somehow I got it
    wrong--perhaps a typo. Thanks to Guillem Jover <email address hidden>
    for pointing out my mistake.

autoconf (2.64-3) unstable; urgency=low

  * Remove Suggests: autobook, autoconf-archive, because these packages
    are no longer in Debian. Thanks to Vincent Bernat <email address hidden>
    for pointing this out. Closes: #548025.

autoconf (2.64-2) unstable; urgency=low

  * Require m4 version 1.4.13 or later for both build and installation.
    GNU m4 1.4.13 adds a "--gnu" option that Autom4te uses at runtime if
    it was found to work at build time, so these dependencies ensure
    consistency. Thanks to Martin Casado <email address hidden> for
    reporting the problem.
 -- Bhavani Shankar <email address hidden> Sun, 08 Nov 2009 18:57:54 +0530

Changed in autoconf (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Is the powerpc build fix still actually relevant with current gcc?

Changed in autoconf (Ubuntu):
status: Fix Released → Incomplete
Martin Pitt (pitti) wrote :

Sorry, the previous comment was for a different bug.

Changed in autoconf (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers