AX_BOOST_UNIT_TEST_FRAMEWORK not working with boost 1.53

Bug #1273669 reported by Enrique on 2014-01-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
autoconf-archive (Ubuntu)
Undecided
Unassigned

Bug Description

 I've been using macro AX_BOOST_UNIT_TEST_FRAMEWORK from autoconf-archive without problems until an upgrade of boost 1.53. In my configure.ac I have the following macros:

AX_BOOST_BASE
AX_BOOST_UNIT_TEST_FRAMEWORK

But running ./configure fails:

checking for boostlib >= 1.20.0... yes
checking whether the Boost::Unit_Test_Framework library is available... yes
configure: error: Could not find a version of the library!

 If I roll back to boost 1.49 with the command:
apt-get install libboost-test1.49-dev libboost1.49-dev

 then everything works fine.

Enrique (enrique-garcia) wrote :

 More info:
 it looks that it works again with boost 1.54 (apt-get install libboost-test1.54-dev libboost1.54-dev). However boost 1.53 is still the default being installed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in autoconf-archive (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers