Ubuntu

aumix throws error aumix: SOUND_MIXER_READ_DEVMASK

Reported by Sjoerd Hemminga on 2007-09-27
50
Affects Status Importance Assigned to Milestone
aumix (Ubuntu)
Medium
Unassigned
Gutsy
Medium
Unassigned

Bug Description

Binary package hint: aumix

When starting aumix it will immediately throw an error:

sjoerd@cicero:~$ aumix
 aumix: SOUND_MIXER_READ_DEVMASK

The exit status is 1.

This happens on Gutsy. gnome-volume-control and alsamixer work without a hitch.

Please let me know if you need more information.

KnuX (hidden-palace) wrote :

Same issue on (pre) 7.10.

Using xubuntu-* and now OSD isn't displayed when using my keyboard to lower or upper the volume.

On Gnome, it works. I don't know how Gnome does this task...

Daniel T Chen (crimsun) on 2007-10-25
Changed in aumix:
status: New → Triaged
raketenman (sesselastronaut) wrote :

jep i got the same issue after upgrading from feisty

Akkana Peck (akkzilla) wrote :

Here, too. Anyone know if it's a kernel problem or an aumix problem?

soothsayer (haikudo) wrote :

Rebuilding this package from source got it working again for me.

jcfp (jcfp) wrote :

Indeed, simply rebuilding the aumix package from the gutsy source package fixed the error here too. Too bad a bug like this still isn't fixed after some 2 months, especially having been reported well before 7.10 release date.

Sean Dague (sdague) wrote :

I'm also hitting the same issue. Please provide a package update for this, as aumix is the best way to script things to change the volume on the command line.

Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.
According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .
The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage .

Changed in aumix:
importance: Undecided → Medium

 have exactly the same problem. I can't beleive what I read

    "The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04)."

So, no hope to get a fix before 6 months, for a program which worked perfectly before.!!
That's incredible, for a program which is the only one which can be used in scripts.
Do that guys ever read the https://wiki.ubuntu.com/HelpingWithBugs page:

    Another way of distinguishing a bug is if it's a regression. That means
   that something used to work, and now doesn't any more. We try fairly hard
   to get these identified early, because regressions are bad news.

That king of bug processing will surely convince newcomers to go back to Windows

Akkana Peck (akkzilla) wrote :

Anyone frustrated with why fixing a simple build problem is apparently against Ubuntu rules might find it cathartic to read the discussion going on at http://www.oreillynet.com/linux/blog/2007/12/ubuntu_innovates_excuses.html and my own humble contribution at http://shallowsky.com/blog/linux/ubuntu-aumix.html

Incidentally, it's not clear how a fix for a build problem could be tested in Hardy first -- Hardy probably has a new version of aumix already. Nobody's asking for a source code change; all anyone is asking for is a correct build of the source code you're claiming is already in Gutsy.

Scott Kitterman (kitterman) wrote :

This nomination should never have been declined. We do fix bugs first in the development release as a risk mitigation strategy for the stable release, but that doesn't mean the task should be rejected.

Changed in aumix:
importance: Undecided → Medium
status: New → Confirmed
Emmet Hikory (persia) wrote :

This issue was likely fixed in hardy with the upload of 2.8-19, and was tested fixed with 2.8-20.

Changed in aumix:
status: Triaged → Fix Released
Abel Cheung (abelcheung) wrote :

Read:

Since the Gutsy release is already out, aumix for Gutsy has entered a stable "buggy state". Any new package would cause the buggy state to be changed, thus require very careful consideration before deploying, and is rejected so far. Hardy has no such requirement ('freezing buggy state'), thus is free to receive newer packages. The final goal is to make Gutsy "Stably Buggy", not changing buggy state all the time.

Christian Iversen (chrivers) wrote :

This should _CLEARLY_ qualify for SRU.

Apart from rebuilding the package from source WITHOUT PATCHING, absolutely NOTHING needs to be done.

Furthermore, how can this not qualify under the rule "Bugs which represent severe regressions from the previous release of Ubuntu" ?

Sorry for the yelling, but it seems completely insane that a bug which is so easy to fix is not fixed immediately.

No patching needs to be performed. The only problem is with the package.

(Sorry for the yelling)

BTW: Why is this marked as "fix released"? As far as I can see, a fix has not been released, at least not to the repositories. If it has, you'll have to excuse my irate comments :-)

I've got the same problem. The amixer command seems to be a reasonable alternative for people who want their volume back. :) it would be nice to aumix working though.

alrac (carla) wrote :

The fix is released where? Not to Gutsy. At first I thought Abel was kidding, but now I know he's quoting official Canonical policy. Adding to the overall atmosphere of whimsical, arbitrary management is KDE4 has been added to Gutsy. Mmmkay. Whatever happened to "absolutely 100% frozen, including broken packages, and that's final"?

Siegfried Gevatter (rainct) wrote :

The status "Fix Released" is correct, as it works in Hardy (or at least is what I've understood from the latest comments). And alrac, KDE4 is *not* in Gutsy, but in gutsy-backports, which is different.

Anyway, I agree with you in that it sounds stupid that rebuilding the package, if this would really make it work, doesn't qualify for an SRU... :(

Siegfried Gevatter (rainct) wrote :

I've tried building it in a Gutsy pbuilder environment and I can confirm that it works. Build log and .deb are attached, for the case they are useful for something.

Siegfried Gevatter (rainct) wrote :

(Oops, forgot that apt-get would get Hardy's one... But well, the changelog doesn't mention any significant change.)

Murat Gunes (mgunes) wrote :

> Anyway, I agree with you in that it sounds stupid that rebuilding the
> package, if this would really make it work, doesn't qualify for an
> SRU... :(

It does qualify for a SRU. From https://wiki.ubuntu.com/StableReleaseUpdates :

"NOTE: With Universe and Multiverse SRU's FTBFS, not installable, and segfault on startup ( e.g. completely un-usable ) can also be considered SRU Candidates"

Jonathan Rogers (jonner) wrote :

I don't see an arch in the report, but Siegried Gevatter mentions rebuilding an i386 package. I do not have this problem on either Gutsy or Hardy on x86_64. On my Gutsy system, I have aumix 2.8-18 installed and my kernel is 2.6.22-14-generic. On Hardy, I have aumix 2.8-20 and kernel 2.6.24-4-generic.

Tested on Gutsy on Intel Macbook 1st gen. (32bit). Same error, the package is entirely useless. I truly hope you fix this because what is the point of keeping this package in the repositories if it does not work for anyone?

Jonathan Rogers (jonner) wrote :

While aumix clearly needs to be fixed on i386, I was merely pointing out that it does work on x86_64, so no one needs to spend any time on that.

alrac (carla) wrote :

Siegfried, KDE4 is in Universe, not Backports.

2008/1/22, alrac <email address hidden>:
> Siegfried, KDE4 is in Universe, not Backports.

You are confusing two different things here. Universe is a component
and gutsy-backports is a repository (which is divided in four
components, one of which is Universe).

Beside that, it is true that there are some KDE4 packages in the gutsy
repository, but those were added *before* Gutsy was released. All the
new KDE4 packages are in gutsy-backports (or in the kubuntu PPA).

Alan (mrintegrity) wrote :

in the time it took to write most of these comments the problem could have been fixed...

Scott Kitterman (kitterman) wrote :

Would someone in motu-sru please give this a proper thumbs up or thumbs down?

John Dong (jdong) wrote :

Hi,

I am a member of the MOTU SRU team that evaluates bugs such as these for approval to the -updates repository.

I am of course interested in sending this bug on the road towards being fixed, but in the 25+ comments I've just read I could not find a definitive explanation of the reason this is broken and how to fix it. My best indication seems to be that this just needs a rebuild?

Please edit the original description of this bug to describe the problem, steps to reproduce, *and the proposed fix*, change the status back to New, and I will look at it promptly.

Changed in aumix:
status: Confirmed → Incomplete
Arda (ardasaltoglu+launchpad) wrote :

There is not much to write about. I don't know the reason _why_ it is broken, but executing "aumix" from the repositories gives the mentioned error, and compiling from sources (without patching, or any other change) fixes it, at least on my system (Kubuntu Gutsy, up-to-date, Kernel 2.6.22-14-generic #1 SMP). So, it is probable that merely rebuilding the package would fix it. This gives us:

Description:
  aumix, when run, gives error "aumix: SOUND_MIXER_READ_DEVMASK" and exits with status 1, can't be used at all
Steps to reproduce:
  just run "aumix", observe error
Proposed fix:
  rebuild, test, make available as an update

John Dong (jdong) wrote :

Based on the clarification, I am ACKing for a MOTU to upload a no-source-change rebuild of aumix to gutsy-proposed.

Changed in aumix:
status: Incomplete → Confirmed
Changed in aumix:
assignee: nobody → rainct
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

I rejected the upload. Please upload to -proposed, not directly to -updates.

Not sure if anyone is aware of this, but this bug is not really a minor issue from the perspective of an Xubuntu user. It turns out that this issue is directly responsible for the failure of the volume control dial on multimedia keyboards to work in 7.10, since xfce converts the dial-turning input into aumix commands.

I've been watching this bug since I ran into it immediately after upgrading from 7.04, in December. I am astounded to see that it's still unresolved when the fix was made clear and confirmed by two users as of Nov 24, 2007. (three and a half months ago!)

This is a highly-visible bug from an Xubuntu perspective.

Jonathan Riddell (jr) wrote :

Accepted into gutsy-proposed, please test.

jcfp (jcfp) wrote :

Package in -proposed works ok for me, SOUND_MIXER_READ_DEVMASK error is gone.

Same here, -proposed works fine.

Changed in aumix:
assignee: rainct → nobody
status: In Progress → Fix Committed
Luca Falavigna (dktrkranz) wrote :

GUTSY VERIFICATION

Using version 2.8-18:
$ aumix
 aumix: SOUND_MIXER_READ_DEVMASK
$

Using version 2.8-18build1 (from gutsy-proposed):
$ aumix
[Application starts correctly]
$

Program works now, tagging as verification-done.

Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in aumix:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers