augeas-lense for apache does not support new "conf-available" layout

Bug #1425183 reported by annunaki2k2 on 2015-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
augeas (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

Summary pretty much says it all.

This is an Ubuntu 14.04 Trusty box and since Apache on it has replaced the conf.d directory with the conf-available/conf-enabled directories, augeas httpd lense no longer works for changing conf file settings.

The attachment "Add support for the new layout to augeas httpd lense" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Raphaël Pinson (raphink) wrote :

Hello and thanks for reporting this bug.

Would you mind providing the patch as a PR on GitHub? [0]

This way I can simply merge it upstream and it will be easier to fix.

Thank you!

[0] https://github.com/hercules-team/augeas

Raphaël Pinson (raphink) wrote :

Merged upstream.

Robie Basak (racb) wrote :

Thank you annunaki2k2 and Raphaël.

I think this is valid and trivial enough to fix in an SRU to 14.04 if somebody wants to prepare the update by following the steps at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in augeas (Ubuntu):
status: New → Triaged
Changed in augeas (Ubuntu Trusty):
status: New → Triaged
Changed in augeas (Ubuntu):
importance: Undecided → Medium
Changed in augeas (Ubuntu Trusty):
importance: Undecided → Medium

I don't think this is worth maintaining a patch. It's easy enough in augeas
to add new transforms using aug_transform or the --transform flag.
On 26 Feb 2015 16:15, "Robie Basak" <email address hidden> wrote:

> Thank you annunaki2k2 and Raphaël.
>
> I think this is valid and trivial enough to fix in an SRU to 14.04 if
> somebody wants to prepare the update by following the steps at
> https://wiki.ubuntu.com/StableReleaseUpdates#Procedure
>
> ** Also affects: augeas (Ubuntu Trusty)
> Importance: Undecided
> Status: New
>
> ** Changed in: augeas (Ubuntu)
> Status: New => Triaged
>
> ** Changed in: augeas (Ubuntu Trusty)
> Status: New => Triaged
>
> ** Changed in: augeas (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: augeas (Ubuntu Trusty)
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to augeas
> in Ubuntu.
> Matching subscriptions: Augeas
> https://bugs.launchpad.net/bugs/1425183
>
> Title:
> augeas-lense for apache does not support new "conf-available" layout
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/augeas/+bug/1425183/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers