Ubuntu

aufs-tools FTBS due to missing linux/aufs_type.h header

Reported by Andy Whitcroft on 2010-12-03
18
This bug affects 5 people
Affects Status Importance Assigned to Milestone
aufs-tools (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Low
Andy Whitcroft

Bug Description

aufs-tools is FTBS on sync from debian due to a missing header: linux/aufs_type.h

Andy Whitcroft (apw) wrote :

Adding a linux task as this looks to be a kernel header missing from linux-libc-dev; keeping aufs-tools to allow this to be found to prevent duplicates.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → Low
status: New → In Progress
Andy Whitcroft (apw) wrote :

Added infrastructure to include ubuntu headers in linux-libc-dev and moved the appropriate header into it. Pushed to natty.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.37-8.20

---------------
linux (2.6.37-8.20) natty; urgency=low

  [ Andy Whitcroft ]

  * Revert "[Upstream] drivers/serial/mfd.c: Fix ARM compile error"
  * Revert "SAUCE: Nouveau: Disable acceleration on MacBook Pros"
  * Revert "SAUCE: Nouveau: Add quirk framework to disable acceleration"
  * Revert "SAUCE: i915 -- disable powersave by default"
  * SAUCE: enable Marvell 9128 PCIe SATA controller
    - LP: #658521
  * [Config] evtchn has been renamed
  * (no-up) add support for installed header files to ubuntu directory
    - LP: #684666
  * ubuntu: AUFS -- include the aufs_types.h file in linux-libc-headers
    - LP: #684666

  [ Tim Gardner ]

  * [Config] MISS: evtchn, NEW : xen-evtchn
  * rebase to v2.6.37-rc4

  [ Upstream Kernel Changes ]

  * drm/i915: Clean conflicting modesetting registers upon init
    - LP: #683775
  * rebase to v2.6.37-rc4
 -- Andy Whitcroft <email address hidden> Fri, 03 Dec 2010 18:42:07 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) wrote :

These patches causes a severe regression and were backed out. The fixes are now under review.

Changed in linux (Ubuntu):
status: Fix Released → In Progress
tags: added: kernel-series-unknown
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.37-9.22

---------------
linux (2.6.37-9.22) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to v2.6.35-rc5
  * [Config] updateconfigs following rebase to v2.6.37-rc5
  * (no-up) add support for installed header files to ubuntu directory
    - LP: #684666
  * ubuntu: AUFS -- include the aufs_types.h file in linux-libc-headers
    - LP: #684666
  * ubuntu: dm-raid4-5 -- follow changes to bio flags
  * ubuntu: dm-raid4-5 -- re-enable
  * ubuntu: omnibook -- update BOM
  * ubuntu: ndiswrapper -- update BOM to match actual version
  * ubuntu: ndiswrapper -- follow removal of the BKL and locked ioctl
  * ubuntu: ndiswrapper -- re-enable
  * ubuntu: iscsitarget -- re-instate copy_io_context
  * ubuntu: iscsitarget -- follow changes to semaphore initialisation
  * ubuntu: iscsitarget -- convert NIPQUAD to %pI4
  * ubuntu: iscsitarget -- re-enable

  [ Kees Cook ]

  * [Config] update config for CONFIG_DEBUG_SET_MODULE_RONX

  [ Manoj Iyer ]

  * SAUCE: Enable jack sense for Thinkpad Edge 13
    - LP: #685015

  [ Tim Gardner ]

  * [Config] CONFIG_9P_FSCACHE=y,CONFIG_9P_FS_POSIX_ACL=y
  * [Config] CONFIG_CRYPTO_CRC32C=y
    - LP: #681819
  * [Config] CONFIG_9P_FSCACHE=n
  * [Config] Add nfsd modules to -virtual flavour
    - LP: #688070

  [ Upstream Kernel Changes ]

  * Revert "Staging: zram: work around oops due to startup ordering snafu"
  * NFS: Fix panic after nfs_umount()
    - LP: #683938
  * x86: Add NX protection for kernel data
  * x86: Add RO/NX protection for loadable kernel modules
  * x86: Resume trampoline must be executable
  * x86: RO/NX protection for loadable kernel, jump_table fix

  [ Upstream Kernel Changes ]

  * rebase to v2.6.37-rc5
 -- Andy Whitcroft <email address hidden> Thu, 09 Dec 2010 18:15:35 +0000

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aufs-tools (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :
Changed in aufs-tools (Ubuntu):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers