package libaudiocdplugins4 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/libaudiocdplugins.so.4', which is also in package kio-audiocd 4:4.14.1-0ubuntu1

Bug #1413841 reported by oldspammer on 2015-01-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
audiocd-kio (Ubuntu)
Undecided
Unassigned

Bug Description

Upgrading from 12.10 to 13.04 to 14.04 to 14.10 through a sequence involving the recommended upgrade sequence using http://old-releases.ubuntu.com/ repository, etc.

Some intermediate stage wanted to upgrade things involving audiocd--the bug reported item.

My last unreported GUI bug was one where the font size of x-terminal was super small. When I clicked on the "+" button, the terminal size and font grew larger, where upon, after too many clicks on that button the font and window were huge. I clicked on the "-" button on the terminal's window top, but it did not shrink the window, just the font size. I then tried to shrink the window using right click resize, but the mouse adjustment to shrink the size did not have any effect except to temporarily change the look of the mouse cursor. When mouse button for dragging the resize was released, the window stayed the same size. The same thing happened when I tried to use just the cursor direction keys on the keyboard.

This terminal window was running my do-release-upgrade that had already downloaded all of the required packages and was processing to set each one up and remove the older packages--so I did not want to test if the quit or close button worked on this malformed terminal window.

After too much dinking around like this, the terminal screen size overlapped greater than all my workspaces combined with microscopic font size and black background. The display probably had 8000 lines of microscopic font scrolling each time the installation proceeded--this was noticably slower than normal.

Only minimize and restore seemed to work and I did not want to click close for fear that this would break all sorts of installed packages. I ended up with a zombie process and somehow the window shut on its own without me asking for this, but after about 9 hours of processing time--hopefully enough to complete the upgrade to ubuntu 14.10? I checked using the compizConfig tool if window resizing was disabled, but it was not disabled at all. To check what version of x-terminal was running the ps display while running as root showed it to be x-terminal-alternative from /etc/alternatives folder or directory that is some script in text.

I had to run all of this because a prior install had that the package resolver decided that there was no need to keep the aptitude character based package manager and removed a huge amount of stuff that could not be re-installed due to unresolved means to re-establish package dependencies, etc. This was due to me saying yes to doing a package clean-up or some such foolishness. Now when any software asks me if I want to automatically remove 200 packages to clean up, I say NO every time because the stupid software does not appreciate what foolishness it is asking to do to itself--a sort of self inflicted wounding or suicide--just to clean up a bit.

After all was done, I tested the x-terminal to see if it refused to shrink its size using the mouse, but it behaved perfectly nicely. Perhaps when an upgrade is in the process of happening, lots of stuff gets into some sort of limbo state of malfunctioning?

On some of the install error messages it says that it is trying to erase a file or directory and determines that the target does not exist. The message comes out that it is presumably that my packages were broken somehow--but no such broken packages were in the prior running of synaptic or in aptitude.

It is too bad that some expert system of sanity checking of existing packages does not exist that could possibly mark the given package for re-installation to fix the discovered "broken-ness".

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: libaudiocdplugins4 (not installed)
ProcVersionSignature: Ubuntu 3.16.0-30.40-generic 3.16.7-ckt3
Uname: Linux 3.16.0-30-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu8.1
AptOrdering:
 libaudiocdplugins4: Install
 libaudiocdplugins4: Configure
Architecture: amd64
Date: Thu Jan 22 17:39:39 2015
DpkgTerminalLog:
 Preparing to unpack .../libaudiocdplugins4_4%3a4.9.5-0ubuntu0.1_amd64.deb ...
 Unpacking libaudiocdplugins4 (4:4.9.5-0ubuntu0.1) ...
 dpkg: error processing archive /var/cache/apt/archives/libaudiocdplugins4_4%3a4.9.5-0ubuntu0.1_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/libaudiocdplugins.so.4', which is also in package kio-audiocd 4:4.14.1-0ubuntu1
DuplicateSignature: package:libaudiocdplugins4:(not installed):trying to overwrite '/usr/lib/libaudiocdplugins.so.4', which is also in package kio-audiocd 4:4.14.1-0ubuntu1
ErrorMessage: trying to overwrite '/usr/lib/libaudiocdplugins.so.4', which is also in package kio-audiocd 4:4.14.1-0ubuntu1
InstallationDate: Installed on 2015-01-21 (1 days ago)
InstallationMedia: Ubuntu-Server 12.10 "Quantal Quetzal" - Release amd64 (20121017.2)
SourcePackage: audiocd-kio
Title: package libaudiocdplugins4 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/libaudiocdplugins.so.4', which is also in package kio-audiocd 4:4.14.1-0ubuntu1
UpgradeStatus: Upgraded to utopic on 2015-01-22 (0 days ago)

Revision history for this message
oldspammer (ckskinner) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers