Certain applications don't have an icon in Software Center

Bug #599535 reported by Mohamed Amine Ilidrissi on 2010-06-28
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Jjed
app-install-data-ubuntu (Ubuntu)
Low
Jjed
audacity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: audacity

When searching for Audacity in the Software Center, it doesn't have an application icon, resulting in confusion for the end-user, who is in doubt whether or not this is really Audacity (since he may have seen the icon before).

Examples:
- Audacity
- Nautilus
- Thunar

Related branches

Benjamin Drung (bdrung) wrote :

audacity has an icon in Software Center on lucid (at least on my system).

It is not the case on Maverick.

Benjamin Drung (bdrung) wrote :

I fired up maverick amd64 in my virtual machine and there is an icon for audacity on Software Center.

Vish (vish) wrote :

I can confirm the bug on Lucid , there is no icon for Audacity[no icon in the list or when viewing Audacity details] , it just uses the generic icon.

Changed in audacity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Benjamin Drung (bdrung) wrote :

...and here is the screenshot of the working version. This bug is in Software Center and not in audacity.

Vish (vish) wrote :

Opening SC task as suggested in comment #5

Changed in software-center (Ubuntu):
importance: Undecided → Low
Vish (vish) wrote :

Seems to be a bug in SC rather than Audacity , happens to several other applications as well

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in audacity (Ubuntu):
status: Confirmed → Invalid
Changed in hundredpapercuts:
status: New → Confirmed
summary: - Audacity doesn't have an icon in Software Center
+ Certain applications don't have an icon in Software Center
description: updated
Vish (vish) on 2010-07-15
description: updated
Vish (vish) wrote :

Kiwinote mentions that this is a bug in app-install-data rather than SC

affects: software-center (Ubuntu) → app-install-data-ubuntu (Ubuntu)
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged
Vish (vish) on 2010-12-04
Changed in hundredpapercuts:
milestone: none → nt10-sc-metadata
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Robert Roth (evfool) wrote :

The bug for thunar, and probably more packages is that the icon mentioned in the desktop file is not present in the icons directory of the app-install-data. The data is retrieved from the site http://rookery.canonical.com/~mvo/gnome-app-install/ in form of a menudata-DATE.tar.gz.

If I add the missing icons from the different application packages and submit a diff, will that be enough? How will it get in a menudata.tar.gz on the server to keep the icons and not loose them on the next run of update-menu-data.sh?

Hi Robert,

> The bug for thunar, and probably more packages is that the icon
> mentioned in the desktop file is not present in the icons directory of
> the app-install-data.
Yep - sounds correct.

> If I add the missing icons from the different application packages and
> submit a diff, will that be enough?
No - most of the app-install-data-ubuntu package is generated content, so
updating generated content doen't work here. See below.

> How will it get in a menudata.tar.gz
> on the server to keep the icons and not loose them on the next run of
> update-menu-data.sh?
menudata.tar.gz is generated by lp:~mvo/archive-crawler/mvo, so this is
where the bug needs to be fixed. I haven't studied the code, but if you have
any questions mvo should be able to help you.

Cheers!

On Wed, Dec 29, 2010 at 1:48 PM, Robert Roth <email address hidden>wrote:

> The bug for thunar, and probably more packages is that the icon
> mentioned in the desktop file is not present in the icons directory of
> the app-install-data. The data is retrieved from the site
> http://rookery.canonical.com/~mvo/gnome-app-install/ in form of a
> menudata-DATE.tar.gz.
>
> If I add the missing icons from the different application packages and
> submit a diff, will that be enough? How will it get in a menudata.tar.gz
> on the server to keep the icons and not loose them on the next run of
> update-menu-data.sh?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/599535
>
> Title:
> Certain applications don't have an icon in Software Center
>

Vish (vish) on 2011-01-13
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → nobody
assignee: nobody → Papercuts Ninja (papercuts-ninja)
Robert Roth (evfool) wrote :

I have made a list of the application which do not have an icon in software center, you can find it on pastebin, at http://paste.ubuntu.com/558970/

I might have missed some, but the list is huge. Probably most of these should be checked why the archive crawler does not find their icons. For some applications the problem is that the desktop file is not in the same package as the icon, but this is a known problem. Other causes should be investigated and fixed in archive-crawler to have the icons packed in app-install-data.

Paul Sladen (sladen) wrote :

In the case of Openbve (in the list) I believe this is because the icon is not distributed with the source code, but as part of the accompanying 'openbve-data' package.

Jjed (jjed) wrote :

This seems to be a four part bug:

  (a) icons in dependencies, *-data, or *-common packages
  (b) icons drawn from the environment. For example, many GTK+ packages
       assume you have gnome-icon-theme
  (c) icons that exist in data.tar as a symlink, which the python `tarfile`
      module seems to fumble with
  (d) icons too big to ship, perhaps a job for imagemagick
  (e) icons in broken or "clever" packages

I'm wrapping up a branch that addresses (a) and most of (b), but there's still
lots to do. This one isn't a paper cut.

Jjed (jjed) wrote :

More work. A new branch fixes problem (c)---symlinked icons---rather completely. The next step is using apt-file to resolve a few odder edge cases.

I've assigned myself to this bug as I'm now confident I can bring it to its conclusion.

Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Jacob Johan Edwards (j-johan-edwards)
Changed in app-install-data-ubuntu (Ubuntu):
assignee: nobody → Jacob Johan Edwards (j-johan-edwards)
Jjed (jjed) on 2011-04-16
Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in app-install-data-ubuntu (Ubuntu):
status: Confirmed → In Progress
Marcus Haslam (marcus-haslam) wrote :

I'm out of the office until 1st August.

On 16 Apr 2011, at 21:30, Jacob Johan Edwards
<email address hidden> wrote:

> More work. A new branch fixes problem (c)---symlinked icons---rather
> completely. The next step is using apt-file to resolve a few odder
> edge
> cases.
>
> I've assigned myself to this bug as I'm now confident I can bring it
> to
> its conclusion.
>
> ** Changed in: hundredpapercuts
>     Assignee: Papercuts Ninja (papercuts-ninja) => Jacob Johan
> Edwards (j-johan-edwards)
>
> ** Changed in: app-install-data-ubuntu (Ubuntu)
>     Assignee: (unassigned) => Jacob Johan Edwards (j-johan-edwards)
>
> ** Changed in: hundredpapercuts
>       Status: Triaged => In Progress
>
> ** Changed in: app-install-data-ubuntu (Ubuntu)
>       Status: Confirmed => In Progress
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/599535
>
> Title:
>  Certain applications don't have an icon in Software Center
>
> Status in One Hundred Paper Cuts:
>  In Progress
> Status in “app-install-data-ubuntu” package in Ubuntu:
>  In Progress
> Status in “audacity” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Binary package hint: audacity
>
>  When searching for Audacity in the Software Center, it doesn't have
> an
>  application icon, resulting in confusion for the end-user, who is in
>  doubt whether or not this is really Audacity (since he may have seen
>  the icon before).
>
>  Examples:
>  - Audacity
>  - Nautilus
>  - Thunar

Marcus Haslam (marcus-haslam) wrote :

I'm out of the office until 1st August.

On 16 Apr 2011, at 19:13, Jacob Johan Edwards
<email address hidden> wrote:

> ** Branch linked: lp:~j-johan-edwards/archive-crawler/fix-symbolic-
> extraction
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/599535
>
> Title:
>  Certain applications don't have an icon in Software Center
>
> Status in One Hundred Paper Cuts:
>  Triaged
> Status in “app-install-data-ubuntu” package in Ubuntu:
>  Confirmed
> Status in “audacity” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Binary package hint: audacity
>
>  When searching for Audacity in the Software Center, it doesn't have
> an
>  application icon, resulting in confusion for the end-user, who is in
>  doubt whether or not this is really Audacity (since he may have seen
>  the icon before).
>
>  Examples:
>  - Audacity
>  - Nautilus
>  - Thunar

Jjed (jjed) wrote :

It is with great pleasure that I mark this bug fixed for app-install-data-ubuntu 0.11.10.2. All missing icons (sixty-six all counted) now seem to be due to flaws in the packages and desktop entries themselves, not our icon fetching script.

In any case, we don't need a metabug anymore. Please report any individual instances of icon missingness against app-install-data-ubuntu. Thanks.

Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in app-install-data-ubuntu (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers