missing LADSPA support

Bug #1261654 reported by James Hunt on 2013-12-17
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Audacity
Invalid
Undecided
Unassigned
audacity (Debian)
Fix Released
Unknown
audacity (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

The version of audacity in trusty seems to be missing LADSPA support: under Effects, I see only 29 plugins listed. Downgrading to version 2.0.3-1 (from raring/saucy), I see the expected list of 277 plugins.

[Impact]
LADSPA plug-ins provided by Debian packages (which install plug-ins into /usr/lib/ladspa/) are not found by Audacity by default.

[Testcase]
1) Install ladspa-sdk (which adds some files to /usr/lib/ladspa/)
2) Launch Audacity
3) Click on Effects

You should see "Plug-ins 16 to 20" (or more). More than the 12 default plug-ins should be displayed.

[Regression Potential]
Due to this change LADSPA plug-ins could be loaded which trigger some bugs. So not only people setting LADSPA_PATH to /usr/lib/ladspa/ would see these.

James Hunt (jamesodhunt) wrote :

A little more detail: I have the following LADSPA plugin packages installed:

cmt
mcp-plugins
omins
swh-plugins
tap-plugins

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in audacity (Ubuntu):
status: New → Confirmed
James Hunt (jamesodhunt) wrote :

I suspect issue this could be rather critical for Ubuntu Studio.

Ross Gammon (retail-0) wrote :

Hi,
Audacity 2.0.5 was released in Debian without ffmpeg support because it has not been fully ported to the libav9 library. Apparently, noone stepped forward to do the work so it was necessary to do this to allow the libav 9 transition to complete. See Debian bug #692809.
It would be great if someone could create some patches to forward upstream. One patch is available (attached) from the Debian bug.

Ross Gammon (retail-0) wrote :

Sorry should have linked to the Debian bug instead of the wrong launchpad bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=692809

The attachment "Partial fix" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

I don't think Audacity's ffmpeg support has anything to do with this bug, because it shows up with a version that I custom-compiled with ffmpeg support as well. A workaround is to symbolically link the /usr/lib/ladspa folder into /usr/share/audacity:

sudo ln -s /usr/lib/ladspa /usr/share/audacity/ladspa

...or if you compiled your own version and installed it with the /usr/local prefix:

sudo ln -s /usr/lib/ladspa /usr/local/share/audacity/ladspa

Ross Gammon (retail-0) wrote :

Thanks Chris. I think you are right. Audacity seems to be looking in the wrong place for the ladspa plugin. A Debian bug reporter has found that it is looking in /usr/lib/x86_64-linux-gnu/ladspa instead of /usr/lib/ladspa.
Regards,
Ross

Changed in audacity:
status: Unknown → New

Would it be terribly difficult to make the search directory configurable?
It seems like sub-par design to hard code the path. In my opinion, the
ideal would be to have a configurable list of search paths. That way, if
the plugins are stored in multiple locations, we can still see them all. Of
course, this fix is more on the Audacity side of things.

On Mon, May 26, 2014 at 8:22 PM, Bug Watch Updater <
<email address hidden>> wrote:

> ** Changed in: audacity
> Status: Unknown => New
>
> --
> You received this bug notification because you are a member of Ubuntu
> Studio, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1261654
>
> Title:
> missing LADSPA support
>
> Status in Audacity:
> New
> Status in “audacity” package in Ubuntu:
> Confirmed
>
> Bug description:
> The version of audacity in trusty seems to be missing LADSPA support:
> under Effects, I see only 29 plugins listed. Downgrading to version
> 2.0.3-1 (from raring/saucy), I see the expected list of 277 plugins.
> Comparing the configure for raring/saucy and trusty the only
> difference I can see is the following, but
>
> raring/saucy: --with-ffmpeg=system
>
> trusty: --without-ffmpeg
>
> I'd be surprised if that is relevant and added to which, the build log
> shows that ladspa is enabled (?!?)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/audacity/+bug/1261654/+subscriptions
>

Adam Nickle (nicklecoder) wrote :

Also, a quick search of the source from github actually shows it searching
in "/usr/local/lib/ladspa", set into the path list in
"src/effects/ladspa/LoadLadspa.cpp". It would be simple to just set this to
the correct path and be done with it.

On Mon, May 26, 2014 at 10:21 PM, Adam Nickle <email address hidden> wrote:

> Would it be terribly difficult to make the search directory configurable?
> It seems like sub-par design to hard code the path. In my opinion, the
> ideal would be to have a configurable list of search paths. That way, if
> the plugins are stored in multiple locations, we can still see them all. Of
> course, this fix is more on the Audacity side of things.
>
>
> On Mon, May 26, 2014 at 8:22 PM, Bug Watch Updater <
> <email address hidden>> wrote:
>
>> ** Changed in: audacity
>> Status: Unknown => New
>>
>> --
>> You received this bug notification because you are a member of Ubuntu
>> Studio, which is subscribed to the bug report.
>> https://bugs.launchpad.net/bugs/1261654
>>
>> Title:
>> missing LADSPA support
>>
>> Status in Audacity:
>> New
>> Status in “audacity” package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> The version of audacity in trusty seems to be missing LADSPA support:
>> under Effects, I see only 29 plugins listed. Downgrading to version
>> 2.0.3-1 (from raring/saucy), I see the expected list of 277 plugins.
>> Comparing the configure for raring/saucy and trusty the only
>> difference I can see is the following, but
>>
>> raring/saucy: --with-ffmpeg=system
>>
>> trusty: --without-ffmpeg
>>
>> I'd be surprised if that is relevant and added to which, the build log
>> shows that ladspa is enabled (?!?)
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/audacity/+bug/1261654/+subscriptions
>>
>
>

Changed in audacity:
status: New → Fix Released
Benjamin Drung (bdrung) on 2014-06-03
description: updated

Hello James, or anyone else affected,

Accepted audacity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/audacity/2.0.5-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in audacity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in audacity:
importance: Unknown → Undecided
status: Fix Released → New
Changed in audacity (Debian):
status: Unknown → Fix Released
James Hunt (jamesodhunt) wrote :

WFM:

- Running audacity 2.0.5-1ubuntu3 on trusty, only plugins 1-12 are shown under the Effect menu with ladspa-sdk installed.

- Running audacity 2.0.5-1ubuntu3.1 on trusty, plugins 1-20 are shown under the Effect menu with ladspa-sdk installed.

- Installing the remaining packages listed in comment #1 displays plugins 1-223 using 2.0.5-1ubuntu3.1.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package audacity - 2.0.5-2ubuntu1

---------------
audacity (2.0.5-2ubuntu1) utopic; urgency=medium

  * Use autotools-dev to update config.{sub,guess} for new arches.
 -- Logan Rosen <email address hidden> Sun, 15 Jun 2014 15:15:40 -0400

Changed in audacity (Ubuntu):
status: Confirmed → Fix Released
Mathew Hodson (mathew-hodson) wrote :
Changed in audacity (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in audacity:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.