Please sync audacity 1.3.2-3 (universe) from Debian unstable (main)

Bug #112606 reported by Emmet Hikory on 2007-05-05
4
Affects Status Importance Assigned to Milestone
audacity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: audacity

Please sync audacity 1.3.2-3 (universe) from Debian unstable (main)

Rationale:
    New Debian version is new upstream version with many enhancements
    New Debain version contains some Ubuntu changes, as follows:
      - Icon transparency
      - use portaudio v19 for ALSA and JACK support
    New Debian version contains alternate patches for Ubuntu changes, as follows:
      - Ship disabled patch for system portaudio (portmixer cannot link against system portaudio)
      - Correct internal name for libmp3lame integration (addresses bug #51063)
      - Do not enable samplerate (as requested by libsamplerate upstream when plugin support is enabled.
    New Debian version contains localisation fixes and other packaging improvements
    New Debian version compiles successfully on gutsy, and works with JACK and ALSA

Additional Debian Changelog:

audacity (1.3.2-3) unstable; urgency=low

  [ Joost Yervante Damad ]
  * Add patch by Joo Martin <email address hidden> to fix installation of
    the locales (Closes: #416864, #422338)
  * Add patch based on work by Mikael Magnusson <email address hidden>
    that enables usage of the portaudio library on the system, however it
    doesn't work, because portmixer doesn't compile against it, soo we're
    not using it yet.
  * Apply changes from #423477 (Closes: #423477)
      - transparent background for icons
      - /usr/share/audacity => /usr/share/pixmaps
  * Look for libmp3lame.so.0 iso libmp3lame.so (Closes: #410516)
  [ Free Ekanayaka ]
  * Add icon for .aup files

 -- Joost Yervante Damad <email address hidden> Sat, 12 May 2007 13:09:13 +0200

audacity (1.3.2-2) unstable; urgency=high

  [Joost Yervante Damad]
  * audacity - FTBFS: error: unrecognized command line option "-msse"
    (Closes: #409255)
    Fixed by building the sse file only with -msse on i386 and amd64 archs
  [ Free Ekanayaka ]
  * FTBFS on GNU/kFreeBSD (Closes: #409260)

 -- Joost Yervante Damad <email address hidden> Fri, 23 Mar 2007 11:00:39 +0100

audacity (1.3.2-1) unstable; urgency=low

  [ Michael Biebl ]
  * New upstream release for GTK2 and ALSA.
  * debian/control
    - Add build-dep on libexpat1-dev, libjack0.100.0-dev, libasound2-dev.
    - Build against libwxgtk2.6-dev. (Closes: #340409, #379616)
  * debian/rules
    - Enable portaudio v19 (ALSA). (Closes: #249157)
    - Enable unicode. (Closes: #298548)
    - Use system expat library.
  * Ship the desktop file provided by upstream, drop
    debian/audacity.desktop.
  * Use debhelper v5 compat mode.
  * Update FSF address in debian/copyright.
  * Update to Standards-Version 3.7.2, no further changes required.

  [ Free Ekanayaka ]
  * Depend on libjack-dev rather that libjack0.100.0-dev, which is now
    obsolete
  * Set Maintainer to Debian Multimedia Team
  * Added Matt and myself to Uploaders

 -- Free Ekanayaka <email address hidden> Tue, 16 Jan 2007 15:53:30 +0100

Emmet Hikory (persia) on 2007-05-05
Changed in audacity:
assignee: nobody → persia
Emmet Hikory (persia) wrote :

Attached is a debdiff against the Debian sources. In building this, the following decisions were taken:

Support for libramplerate was disabled, as the comments in src/Resample.h indicate that the libsamplerate author would prefer that we not distribute audacity with both support for plug-ins and compiled with libsamplerate. I believe that supporting LADSPA and Nyquist plugins provides better service to Ubuntu users. This matches the Debian build.

The portaudio support was built with the supplied libraries, rather than the system libraries, as portmixer requires a patched portaudio to run, and it seems more appropriate to keep a separate portaudio for audacity until upstream portaudio accepts the relevant patches.

Support for JACK was disabled on all architectures other than i386 and ppc, to match the portaudio19 package decision to disable this functionality. The problem is that portaudio does not check the boundaries for memory allocation properly on other architectures, and as a result, audacity will crash if jackd is running when it is launched. As this results in no functional JACK support, support was not compiled in.

Jack support would be great for the end user.

Failing that, enabling portaudio in jackd would be another option.
Either way, it would enable realtime effects in Audacity, which is the
bigger picture!

Will file a usability bug against jack asap.
Thanks for taking the time for Audacity 1.3.2!!! :)
-Toma

On 05/05/07, Emmet Hikory <email address hidden> wrote:
> Attached is a debdiff against the Debian sources. In building this, the
> following decisions were taken:
>
> Support for libramplerate was disabled, as the comments in
> src/Resample.h indicate that the libsamplerate author would prefer that
> we not distribute audacity with both support for plug-ins and compiled
> with libsamplerate. I believe that supporting LADSPA and Nyquist
> plugins provides better service to Ubuntu users. This matches the
> Debian build.
>
> The portaudio support was built with the supplied libraries, rather than
> the system libraries, as portmixer requires a patched portaudio to run,
> and it seems more appropriate to keep a separate portaudio for audacity
> until upstream portaudio accepts the relevant patches.
>
> Support for JACK was disabled on all architectures other than i386 and
> ppc, to match the portaudio19 package decision to disable this
> functionality. The problem is that portaudio does not check the
> boundaries for memory allocation properly on other architectures, and as
> a result, audacity will crash if jackd is running when it is launched.
> As this results in no functional JACK support, support was not compiled
> in.
>
> ** Attachment added: "debdiff for merge"
> http://librarian.launchpad.net/7562248/M112606.patch
>
> --
> Please merge audacity 1.3.2-2 from Debian unstable
> https://bugs.launchpad.net/bugs/112606
> You received this bug notification because you are a member of Ubuntu
> Studio, which is a bug contact for audacity in ubuntu.
>

I've been able to test the changes in a i386 environment, and the JACK interface works just fine. I don't really like how portaudio19 doesn't maintain a persistent connection to JACK, but that cannot be easily fixed within Audacity.

Changed in audacity:
assignee: persia → nobody
status: Unconfirmed → Confirmed
Emmet Hikory (persia) wrote :

A new audacity is released in Debian, significantly reducing the Ubuntu changes.

Changed in audacity:
assignee: nobody → persia
status: Confirmed → In Progress

Description changed to indicate SYNC rather than MERGE. Please do not upload the previously attached debdiff.

description: updated
Changed in audacity:
assignee: persia → nobody
status: In Progress → Confirmed
Emmet Hikory (persia) on 2007-05-13
Changed in audacity:
status: Confirmed → Unconfirmed
Daniel T Chen (crimsun) wrote :

Sync request ACKed.

Changed in audacity:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
description: updated
Martin Pitt (pitti) wrote :

synced 1.3.2-4

Changed in audacity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers